INSTRUCTIONS

OV100
SOFTWARE
IN-VIVO IMAGING SYSTEM

This instruction manual is for the Olympus software of the In Vivo Imaging System OV100. To ensure safety, optimum performance and familiarize yourself fully with the use of the system, we recommend that you study this manual thoroughly before operating the system. Retain this instruction manual in an easily accessible place near the work desk for future reference.
LICENSE AGREEMENT

declare that the software does not contain any viruses, worms, or other similar programs that can cause damage to the software. This warranty does not apply to damages or injuries resulting from the use of the software, or the lack of capabilities of the software, unless the User can show gross negligence on the part of OLYMPUS BIOSYSTEMS. In such cases, the User may file a lawsuit to claim reparations for damages, non-compliance, or losses.

§ 7. Contract duration, legal consequences of violating the license
(1) The contract is deemed to be in force for an unspecified period. The User rights are automatically terminated if one of the conditions of the contracts has been violated.

§ 8. Additional user rights
Only if OLYMPUS BIOSYSTEMS provides the User with permission in written form the User can incorporate parts of the software into other software developed by the User. A distribution of the software can only be made in compiled form as part of the software developed by the User under strict observation of the conditions set forth in the written permission to the User. The User must include with the software:

- the OBS Cell SOFTWARE PRODUCT.
- this LICENSE AGREEMENT.
- the OBS Cell SOFTWARE PRODUCT copyright notification.
- the OBS Cell SOFTWARE PRODUCT documentation.

This LICENSE AGREEMENT has two parts:
I LICENSE AGREEMENT between END USER and Olympus BioSystems regarding the "OBS cell SOFTWARE PRODUCT".
II LICENSE AGREEMENT between END USER and Soft Imaging System regarding the "SOFTWARE PRODUCT".

Part I
LICENSE AGREEMENT between END USER and Olympus BioSystems regarding the OBS cell SOFTWARE PRODUCT.

IMPORTANT-READ CAREFULLY: Below you will find the contractual conditions governing the use of the OBS Cell SOFTWARE PRODUCT. These conditions apply to you, the user, and to OLYMPUS BIOSYSTEMS. With any of the following actions you explicitly agree to be bound by the conditions of this contract: purchasing the software, opening the package, breaking one of the seals or using the software. In case you do not agree with any of the conditions of this contract, please return all parts of the product including manuals and the software protection key before using and without delay. Remove all software installations of the product from any computer you might have installed it on. Return all electronic media of the product or completely destroy all electronic media of the product and send proof that this has been accomplished. For a refund, please return everything to where you purchased the product.

§ 1. Scope
(1) This License agreement explicitly covers only the software diskettes or other media you received with the purchase and the software stored on these media, the manuals, as far as they were developed and produced by OLYMPUS BIOSYSTEMS.

§ 2. User rights
(1) OLYMPUS BIOSYSTEMS permits the User, for the duration of this contract, to use the software on a single computer and a single terminal on that computer. This license is explicitly non-exclusive, i.e., the User does not have an exclusive right to use the software. As a licensed user you can copy the software from one computer to another by using a computer network or other storage devices, as long as it is assured, that the software can only be used on a single computer or terminal at any time and that the conditions set forth under § 4 are observed.
(2) The User has the right to produce a copy of the software only for backup purposes.
(3) The User is authorized to make copies of the software only if these copies are for backup purposes.

§ 3. Additional user rights
Only if OLYMPUS BIOSYSTEMS provides the User with permission in written form the User can incorporate parts of the software into other software developed by the User. A distribution of the software can only be made in compiled form as part of the software developed by the User under strict observation of the conditions set forth in the written permission to the User. The User must include the OBS Cell SOFTWARE PRODUCT copyright notification with the User’s software. The User has to make sure, that OLYMPUS BIOSYSTEMS cannot be held liable for any damages or injuries resulting from the use of the User’s software, that include parts of the OBS Cell SOFTWARE PRODUCT.

§ 4. Copyright
(1) OLYMPUS BIOSYSTEMS or its subsidiaries remain owners of the software and it’s documentation. With the purchase, the User obtains ownership of the diskettes or other physical storage devices (excluding the software and other data contained thereon), the manuals, and the software protection key.
(2) OLYMPUS BIOSYSTEMS reserves the right to all publications, duplication, editing, and marketing of the software and the software documentation. Without prior written permission the User may not:
- change, translate, de-compile or de-assemble the software,
- copy any of the written or printed documentation of the software,
- rent, lease, or license the software to a third party,
- use the software protection different than described in this contract.
(3) The license, property, and user rights to the OLYMPUS BIOSYSTEMS software, disk, and manuals may only be sold or transferred to a third party on a permanent basis, if the third party agrees to abide by the conditions in this contract.
(4) OLYMPUS BIOSYSTEMS is the legal owner of all copyrights and trademarks of the OBS Cell SOFTWARE PRODUCT and documentation. Copyrights and trademarks are protected by national and international law. OLYMPUS BIOSYSTEMS reserves all rights, which are not explicitly expressed in written form.

§ 5. Warranty
(1) OLYMPUS BIOSYSTEMS guarantees for the period of 12 months after the date of purchase, that the software works in all major aspects according to the descriptions in the manuals. OLYMPUS BIOSYSTEMS, as the producer of the software, provides this warranty. It does not replace or restrict other warranties or liabilities provided to the User by local or other sales people or organizations. OLYMPUS BIOSYSTEMS does not guarantee, that the software is defect free, that the software fulfills the specific requirements of the User, or that the OBS Cell SOFTWARE PRODUCT works with other software provided by the User.
(2) OLYMPUS BIOSYSTEMS further guarantees, that the software storage devices (floppy disks, CD-ROMs, etc.) and the manuals are free of material defects. Defective storage devices or manuals will be replaced free of charge, if they are returned to OLYMPUS BIOSYSTEMS within 90 days of purchase and accompanied by a proof of purchase.

§ 6. Liability
(1) OLYMPUS BIOSYSTEMS or their sales organizations cannot be held liable for damages or injuries resulting from the use of the software or the lack of capabilities of the software, unless the User can show gross negligence on the part of OLYMPUS BIOSYSTEMS. This applies, without exceptions, also to losses of productivity or profit, interruptions in the flow of business or manufacture, loss of information, and other financial losses. Without exceptions the possible liability of OLYMPUS BIOSYSTEMS is limited to the amount that the User paid for the product. These limitations on the liability do not influence claims for reasons of product liability.

§ 7. Contract duration, legal consequences of violating the license
(1) The contract is deemed to be in force for an unspecified period. The User rights are automatically terminated if one of the conditions of the contracts has been violated.
(2) In case of a contract violation the User has to return the original storage devices and all copies thereof including all modified copies, all printed and written documentation, and the software protection key to OLYMPUS BIOSYSTEMS, or the User has to destroy these items.
(3) In addition OLYMPUS BIOSYSTEMS reserves the right to file a lawsuit to claim reparations for damages, non-compliance, or removal of the software in case of license violations. The following laws and/or conditions are in effect: the conditions of this contract, the software protection key, the software, and the laws of the civil code.
Part II
LICENSE AGREEMENT between END USER and Soft Imaging System regarding the SOFTWARE PRODUCT

IMPORTANT-READ CAREFULLY: Below you will find the contractual agreements governing the use of this image processing software referred to in the following as SOFTWARE PRODUCT. These conditions apply to you, the user, and to SOFT IMAGING SYSTEM. With any of the following actions you explicitly agree to be bound by the conditions of this contract: purchasing the software, opening the package, breaking of one of the seals or using the software.

In case you do not agree with any of the conditions of this contract, please return all parts of the product including manuals and the software protection key before using and without delay. Remove all software installations of the product from any computer you might have installed it on. Return all electronic media of the product or completely destroy all electronic media of the product and send proof that this has been accomplished. For a refund, please return everything to where you purchased the product.

§ 1. Scope
(1) This License agreement explicitly covers only the software diskettes or other media you received with the purchase and the software protection key, as far as they were developed and produced by SOFT IMAGING SYSTEM.

§ 2. User rights
(1) SOFT IMAGING SYSTEM permits the User, for the duration of this contract, to use the software on a single computer and a single terminal on that computer. This license is explicitly non-exclusive, i.e., the User does not have an exclusive right to use the software. As a licensed user you can copy the software from one computer to another by using a computer network or other storage devices, as long as it is assured, that the software can only be used on a single computer or terminal at any time and that the conditions set forth under § 4 are observed.
(2) The User has the right to produce a copy of the software only for backup purposes.

§ 3. Additional user rights
Only if SOFT IMAGING SYSTEM provides the User with permission in written form the User can incorporate parts of the software into other software developed by the User. A distribution of the software can only be made in compiled form as part of the software developed by the User under strict observation of the conditions set forth in the written permission to the User. The User must include the SOFTWARE PRODUCT copyright notification with the User’s software. The User has to make sure, that SOFT IMAGING SYSTEM cannot be held liable for any damages or injuries resulting from the use of the User’s software, that include parts of the SOFTWARE PRODUCT.

§ 4. Copyright
(1) SOFT IMAGING SYSTEM or its subsidiaries remain owners of the software and it’s documentation. With the purchase, the User obtains ownership of the diskettes or other physical storage devices (excluding the software and other data contained thereon), the manuals, and the software protection key.
(2) SOFT IMAGING SYSTEM reserves the right to all publications, duplication, editing, and marketing of the software and the software documentation.

Without prior written permission the User may not:
 a. change, translate, de-compile or de-assemble the software,
 b. copy any of the written or printed documentation of the software,
 c. rent, lease, or license the software to a third party,
 d. use the software protection different than described in this contract.
(3) The license, property, and user rights to the SOFTWARE PRODUCT software, disks, and manuals may only be sold or transferred to a third party on a permanent basis, if the third party agrees to abide by the conditions in this contract.
(4) SOFT IMAGING SYSTEM is the legal owner of all copyrights and trademarks of the SOFTWARE PRODUCT and documentation. Copyrights and trademarks are protected by national and international law. SOFT IMAGING SYSTEM reserves all rights, which are not explicitly expressed in written form.

§ 5. Warranty
(1) SOFT IMAGING SYSTEM guarantees for the period of 12 months after the date of purchase, that the software works in all major aspects according to the descriptions in the manuals. SOFT IMAGING SYSTEM, as the producer of the software, provides this warranty. It does not replace or restrict other warranties or liabilities provided to the User by local or other sales people or organizations.
(2) SOFT IMAGING SYSTEM further guarantees, that the software storage devices (floppy disks, CD-ROMs, etc.) and the manuals are free of material defects. Defective storage devices or manuals will be replace free of charge, if they are returned to SOFT IMAGING SYSTEM within 90 days of purchase and accompanied by a proof of purchase.

§ 6. Liability
(1) SOFT IMAGING SYSTEM or their sales organizations cannot be held liable for damages or injuries resulting from the use of the software or the lack of capabilities of the software, unless the User can show gross negligence on the part of SOFT IMAGING SYSTEM. This applies, without exceptions, also to losses of productivity or profit, interruptions in the flow of business or manufacture, loss of information, and other financial losses. Without exceptions the possible liability of SOFT IMAGING SYSTEM is limited to the amount that the User paid for the product. These limitations on the liability do not influence claims for reasons of product liability.

§ 7. Contract duration, legal consequences of violating the license
(1) The contract is deemed to be in force for an unspecified period.
(2) In case of a contract violation the User has to return the original storage devices and all copies thereof including all modified copies, all printed and written documentation, and the software protection key to SOFT IMAGING SYSTEM, or the User has to destroy these items.
(3) In addition SOFT IMAGING SYSTEM reserves the right to file a lawsuit to claim reparations for damages, non-compliance, or removal of the software in case of license violations. The following laws and/or conditions are in effect: the conditions of this contract, copyright laws, and the laws of the civil code.
## Contents

### Chapter 1
**Introduction**

1. Introduction ........................................................................................................... 1
   1.1 Abstract ........................................................................................................... 1
   1.2 Technical Support ......................................................................................... 1

### Chapter 2
**System Overview**

2. System Overview ................................................................................................ 1
   2.1 Hardware ....................................................................................................... 1
   2.2 Software ........................................................................................................ 1

### Chapter 3
**Brief Introduction to the Software and First Steps**

3. Brief Introduction to the Software and First Steps ......................................... 1
   3.1 The OV100 User Interface ........................................................................ 1
      3.1.1 The Image Manager ............................................................................. 2
      3.1.2 The Viewport Manager ....................................................................... 5
      3.1.3 The Viewport ....................................................................................... 5
   3.2 Simple Image Acquisition ............................................................................ 6
   3.3 Saving Images – The Database ................................................................... 8
   3.4 Loading Images ........................................................................................... 8
   3.5 Conducting Experiments with the Experiment Manager ......................... 8
   3.6 Displaying Multi-Color Images ................................................................... 10
   3.7 Displaying Sequences ................................................................................. 10

### Chapter 4
**Image Acquisition and Hardware Control**

4. Image Acquisition and Hardware Control ......................................................... 1
   4.1 Simple Image Acquisition ........................................................................... 1
   4.2 Camera Control ............................................................................................ 2
   4.3 Illumination Control ....................................................................................... 5
   4.4 Microscope Control ....................................................................................... 6
   4.5 Motorized Stage Control ............................................................................... 7
   4.5.1 Defining a Positions List ......................................................................... 8
   4.5.2 Correcting a Positions List ..................................................................... 8
   4.5.3 Calibrating the Motorized Stage .............................................................. 11
   4.6 Autofocus ...................................................................................................... 13
      4.6.1 Autofocus options .............................................................................. 13
      4.6.2 Executing an Autofocus Scan ................................................................. 14
   4.7 Atlas Navigator ............................................................................................ 15

### Chapter 5
**Experiment Manager**

5. Experiment Manager .......................................................................................... 1
   5.1 A Graphical Tool .......................................................................................... 1
   5.2 Concept of Usage .......................................................................................... 2
      5.2.1 Experiment Manager Components ......................................................... 2
      5.2.2 Arrangement and Customization ............................................................. 3
   5.3 Setting Up Experiment Plans ......................................................................... 4
      5.3.1 Types of Graphical Icons and the General Principles of Usage .......... 5
      5.3.2 The Command Symbols and Their Properties Pages ......................... 6
      5.3.3 Types of Experiments ........................................................................... 18
   5.4 Conducting Experiments / Data Acquisition .............................................. 25
      5.4.1 Opening a Database .............................................................................. 25
      5.4.2 Executing an Experiment .................................................................... 26
### Contents

#### Chapter 6

**Touching up the image display by brightness, contrast and color adjustment and navigation through multi-dimensional image sets**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.1</td>
<td>1</td>
</tr>
<tr>
<td>6.2</td>
<td>3</td>
</tr>
<tr>
<td>6.2.1</td>
<td>3</td>
</tr>
<tr>
<td>6.2.2</td>
<td>3</td>
</tr>
<tr>
<td>6.2.3</td>
<td>7</td>
</tr>
<tr>
<td>6.2.4</td>
<td>7</td>
</tr>
<tr>
<td>6.2.5</td>
<td>8</td>
</tr>
<tr>
<td>6.2.6</td>
<td>9</td>
</tr>
<tr>
<td>6.2.7</td>
<td>9</td>
</tr>
<tr>
<td>6.2.8</td>
<td>9</td>
</tr>
<tr>
<td>6.2.9</td>
<td>10</td>
</tr>
<tr>
<td>6.2.10</td>
<td>12</td>
</tr>
<tr>
<td>6.3</td>
<td>18</td>
</tr>
<tr>
<td>6.3.1</td>
<td>18</td>
</tr>
<tr>
<td>6.3.2</td>
<td>18</td>
</tr>
<tr>
<td>6.3.3</td>
<td>19</td>
</tr>
<tr>
<td>6.3.4</td>
<td>19</td>
</tr>
<tr>
<td>6.3.5</td>
<td>21</td>
</tr>
<tr>
<td>6.3.6</td>
<td>21</td>
</tr>
<tr>
<td>6.3.7</td>
<td>21</td>
</tr>
<tr>
<td>6.4</td>
<td>22</td>
</tr>
<tr>
<td>6.4.1</td>
<td>22</td>
</tr>
<tr>
<td>6.4.2</td>
<td>23</td>
</tr>
<tr>
<td>6.5</td>
<td>23</td>
</tr>
<tr>
<td>6.6</td>
<td>24</td>
</tr>
</tbody>
</table>

#### Chapter 7

**Basic processing routine like size calibration, overlay drawings, extraction and conversion of image sets**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.1</td>
<td>1</td>
</tr>
<tr>
<td>7.1.1</td>
<td>1</td>
</tr>
<tr>
<td>7.1.2</td>
<td>1</td>
</tr>
<tr>
<td>7.1.3</td>
<td>3</td>
</tr>
<tr>
<td>7.1.4</td>
<td>5</td>
</tr>
<tr>
<td>7.2</td>
<td>5</td>
</tr>
<tr>
<td>7.2.1</td>
<td>5</td>
</tr>
<tr>
<td>7.2.2</td>
<td>6</td>
</tr>
<tr>
<td>7.2.3</td>
<td>6</td>
</tr>
<tr>
<td>7.2.4</td>
<td>7</td>
</tr>
<tr>
<td>7.3</td>
<td>7</td>
</tr>
<tr>
<td>7.4</td>
<td>7</td>
</tr>
<tr>
<td>7.5</td>
<td>9</td>
</tr>
<tr>
<td>7.5.1</td>
<td>9</td>
</tr>
<tr>
<td>7.5.2</td>
<td>9</td>
</tr>
<tr>
<td>7.5.3</td>
<td>10</td>
</tr>
<tr>
<td>7.6</td>
<td>14</td>
</tr>
<tr>
<td>7.7</td>
<td>14</td>
</tr>
<tr>
<td>7.8</td>
<td>15</td>
</tr>
</tbody>
</table>

**6 Image Display and Navigation**

- The Viewport
- Image Display
- General
- Adjust Display
- Auto Adjust Display
- White Balance
- Black Balance
- Gray Scale
- Fluorescence Color
- Edit Fluorescence Color
- False-Color
- Edit False-Color
- Image Navigation
- General
- Multi-Color Images
- Displaying Different Color Bands in the Tile View Mode
- Time-Lapse Sequences
- Z-Stacks
- Multi-dimensional Sequences
- Parallel Navigation in Multiple Viewports
- Projections and Extended Focal Imaging
- Projections Along the Z and Time Axes
- EFI – Extended Focal Imaging
- Fluorescence and Transmission Image Overlay
- Intensity Modulated Display

**7 Image Data Handling**

- Calibrate Images
- Why Calibrate Images?
- Calibrating the Camera Channel
- XY-Calibration
- Z-Calibration
- Scale Bar
- General
- Setting the Scale Bar Properties
- Show in Viewport
- Draw into Overlay
- Show Markers, Time and Z Information
- Grid
- Overlays
- General
- Activating the Overlay Toolbar
- Creating and Editing Overlays
- Separate
- Extract
- Combine
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.8.1 General</td>
<td>15</td>
</tr>
<tr>
<td>7.8.2 Combining Data Sets</td>
<td>15</td>
</tr>
<tr>
<td>7.9 Convert Image</td>
<td>16</td>
</tr>
<tr>
<td>7.9.1 General</td>
<td>16</td>
</tr>
<tr>
<td>7.9.2 To 8-Bit</td>
<td>17</td>
</tr>
<tr>
<td>7.9.3 To 16-Bit</td>
<td>17</td>
</tr>
<tr>
<td>7.9.4 To RGB (3x8-Bit)</td>
<td>17</td>
</tr>
<tr>
<td>7.9.5 Invert</td>
<td>18</td>
</tr>
<tr>
<td>7.10 Image Information</td>
<td>18</td>
</tr>
<tr>
<td>8.1.2 Define Shading Correction</td>
<td>1</td>
</tr>
<tr>
<td>8.1.3 Executing a Shading Correction</td>
<td>4</td>
</tr>
<tr>
<td>8.2 Filters</td>
<td>5</td>
</tr>
<tr>
<td>8.2.1 General</td>
<td>5</td>
</tr>
<tr>
<td>8.2.2 Sharpen I</td>
<td>8</td>
</tr>
<tr>
<td>8.2.3 Sharpen II</td>
<td>8</td>
</tr>
<tr>
<td>8.2.4 Differentiate X</td>
<td>9</td>
</tr>
<tr>
<td>8.2.5 Differentiate Y</td>
<td>9</td>
</tr>
<tr>
<td>8.2.6 Laplace I</td>
<td>9</td>
</tr>
<tr>
<td>8.2.7 Laplace II</td>
<td>10</td>
</tr>
<tr>
<td>8.2.8 Mean</td>
<td>10</td>
</tr>
<tr>
<td>8.2.9 Median</td>
<td>10</td>
</tr>
<tr>
<td>8.2.10 Pseudo Filter</td>
<td>11</td>
</tr>
<tr>
<td>8.2.11 Sobel</td>
<td>12</td>
</tr>
<tr>
<td>8.2.12 Roberts</td>
<td>12</td>
</tr>
<tr>
<td>8.2.13 Reimer</td>
<td>13</td>
</tr>
<tr>
<td>8.2.14 User Filter</td>
<td>13</td>
</tr>
<tr>
<td>8.2.15 NxN</td>
<td>15</td>
</tr>
<tr>
<td>8.2.16 Lowpass</td>
<td>16</td>
</tr>
<tr>
<td>8.2.17 Edge Enhance</td>
<td>16</td>
</tr>
<tr>
<td>8.2.18 Rank</td>
<td>17</td>
</tr>
<tr>
<td>8.2.19 Sigma</td>
<td>17</td>
</tr>
<tr>
<td>8.3 Arithmetic Operations</td>
<td>18</td>
</tr>
<tr>
<td>8.4 Image Geometry</td>
<td>20</td>
</tr>
<tr>
<td>8.4.1 Resize</td>
<td>20</td>
</tr>
<tr>
<td>8.4.2 Rotate</td>
<td>21</td>
</tr>
<tr>
<td>8.4.3 Mirror</td>
<td>23</td>
</tr>
<tr>
<td>8.4.4 Align</td>
<td>23</td>
</tr>
<tr>
<td>8.4.5 Auto Align Z</td>
<td>23</td>
</tr>
<tr>
<td>8.4.6 Apply Shift Correction</td>
<td>24</td>
</tr>
<tr>
<td>8.5 Deblurring and Deconvolution</td>
<td>24</td>
</tr>
</tbody>
</table>
Chapter 9
The software contains a host of measuring tools in a special measurement environment.

Chapter 10
Sophisticated analyses of fluorescence intensities, mostly for time sequences and Z-stacks.

8.5.1 General................................................................. 24
8.5.2 No Neighbor.......................................................... 25
8.5.3 Nearest Neighbors.................................................. 25
8.5.4 Deblurring Images.................................................. 25
8.5.5 Inverse Filter.......................................................... 27

9 Measurements...................................................................... 1
9.1 Measurements Toolbar...................................................... 1
9.2 Drawing Tools for Length and Area Measurements .................. 2
9.2.1 Point................................................................. 2
9.2.2 Touch Count .......................................................... 2
9.2.3 Length ................................................................. 3
9.2.4 Angle................................................................. 5
9.2.5 Area..................................................................... 6
9.3 Magic Wand................................................................. 10
9.3.1 Magic Wand Options................................................. 11
9.4 Results......................................................................... 12
9.4.1 Move Origin............................................................. 12
9.4.2 Create Measurement Sheet......................................... 12
9.4.3 Deleting Measurement Results..................................... 14
9.4.4 Image Link.............................................................. 14
9.4.5 Show/Hide Statistic ................................................... 15
9.4.6 Select Measurements................................................. 15
9.4.7 Define Statistics......................................................... 16
9.4.8 The Preferences ▶ Measure Tab................................. 17

10 Intensity Analyses.................................................................. 1
10.1 Pixel Value..................................................................... 1
10.2 Histogram..................................................................... 2
10.3 Line Profiles: Intensity..................................................... 3
10.3.1 Horizontal Line Profile.............................................. 3
10.3.2 Vertical Line Profile .................................................... 4
10.3.3 Arbitrary Line Profile................................................ 4
10.3.4 Average Intensity of Neighboring Pixels....................... 4
10.4 Regions of Interest – ROIs ............................................... 5
10.4.1 General................................................................. 5
10.4.2 Drawing ROIs.......................................................... 5
10.4.3 ROI Measurements (2-D)........................................... 7
10.5 Background Subtraction................................................ 8
10.5.1 General................................................................. 8
10.5.2 Subtracting the Image Background............................... 9
10.6 Intensity Kinetics in Time and Z....................................... 10
10.7 DeltaF / F (ΔF/F) Analysis............................................. 11
10.7.1 General................................................................. 11
10.7.2 Generating a (ΔF/F) sequence..................................... 12
10.8 Ratio Analysis.............................................................. 14
10.8.1 General................................................................. 14
10.8.2 Generating a Ratio Sequence..................................... 14
10.9 Spectral Unmixing.......................................................... 16
10.9.1 Application ................................................................. 16
10.9.2 The Problem .............................................................. 16
10.9.3 The Solution ............................................................... 18
10.9.4 How Does it Work? ..................................................... 18
10.9.5 Spectral Unmixing with OV100 ..................................... 19
10.9.6 Calibration ................................................................. 20
10.9.7 Unmixing ................................................................. 20

Chapter 11
Analyses of intensity kinetics of fluorescence image time series

11 Graph Display and Graph Analysis ...................................... 1
11.1 Graph Documents .......................................................... 1
11.2 The Graph Window ......................................................... 2
11.2.1 The Cursor: Changing the XY Scaling in the Diagram ...... 3
11.2.2 The Cursor: Measuring Individual Graph Points .......... 4
11.2.3 The Graphs Button Bar ............................................... 4
11.3 The Graph Analysis Menu ............................................... 7
11.3.1 Markers and Labels ...................................................... 7
11.3.2 Protect Graph ............................................................ 10
11.3.3 Delete Graph ............................................................ 10
11.3.4 Graph Information ...................................................... 10
11.3.5 Record Graph History ................................................ 12
11.3.6 Sheet ................................................................. 12
11.3.7 Convert to ............................................................... 15
11.4 Printing Graphs ............................................................. 15
11.4.1 Graphs and Images ..................................................... 15

Chapter 12
Images generated during an experiment are automatically stored in structured databases – analytical data can be added

12 Archiving ........................................................................ 1
12.1 Directories for Data Storage ............................................. 1
12.2 Open Database ............................................................. 2
12.3 New Database ............................................................. 3
12.4 The Database Features ................................................... 4
12.4.1 General Remarks ....................................................... 4
12.4.2 The Database Window ................................................. 5
12.4.3 Adjusting the Database Window .................................. 5
12.5 Working with the Database ............................................. 8
12.5.1 Loading Documents ................................................... 8
12.5.2 Inserting Documents ................................................... 9
12.5.3 Query .................................................................. 10
12.5.4 Administration: Defining Organizational and Database Fields ...... 11

Chapter 13
Setting personal preferences of the software user interface

13 The Special Menu and the Window Menu ............................ 1
13.1 Macros .................................................................... 1
13.1.1 General ............................................................... 1
13.1.2 Record Macro ........................................................ 2
13.1.3 Executing Macros .................................................... 3
13.1.4 Stop Macro Recorder .............................................. 4
13.1.5 Run Macro ............................................................ 4
13.1.6 Single Step ............................................................ 5
13.1.7 Reset Interpreter ..................................................... 6
13.1.8 Set as Default-Macro ............................................... 6
<table>
<thead>
<tr>
<th>Chapter 14</th>
<th>Imaging C</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>14.1</td>
<td>New Module...</td>
<td>2</td>
</tr>
<tr>
<td>14.2</td>
<td>Open Module...</td>
<td>9</td>
</tr>
<tr>
<td>14.3</td>
<td>Add to Module</td>
<td>10</td>
</tr>
<tr>
<td>14.4</td>
<td>Save Module Configuration</td>
<td>11</td>
</tr>
<tr>
<td>14.5</td>
<td>Edit Module...</td>
<td>12</td>
</tr>
<tr>
<td>14.6</td>
<td>Build Module</td>
<td>13</td>
</tr>
<tr>
<td>14.7</td>
<td>Close Module</td>
<td>14</td>
</tr>
<tr>
<td>14.8</td>
<td>About Module...</td>
<td>14</td>
</tr>
<tr>
<td>14.9</td>
<td>Module Manager...</td>
<td>15</td>
</tr>
<tr>
<td>14.9.1</td>
<td>The Define Search Path for Modules Dialog Box</td>
<td>18</td>
</tr>
<tr>
<td>14.10</td>
<td>Browser...</td>
<td>19</td>
</tr>
<tr>
<td>14.11</td>
<td>Find Symbol</td>
<td>21</td>
</tr>
<tr>
<td>14.12</td>
<td>Goto Definition</td>
<td>21</td>
</tr>
<tr>
<td>14.13</td>
<td>Quick Watch...</td>
<td>22</td>
</tr>
<tr>
<td>14.14</td>
<td>Watch Variables</td>
<td>24</td>
</tr>
<tr>
<td>14.15</td>
<td>Toggle Breakpoint...</td>
<td>25</td>
</tr>
<tr>
<td>14.16</td>
<td>Edit Breakpoints...</td>
<td>26</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 15</th>
<th>OV100 Configuration</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>15.1</td>
<td>The Illumination System MT10...</td>
<td>1</td>
</tr>
<tr>
<td>15.1.1</td>
<td>Configuring the Excitation Filters...</td>
<td>1</td>
</tr>
<tr>
<td>15.1.2</td>
<td>Burner Configuration</td>
<td>4</td>
</tr>
<tr>
<td>15.1.3</td>
<td>Using MT10 without the Imaging Software...</td>
<td>4</td>
</tr>
<tr>
<td>15.2</td>
<td>Configuring the Microscope...</td>
<td>4</td>
</tr>
</tbody>
</table>
15.2.1 General Configuration ................................................................. 4
15.2.2 Z-Drive Configuration ................................................................. 5
15.2.3 Configuration of the Objectives ..................................................... 6
15.2.4 Configuration of the Fluorescence Filter Turret ............................ 7
15.2.5 Transmission Contrast Inserts ....................................................... 7
15.2.6 Configuration of the Filters of a Filter Wheel ............................... 8
15.3 Definition of Image Types ............................................................... 8
15.4 Configuration of the Motorized Stage ............................................. 9
15.5 Parfocality Correction of Objectives .............................................. 10

16 Installing the OV100 Software ........................................................... 1
16.1 Updating the OV100 Software to Version 2.3 ................................. 1
16.2 Updating the OV100 Hardware Control to Version 2.3 .................... 3
16.3 Configuring the OV100 Software .................................................... 4
16.4 Single-User Systems (Administrator Users) ..................................... 5
16.5 Multi-User Systems ................................................................. 6
1 Introduction

1.1 Abstract

This manual is the complete documentation necessary for using the Olympus in vivo imaging system OV100 correctly and efficiently.

Special care has been undertaken for this manual to guarantee correct and accurate information, although this is subject to changes due to further development of the imaging system OV100. Thus, the manufacturer cannot assume liability for any possible errors. We would appreciate reports of any mistakes as well as suggestions or criticism.

1.2 Technical Support

If you find any information missing in this manual or you need additional support, please contact your local Olympus dealer.
2 System Overview

The following chapter gives you a short overview of the basic OV100 system components. The system consists of different hardware and software devices, which are full integrated.

2.1 Hardware

The hardware devices of the OV100 in vivo imaging system are listed below:

- Olympus OV100 microscope with motorized mirror unit turret BX-RFAA and motorized observation filter wheel U-FWO.
- Motorized stage
- CCD camera: Monochrome or color high resolution CCD camera, 12 bit or 16 bit data output via IEEE-1394 (FireWire™) interface, selection of sub-frames, and on-chip binning.
- Illumination System MT10, bearing the arc burner (150W Xe or 150W Xe/Hg), the motorized filter wheel (8 positions), attenuator (14 levels) and shutter.
- cell^M System Coordinator for multi-task acquisition.
- Computer: latest generation PC with all standard features, modified for hardware control and peripherals integration, monitor.
- System-specific accessories (filter sets etc.).

2.2 Software

- OV100 Configuration Software to configure the Illumination System MT10.
- OV100 Imaging Software integrating the Experiment Manager for planning and executing experiments, Viewport, Viewport Manager, and Image Manager for managing and displaying the images on the desktop, Image and Graph Analysis tools to analyze the acquired data, and a database for storing and archiving the images.
- OV100 software updates only: Update Software for the cell^M System Coordinator and the MT10 electronics.
3 Brief Introduction to the Software and First Steps

The following sections explain the basic OV100 features and functions. They also introduce the most important terms used in the software and in this manual and thus should help you to get started.

For you to follow the contents of this chapter it is necessary that the system (hardware and software) has been installed and properly configured. For a detailed description of the system installation and configuration read Chapter 15, "OV100 Configuration," of this manual carefully as well as the Hardware Manual, especially Chapter 7, "System Assembly and Adjustment."

3.1 The OV100 User Interface

To start the OV100 software double-click the OV100 icon on your desktop or open it via Start > Programs > OV100.

The screenshot below shows the program's graphical user interface (GUI). It is composed of:

a Menu bar: access to pull-down menus with assorted commands.
b Tool bar: direct access to the most important commands for image acquisition, processing and analysis.
c Status bar: shows the connected CCD camera and displays information depending on the active functions.
d Viewport Manager (top left below button bars): shows a thumbnail of the active image; a red rectangle indicates the current zoomed-in sector of the image in the Viewport. The rectangle can be mouse-dragged across the thumbnail to bring a different area into display.
e Image Manager (underneath the Viewport Manager): consists of two parts:
   - the Operand Box, an operational area to determine source and destination buffers for image processing
   - the Image Buffer Box listing the currently loaded images or graphs. Four tabs are available:
     1 The List View that lists the names, the XY size and the bit depth of the images.
2 The **Gallery View** that shows thumbnails of the images.
3 The **Graph View** that shows thumbnails of loaded graphs.
4 The **Measurement View** that lists the results of area and length measurements in images.

**Documents Area** which always contains:

**Viewport:** displays the active image or a selection of currently loaded images.

**Graph document:** the currently active graph (if a corresponding analysis has been carried out). It is minimized when the software is started.

Additionally the **Documents Area** may contain:

**Database Documents**

**Data Sheets**

**Text Documents** and **Macros**

### 3.1.1 The Image Manager

In the **Image Manager** different image types, like single color images, multi-color images, or the various image sequences (z-stack; time-lapse, etc.), are represented by different symbols.

- Single color image
- Z-stack
- Single color time-lapse
- Single color Z-Stacks in time-lapse
- Multi-color image
- Multi-color Z-stack
- Multi-color time-lapse
- Multi-color Z-Stacks in time-lapse
The highlighted image frame in the Image Manager field is active and displayed in the Viewport Manager and the Viewport.

### 3.1.2 The Viewport Manager

![Image Manager](image.png)

The image in the Viewport manager in the top left corner of the OV100 window shows a red rectangle. It represents the region of the image currently displayed in the Viewport – if the image is zoomed to an extent that is larger than the Viewport. The rectangle is interactive: It can be freely moved within the Viewport Manager to display different areas in the Viewport. It can also be resized by mouse drag to change the zoom factor in the Viewport display.

### 3.1.3 The Viewport

![Viewport](viewport.png)
The Viewport window allows displaying one image or a number of images at the same time. The number of Viewports to be displayed and their arrangement can be set using the **Arrange Viewports** button in the toolbar of the **Image** window. Just mark the columns and rows by moving the mouse cursor over the schematic Viewport which opens with 4x4 image icons symbolizing independent image areas. The maximum number of images that can be shown at one time is 16 (4x4) by default. This setting can be increased to 5x5 as maximum via the **Display Properties**. Right-click on the Viewport Manager to open the **Display Properties** window and change the **Viewport limit** entry accordingly.

**3.2 Simple Image Acquisition**

The most important tools for simple image acquisition are the **Live View** and **Snapshot** buttons and the control boxes that are opened by the **Camera Control** and **Illumination Settings** buttons; all can be found in the **Acquisition toolbar**.

In the following a typical procedure for the acquisition of a fluorescence image will briefly be described. For detailed explanations, see Chapter 4, **Image Acquisition and Illumination Control**. Make sure to select the correct objective and fluorescence filter and place your sample on the stage. The usage of the microscope will not be explained here.

1. Click **Illumination Settings** to open the Illumination System MT control box.

2. Click **Main switch / Burner ON** to ignite the burner. (For a stable light output, wait about 10 min.)

3. Click on one of the **Excitation filter** buttons to select an illumination color.
4. Click **Camera Control** to open the corresponding window. Reasonable starting settings are:
   - **Binning** 2x2
   - **Exposure time** 50 ms
   - **Brightness adjustment** automatic
   These settings have to be adjusted in the course of the working session.

5. Direct the light path of the microscope to the camera. (Of course, focusing can be done via the ocular, but this will not be explained here.)

6. Click **Shutter** in the Illumination System MT control box to illuminate the specimen.

7. Click **Acquire** in the **Acquisition** toolbar or the **Camera Control** window. The following happens:
   - The camera starts acquiring images at maximal speed. None is stored; instead, the newest image overwrites the previous one in the temporary buffer.
   - The current image is displayed in the active Viewport.
   - A single image icon appears in the Image Buffer Box.

8. Focus your sample with the microscope Z-drive using the slider in the **Microscope** window.

9. If necessary, change the **Binning** factor in the **Camera Control** window: 1x1 in order to get highest spatial resolution, larger factors increase the signal intensity at the cost of resolution.

10. Adjust the **Exposure time** for a good signal-to-noise ratio.

11. Click **Snapshot** in the **Acquisition** toolbar or the **Camera Control** window to stop the **Live View**. The very last image is being stored as a Snapshot in the Image Buffer Box and displayed in the Viewport.

12. Click **Shutter** in the Illumination System MT control box to stop the illumination.

13. Save your image as described in the next chapter.

---

Select an empty buffer in the Image Manager if you want to acquire a new image, otherwise the current image will be overwritten and lost: snapshots are only stored temporarily and need to be saved.
3.3 Saving Images – The Database

To save a snapshot in the most basic way select File ▶ Save from the menu bar or use the short cut <Ctrl + s>. The snapshot will be stored in a 16 bit tiff format by default. Other data types can be chosen as usual in the Save Image As window. As with other files, you have to give a name and select the destination (path) of the storage.

OV100 features a database module for the storage of images and entire experiments including Experiment Plans, data sets, analyses and so on. The module is explained in detail in Chapter 12, Archiving.

The command Open Database... to load an existing one can be found redundantly in the menus File, Acquisition and Archiving. Database files carry the extension *.apl. New databases can be created with the command New Database..., to be found in the same menus.

In order to be able to store your images in the database, first you have to create an experiment folder via Archiving ▶ Insert ▶ Experiment... (or use an existing one). To store an image in the database just drag it from the Image Buffer Box into the experiment folder. You will be asked in a dialog box to give it a name.

Images acquired via the Experiment Manager will be stored automatically in a database.

3.4 Loading Images

To load images that are not stored in a database and to display them in the Viewport use the command File ▶ Open (short-cut <Ctrl + o>) or click on the Open button in the toolbar. As usually you have to navigate to the storage folder of the file and select it.

Open the experiment folder in the database to load an image or an image sequence from it (see previous chapter 3.3). In the Structure Strip on the left hand side of the database window you will find the Image Icon and in the Gallery Field – the Image Thumbnail. Drag either the icon or the thumbnail into the Viewport or the Image Manager to load the image set.

3.5 Conducting Experiments with the Experiment Manager

In general, most imaging applications in life science are rather complex and go beyond taking simple snapshots, for example, multi-color imaging, time-lapse imaging, ion imaging with
ratiometric fluorescence dyes, multi-dimensional imaging, etc. The OV100 Imaging Software includes the Experiment Manager, an easy-to-use and intuitive tool to plan, configure and execute even the most complex experiments without any programming knowledge. The Experiment Manager is explained in every detail in chapter 5. In the following only a brief introduction will be given.

To open the Experiment Manager click the Experiment Manager button in the acquisition toolbar. Experiment Plans are set-up by assembling and connecting diverse command icons and frames. The most frequent ones can be selected via buttons in the Standard Command toolbar and placed into the editing area by drag&drop.

---

**Image Acquisition, Multi-Color, Z-Stack, Time Loop and Stage Frame**

A Properties page to specify certain settings accompanies each command icon that is placed into the editing area. In case of Image Acquisition, for example, parameters such as exposure time and excitation filter have to be set.

The scheme below is just one example of an experiment plan. It shows the command icons that define a multi-color time-lapse experiment. There are three Image Acquisition icons, each with a different excitation filter, surrounded by a multi-color frame for combination of the three Image Types (monochrome images) to one multi-color image. The outer frame represents a Time Loop to repeat all commands contained a certain number of times.

The Experiment Manager is not only a tool to design the experiments, but also the command center to acquire the images according to the Experiment Plan. The necessary icons are grouped in the Control Center toolbar.

---

**Check!, System Ready!, Start!, Pause and Stop**

The execution of an Experiment Plan involves three steps:

1. **Check!**: The system verifies if the execution of the Experiment Plan is feasible or if there are invalid parameters or logical faults.

2. **System Ready!**: The Experiment Plan is downloaded to the Real-Time Controller and data storage space is allocated on the hard disk.

3. The experiment itself is started, paused and stopped with **Start!**, **Pause**, and **Stop**.
Any image or image sequence acquired with the Experiment Manager is automatically stored on the hard disk in a OV100 database.

### 3.6 Displaying Multi-Color Images

Multi-color OV100 images consist of several color channels – in principle the number is unlimited. Each channel contains a monochrome image of predefined color resulting from one Image Acquisition command in the Experiment Plan. When loaded from an archive all color channels are displayed together in an overlay resulting in a color image. The **Select Color Channel** button in the Navigation toolbar provides a tool to navigate easily through all color channels and to display selected ones.

Adjusting the single color intensities with the dialog box of the **Display Intensity** command can optimize the look of the multi-color image. For details, see Chapter 6.2.2, Adjust Display.

### 3.7 Displaying Sequences

Time-Lapse experiments and Z-stack acquisitions generate series of images that are all stored together within one file. The individual images can be accessed with the navigation buttons.
(First, Previous, Next, Last) in the Navigation toolbar. The number in the Go To field represents the actual frame displayed in the Viewport.

An additional feature enables the user to animate image sequences and play it as a movie. Pressing the Animate button opens the Animate Image Stack window.

Here you find the buttons to start (Play) the animation, to Stop it and to play it in the Reverse mode.

Reverse, Stop and Play buttons:

For a detailed description of the navigation tools see Chapter 6.3, Image Navigation.
4 Image Acquisition and Hardware Control

The following chapters explain how snapshots or live images can be taken, what camera parameters have to be adjusted for good quality and how the illumination system with the excitation filters and the motorized parts of the microscope can be used.

4.1 Simple Image Acquisition

There are two ways to achieve simple image acquisition. The first one is the acquisition of a single image with the Snapshot button in the Acquisition toolbar or the Camera Control (or Acquisition → Snapshot). The second one is the live view started with the neighboring Live View button (or Acquisition → Live). Here the displayed image is updated continuously (and the previous image discarded). The Live View image display is stopped by pressing the Snapshot button (or the Esc key); thus a final snapshot is taken, which remains in the image memory.

OV100 uses the current camera control and display settings for image acquisition. It remembers the settings from your last session after program shut-down and restart. Please be aware that in case the properties of your object (dye, intensity, background etc.) have changed significantly, it might be necessary to adjust the camera control and display settings accordingly before you can see a reasonable image. This is explained in the following chapters.

The following settings should be checked or corrected before the image acquisition is started:

- Exposure time (Camera Control)
- Binning factor (Camera Control)
- Brightness adjustment (Camera Control)
- Image size, i.e., full frame or area of interest/partial frame (Camera Control)
- Excitation filter (Illumination Control)
- Light intensity (Illumination Control)
Snapshots are not being stored automatically and are lost upon exiting the software unless saved via File > Save (or Save as...) or Database > Insert > Image... (See Chapter 5.4.3, Data Storage.)

4.2 Camera Control

The Camera Control button (or Acquisition > Camera settings...) opens the window to set the acquisition parameters Exposure time, Binning factor and Subframe as well as the principal image display parameters. The Camera Control window can be moved freely across the screen. The OV100 Imaging Software provides the unique possibility to change all the above mentioned parameters during Live View, which makes it very convenient to adjust the acquisition for each experiment.
**Snapshot**, **Live View**

The Camera Control window contains the same **Snapshot** and **Live View** buttons as the Acquisition toolbar described in Chapter 4.1, *Simple image Acquisition*.

**Binning**. The CCD chip is composed of many light-sensitive units (pixels). These pixels can be read out individually (binning = 1x1) or the signal of neighboring pixels can be combined electronically on the CCD chip (binning > 1x1). Binning reduces the spatial resolution but increases the sensitivity and thus reduces the exposure time required for a good signal-to-noise ratio. It further reduces the amount of data and consequently increases the readout speed. Therefore binning is recommended if weak signals have to be detected at high acquisition rates or if spatial resolution is of minor importance.

**Exposure Time**
The exposure time determines the period of time during which the CCD-chip is sensitive to incoming light, in other words, during which photons are collected and converted into charges to be read out afterwards. The exposure time can be changed by 1 ms increments using either the slider or the mouse scroll wheel or by directly typing the value into the **Exposure time** window.

**Adjust with binning.** This feature automatically adapts the exposure time if the binning is changed. (See also: [http://www.olympus-europa.com/medical/39_MicroGlossary.cfm?buchstabe=1&amp;app_id=97](http://www.olympus-europa.com/medical/39_MicroGlossary.cfm?buchstabe=1&amp;app_id=97)).

**Standard Tab**

**Brightness adjustment**
After a snapshot acquisition or during live view the image on the monitor is displayed in gray scale according to the current **Brightness adjustment**. You have the possibility to change the brightness of the displayed image manually with the **Min.** and **Max.** sliders or to use the **Automatic** adjustment.

For further optimization you can adapt the intensity clipping **Min. %** and **Max. %**, respectively representing the percentage of the darkest and brightest pixels which are set to black (value of 0) or white (value of 255) and are not scaled linearly by the automatic adjustment. The effect of the brightness adjustment can be viewed directly in the **Live View** mode.

> If an image appears either too dim or too bright make sure to control the minimum and maximum intensities in the **Min** and **Max** field before judging that the exposure time is respectively too short or too long. The appearance might be due to improper settings if the **Automatic** option is deselected.

**Online histogram.** This option opens the **Histogram** window that allows judgment of the intensity distribution in live images at a glance.

**Subframe**
OV100 offers the possibility to readout only a sub-frame instead of the entire image captured by the camera (around 1376x1024 pixels in standard CCD cameras). The size of readout frame can be customized by moving the slider at each side of the frame that represents the field of view of
the camera. The advantage of sub-frame readout is a reduced amount of data and an increase in possible acquisition speed (with most cameras, an exception is the VF2T).

**Define.** It is very convenient to define the sub-frame via a region-of-interest either in snapshots or live images. When the button is clicked, a rectangle drawing tool appears in the Viewport. It can be moved freely and the size can be adjusted via mouse drag. A right-click defines the ROI and the sub-frame settings are set accordingly in the **Camera control** window.

**Reset.** This function sets the readout back to full frame; it is also possible to double-click on the frame selection area.

**Extended Tab**
The availability of the functions on this tab depend on the camera.

**Gain.** The gain factor in CCD imaging defines how many photon-generated electrons of each individual CCD pixel are converted into one intensity count by the A/D converter. Usually the system gain is set so that with gain factor 1 the full well capacity matches the full range of the converter. With a gain factor larger than 1, fewer electrons are converted into one count causing the image brightness to increase – and the noise as well. Set the value by using the slider or type in a number.

**Offset.** Images captured by CCD cameras usually have a certain offset, that means, even pixels of images taken in the absence of light and with the shortest possible exposure time (where any possible dark current does not come into play) have a set intensity larger than 0. Often it is around 128 counts. The **Offset** option allows to automatically subtract the value set in the **Offset** box from each pixel intensity. Set the value by using the slider or type in a number.

**Color control.** These functions are available for color cameras only.

**R**, **G** and **B** gain values. These functions are available during Live View image acquisition only and allow to set the gain value for each color individually to adjust the color balance. Set the values by using the **R**, **G** and **B** sliders or type in the numbers.

**White Balance.** This function is available for color cameras only. It is primarily useful in brightfield imaging to provide accurate color rendition regardless of illumination variations. Upon clicking the button, a snapshot is taken automatically, the color balance is analyzed and the appropriate color adjustments are being conducted (the **R**, **G** and **B** gain values are changed). Finally, another snapshot is taken using the new settings.

**WBalance ROI.** For many specimens, better white balance adjustment may be achieved by manually selecting a white or neutral gray area for reference within the specimen image area. Clicking on the button allows to set a region-of-interest first. Once this is done, the color adjustments are carried out as described above.
4.3 Illumination Control

Illumination Settings

To adjust the parameters of the illumination, open the control window with the Illumination Settings button (or via Acquisition → Illumination settings...). The Illumination system MT window can be moved freely across the screen to your convenience.

Main switch: In this control window you find the Main switch Burner ON / OFF button to ignite the arc burner or switch it off again. At the front of the Illumination System MT10 housing the green LED labeled BURNER ON indicates that the burner is turned on.

Shutter. The shutter can be opened and closed by pressing the Shutter button to start and stop the fluorescence illumination of the microscope.

Excitation filter buttons. The Illumination System MT10 has a built-in filter wheel with eight positions for different excitation filters. To select a specific excitation filter click on the respective button. The color of the buttons and their connection with the respective excitation filters and filter positions in the MT10 is set in the OV100 Configuration Software (see Chapter 15, OV100 Configuration).

Intensity. The MT10's built-in attenuator controls the brightness of the illumination. 14, respectively seven levels are available between about 1% and 100%. The intensity can be adjusted by moving the Intensity slider. Once this is active after a mouse click, it can be moved by the scroll wheel of the mouse as well.
Information field. In the lowest part of the window you find information about the Burner type. The Burner hours counter tells you for how many hours the burner has already been used. A bright green circle behind Burner indicates that the burner is on, otherwise it is dark green. Similarly, a bright or dark green circle behind Sample illumination indicates that the shutter is open or closed. This information field can be closed to save space on the screen and reopened again by pressing the arrowhead on the top right corner.

4.4 Microscope Control

The OV100 Imaging Software features a module for the easy control and efficient usage of the automated OV100 microscope. Its use will be described in this chapter. Use the Microscope Control button to open the Microscope dialog window that allows full electronic control of the OV100 microscope.

The Microscope dialog window renders a permanent status overview of the microscope (indicated by the icons of the toggle buttons and by the optical elements listed in the boxes) that is updated several times per minute. Thus, if changes are made by the user directly at the microscope the dialog box will display these changes.

Focus. A slider control for adjusting the Z-position is displayed together with the current position. There are different ways to use the slider:

- The slider can be dragged.
Once the slider is activated after a mouse click, it can be moved with the scroll wheel of the mouse as well.
- Clicking above or below the slider and keeping the left mouse button pressed moves the drive quickly up, respectively down.
- Clicking on the up or down arrow and keeping the left mouse button pressed moves the drive slowly up, respectively down.

**Escape.** Click on this button to move the stage to the bottom (Escape) position.

**Magnification.** Select the magnification by clicking on one of the buttons. The corresponding objective will be moved into position. If the zoom objective is selected, the zoom slider can be used to set the magnification.

**Aperture.** This function is available only if the zoom objective is selected. The slider allows to set the aperture in steps from 1 to 6. A larger aperture reduces the resolution but allows shorter exposure times.

**BF Lamp on / off.** Use this toggle button to switch the transmission lamp on and off. Moving the slider changes the transmission light intensity.

**Image Type** buttons. A click on one of the Image Type buttons automatically selects the MT10 excitation filter, the mirror unit and the emission filter connected with the selected Image Type into position (see Chapter 15.3, *Definition of Image Types*).

### 4.5 Motorized Stage Control

The OV100 Imaging Software features a module for the easy control and efficient usage of the motorized microscope in imaging experiments via the Experiment Manager (see also Chapter 5.3.2.5, *The Stage Frame*, and Chapter 5.3.3.8, *Experiments with image acquisitions at different stage positions*). While simple movements of the stage are conveniently done via joystick, automated experiments require position lists. This chapter describes how to define these and how to calibrate the stage.

Proper operation of the stage via software is only possible if the stage is calibrated. See Chapter 4.5.3 for details.

If the OV100 software is started without the MSCB control box being switched on, the following error message will appear as a reminder to switch it on.
Once the MSCB is switched on, the following error message will appear as a reminder to initialize the stage.

4.5.1 Defining a Positions List

A click on the **Motorized Stage** button opens the **Stage** dialog window. The last **Positions** list used will be loaded automatically and can be modified at will. To create a new one, select **<New List>** from the short list. To load an existing list, select it from the shortlist. To delete a list, load it and then click **Delete**.

To add stage positions to the list, move the stage to the desired position using the joystick, focus and click **Add**.
Positions can be deleted, copied and pasted with the usual MSWindows commands and moved within the list via <Alt + up/down>. Once the list is complete, type in a name in the List box and click Save. All positions list are saved in one file called OBSPOSLISTS.XML in the OV100 folder.

To move the stage to one of the positions in the list, select the position via mouse click, then click Go to – or simply double-click the position.

4.5.2 Correcting a Positions List

It is possible to automatically correct all positions of an existing positions list. This may be convenient if a focus drift is observed, if the microscope was shaken causing the sample to move or if a sample was removed and is put back onto the stage. Corrections can be carried out in the XY plane and in Z.

Lateral List Correction.
If there were a lateral shift of the sample on the stage, you can correct the list by doing the following:

1. Go to any list position and correct the position of the stage.

2. Right-click the position in the list to open the context menu and select Lateral List Correction.

3. A message like the following will appear:

   ![Message](image)

   Click Yes and the X and Y coordinates of all positions in the list will be adjusted by the amounts given in the message.
Focus List Correction.
If you observe a focus drift, do the following:

1. Go to any list position and correct the focus.

2. Right-click the position in the list to open the context menu and click **Set Current Position As Reference**.
   A green letter R will appear to the left of the position number in the list and the command **Focus List Correction** in the context menu will become enabled.

```
<table>
<thead>
<tr>
<th>0</th>
<th>-45025.5,  -37290,  6264.31</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>5</td>
<td>-47914.5,  -35775,  5729.53</td>
</tr>
</tbody>
</table>
```

3. Upon executing the command **List Correction** a message like the following will appear:

   ![Message](image)

4. Click **Yes** and the Z coordinates of all positions in the list will be adjusted by the amount given in the message.

Correction of a tilt of the sample
If the sample is tilt relative to when the positions list was defined, a simple focus correction will not help. In that case setting three reference points defines a reference plane. With the help of this plane the software determines individual focus corrections for each position in the list.

1. Go to any list position and correct the focus.

2. Right-click the position in the list to open the context menu and click **Set Current Position As Reference**.
   A green letter R will appear to the left of the position number in the list.

3. Define two more reference positions by repeating steps 1 and 2 at two other positions in the list.

```
<table>
<thead>
<tr>
<th>R</th>
<th>2</th>
<th>-44312.5,  -39490,  6670.21</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>3</td>
<td>-49875.5,  -37290,  6264.21</td>
</tr>
<tr>
<td>R</td>
<td>4</td>
<td>-45837.5,  -35775,  5729.53</td>
</tr>
</tbody>
</table>
```

4. Execute the command **Focus List Correction** in the context menu. A message like the following will appear:
5. Click Yes and the Z coordinates of all positions in the list will be adjusted by the amount given in the message.

4.5.3 Calibrating the Motorized Stage

In case the Stage dialog box does not show the calibration commands, click on the button with the arrowhead pointing downwards in the bottom right corner. Loading an existing positions list to use it anew is only practical if it is known where the origin of the coordinate system was set at the time the list was generated. If, for example, the same slides are used routinely, it is commended to set the origin always at the same spot on the slide.
Set Origin. Upon clicking this button the current stage and Z-device position will become the origin of the coordinate system with the X/Y/Z values 0/0/0. The red status box Not calibrated turns green and states Calibrated.

Auto Calibrate. Upon clicking this button the stage will always move to a certain corner position and set this as origin of the coordinate system. The red status box Not calibrated turns green and states Calibrated.

Set Limits. This command opens the Stage limits window. If no limits have been set previously the four limit position buttons will be marked by a blue question mark. To set limits, move the stage with the joystick, for example, to the leftmost position of your sample and click X. The blue question mark will disappear. Once all four limits are set, a green cross appears in the center of the four buttons. A red dot indicates the current stage position.

Any position in the positions list outside the limits will be labeled with a red diamond symbol. A reference position outside the limits will be labeled with a red R.

In order to widen the limits so that all positions in the list remain in bounds, right-click the positions list to open the positions list context menu and select Adapt Corner Limits.

The limits do not affect the function of the joystick. However, the Experiment Manager checks if all positions in the selected list are within the limits. Otherwise a warning message is generated.
4.6 Autofocus

The Autofocus function automatically finds the mounted specimen by acquiring images at different Z-positions and analyzes the focality (sharpness) of the image contents. The time required for the Autofocus to find the focus depends on the Autofocus options settings (see below) and the distance of the focus from the starting position. The focal position may not be found if the signal-to-noise ratio is too low, in other words, the camera settings Exposure time and Binning, see Chapter 4.2, Camera Control. Also, quite obviously, the focus cannot be found if it is outside the set range.

The Autofocus is a two-step procedure. First an Autofocus scan is performed according to the settings and analyzed. The found focal position will be used as reference position for a second Autofocus scan that uses a finer step size to improve the focus. The resulting position of best focus will be used as focal position.

4.6.1 Autofocus options...

Range. Set here the range of Z-positions to be scanned during the Autofocus process in the Autofocus normal mode (see below). The range is centered around the current Z-position. The narrower the range is, the shorter will be the time required for the Autofocus scan to finish. However, the focus cannot be found if it is outside the range. Thus, a certain cautiousness is necessary when setting the range.
**Big Step.** Set here the step width to be made between neighboring Z-positions during the first of the two **Autofocus** scans. Whenever the **Range** is newly set, a default step size is being set in dependence of it.

**Fine Step.** Set here the step width to be made between neighboring Z-positions during the second of the two **Autofocus** scans. Whenever the **Range** is newly set, a default step size is being set in dependence of it.

**Use entire range.** If this box is NOT checked, the following will be done: if the focality initially increases during an **Autofocus** scan and then worsens again, the process will be terminated and the found focality maximum will be set as reference position for the second, finer, scan. If the box is checked, however, the process will not be terminated after a local focality maximum is determined, but the entire range will be examined. Obviously, this causes the **Autofocus** scan to last longer, but reduces the possibility that a wrong focal position is being detected.

**Display.** If this option is checked, online images of the **Autofocus** scan will be displayed.

**Use ROI.** In case of thicker specimens it may be that structures are brought into focus that are not the ones of interest for the user. In such a case an ROI can be defined that will be considered exclusively in the focality analysis of the **Autofocus** scan. If the option is activated and one clicks the **Autofocus** button to execute an **Autofocus** scan, first a red rectangular ROI drawing tool will appear in the active image to enable the user to define an autofocus ROI via mouse drag and confirmation with a right click (compare Chapter 10.4.2, **Drawing ROIs**). Once this is done, the **Autofocus** scan will be carried out automatically.

**Low Signal mode.** If this option is checked, a Mean filter (see Chapter 8.2.8) will be applied on each image before evaluation of the sharpness.

### 4.6.2 Executing an Autofocus Scan

First of all, an **Autofocus mode** needs to be selected from the **Autofocus** button shortlist. The selected mode will be executed upon clicking the **Autofocus** button. To stop the autofocus scan, click the **Autofocus** button again. If the **Use ROI** option in the **Autofocus options** is active, an ROI has to be defined before the **Autofocus** scan is carried out (see previous chapter).

**Autofocus normal.** In this mode, the **Range** and **Step** parameters set in the **Autofocus options** (see previous chapter) are used. This is the default mode and mostly the one of choice if a sample is newly placed onto the microscope and is found to be totally out of focus.

**Autofocus fine.** In this mode, the range set in the **Autofocus options** (see previous chapter) is divided by three and the step size adjusted by default. This mode can be used if the sample is already relatively close to the specimen. In this case the settings of the **Autofocus normal** mode would probably first move the specimen way out of focus and it would cause an unnecessary
loss of time to bring it back into focus again. With the **Autofocus fine** mode, the user does not have to reduce manually the range in the **Autofocus options**.

**Autofocus very fine.** In this mode, the range set in the **Autofocus options** (see previous chapter) is divided by five and the step size adjusted by default. Similar arguments as for the **Autofocus fine** mode apply. The **Autofocus fine** mode can be useful, for example, if a slight loss of focus is caused due to a movement of the specimen with the microscope stage.

### 4.7 Atlas Navigator

**Atlas Navigator button**

The Atlas navigator is a tool to interactively move the XY-stage via mouse drag in a live image window and to change the magnification. A click on the **Atlas Navigator** button (or executing the **Acquisition** → **Atlas Navigator** command) opens the **Atlas Navigator** window that displays images acquired in **Live Image** mode. Clicking the **Atlas Navigator** button again or closing the window stops the image acquisition.

**Move Mode**

Click this button to start the **Move** mode. Drag the mouse across the live image to move the stage correspondingly. The update of the screen may take a few instants depending on the settings in the **Camera Control** window (see Chapter 4.2, **Camera Control**). A right click opens a context dialog that allows to toggle between **Move** and **Zoom** modes.

**Zoom Mode**

Click this button to start the **Zoom** mode. To zoom in click into the image at the position that shall be the center of the next view. The stage will be moved accordingly and the objective with the next higher magnification will be moved into position. This takes several seconds. The camera continues acquiring live images in the meanwhile but the illumination will be switched off during the changes. To zoom out click into the image at the position that shall be the center of the next view while keeping the **Ctrl** key pressed. If the zoom objective is selected, the magnification will be changed in steps of 1.6 units (between 1.6x and 16x). A right click opens a context dialog that allows to toggle between **Move** and **Zoom** modes.
Previous View

Click this button to undo the previous stage movement or magnification change (whatever was done last). This button becomes active only after at least one Move or Zoom command was carried out.

Next View

Click this button to redo the previous stage movement or magnification change (whatever was undone before). This button becomes active only after at least one Undo step was carried out.

Full Screen

Click this button to increase the Atlas Navigator window to full screen.

Close Full Screen

Click this button to switch the Atlas Navigator window back from full screen display to normal size..
5 Experiment Manager

The Experiment Manager is a universal and easy-to-use tool for planning, preparing, and executing experiments with the Imaging Station OV100. This chapter explains the general concept of setting up experiments, lines out how the different system modules are integrated into experiments, describes different types of experiments and guides through the system preparation and the execution of experiment.

5.1 A Graphical Tool

The Experiment Manager is a universal and easy-to-use tool for planning, preparing, and executing experiments with the in vivo imaging system OV100.

Planning an experiment:
Your experiment may, for example, require capturing fluorescence images of a multi-labeled sample and to display and archive them as composite multi-color images. Or it may be more complex and involve acquisition of precisely timed image sequences in multiple fluorescence channels and on multiple focus levels. With the Experiment Manager any such experiment can be defined in an easy graphical way by setting up an “Experiment Plan”. Once defined, an Experiment Plan can be saved as an independent file. Each user can thus define their own set of Experiment Plans for repeated experimental runs. Experiment Plans can be transferred and executed on any other OV100 imaging station, however, if the system configurations differ certain changes might be required. Also, the plans are stored together with the image data in the database after execution of an experiment.

Preparing an experiment:
Depending on the variability of your samples, it may be necessary to individually adjust certain parameters of an Experiment Plan for each sample; for example, it might be necessary to optimize the exposure times according to the quality of the staining. Such parameters are variables in an Experiment Plan and can be changed easily.

Executing an experiment:
The same Experiment Plan can be executed as often as necessary. During execution of an experiment the acquired images can be displayed live on the monitor allowing online observation of the sample in one or several fluorescence channels. User interference during experiment
execution is possible via the Experiment Manager’s control field: The experiment may be paused / continued or stopped. It is also possible to interactively set markers, for example, to indicate external events such as the application of an agonist to the sample.

Data storage:
The images acquired during an experiment are automatically sorted, arranged and transferred to a structured database from where they can be easily retrieved.

5.2 Concept of Usage

Open the Experiment Manager with the Experiment Manager button in the toolbar or via the menu Acquisition ▶ Experiment Manager.
Close the Experiment Manager in the same way or with the Close button or via the menu File ▶ Close in the Experiment Manager window. The Experiment Manager always opens in the state and configuration in which it has been closed the last time.

5.2.1 Experiment Manager Components

The Experiment Manager consists of different components used to configure the different stages of an experiment (planning, preparing, executing). In the default configuration of the Experiment Manager these components are arranged in the following way:

The Experiment Manager window – in the default settings – consists of the following elements:
5.2.2 Arrangement and Customization

5.2.2.1 Opening and closing components

The two Command toolbars, the Properties page and the Control Center field can be closed via the View menu independently from each other. The open state is indicated by a tick mark in the list of components. The properties page can also be closed by clicking on its "x" button in the top right corner.

5.2.2.2 Detaching and repositioning components

It is possible to detach the toolbars and the property page from the Experiment Manager’s window and position them anywhere on the screen or to re-arrange them according to your personal preferences within the Experiment Manager’s main window.

To detach a toolbar point with the mouse tip on the double line at its left side and drag&drop it to the new position. To detach the properties page click on its title bar and than drag&drop it to a new position. Afterwards the size of the new independent toolbar window or properties window has to be adjusted via mouse drag.

To reposition a detached component to the original location double-click on the title bar or drag&drop the window back into position.

5.2.2.3 Minimizing the Experiment Manager

The Experiment Manager window can be minimized with the standard MSWindows Minimize button or by clicking on the Experiment Manager button in the OV100 toolbar or in the MSWindows task bar. This is often desirable during image acquisition or experiment execution when the monitor space is required for the display of images in the Viewport. The Experiment Manager window can be reopened by pressing the Experiment Manager button in the OV100 toolbar or the MSWindows task bar again.
Closing the Experiment Manager instead of minimizing it will not cause the loss of the plan; it will reappear upon opening the Experiment Manager again.

5.2.2.4 Minimized view: The OV100 Execution Center

Minimize and Maximize button

The OV100 Execution Center, accessible via View ▶ Execution Center, <Ctrl+e> or the Minimize button, is a minimized version of the Experiment Manager window that features only the Control Center button bar, the Maximize button and the status bar. These are the only components that may be of use while an experiment is carried out. However, they are not available if the entire Experiment Manager is minimized. The OV100 Execution Center is especially useful during experiments with online display of images because the Experiment Manager window blocks a large area of the screen. Click on the Enlarge button on the right side to re-enlarge the view.

5.3 Setting Up Experiment Plans

To set up new experiments you can either change an existing Experiment Plan or start from scratch with an "empty" editor surface. To obtain an empty editor surface use the Experiment Manager menu File ▶ New. If the current Experiment Plan has not yet been saved a dialog will appear asking whether it should be saved. Experiment plans are set up in a simple graphical manner without the necessity of any programming knowledge. Icons that symbolize commands or series of commands have to be placed, ordered and connected on the editor surface and certain parameters have to be set in context sensitive Properties pages; either by typing in values or by reading in current settings from the OV100 software.
5.3.1 Types of Graphical Icons and the General Principles of Usage

(Standard) icons to drop: ![icon1] ![icon2] ![icon3] ![icon4]
Frames to drag: ![frame1] ![frame2] ![frame3] ![frame4]

There are two types of buttons in the Standard Commands and Additional Commands toolbars to be used when setting up an Experiment Plan: one sort serves to place command icons into the editing surface and the other enables dragging command frames around groups of icons.

To place a drop icon activate the respective button via mouse click and place it on the editor surface by clicking at its designated position. Frames are used to encircle one or more icons – similar to a bracket in a mathematical function. To draw a frame activate the button and click in the designated top left corner and then drag the frame towards the designated bottom left corner.

When a new icon is placed or a frame drawn the corresponding Properties Pages opens immediately. This will be explained in detail in the following chapters. The blue squares on the left and right side of (inactivated) icons and frames are connection nodes; their use is explained below. Frames and icons can be activated via mouse click. Activation is indicated by a thick black frame as shown on the right side of the following image:

**Image Acquisition**, deactivated (left) and active (right): ![image1] ![image2]

Icons can simply be moved by drag&drop. Frames can be enlarged or diminished by dragging the black knots at the corners and sides that appear upon activation. Both can be deleted by activation via mouse click and Edit > Cut or by pressing the Del key. They can be copied and pasted via Edit > Copy and Edit > Paste or <Ctrl+c> and <Ctrl+v>.

In order to generate an unequivocal Experiment Plan the icons and frames have to be interconnected to give the order of execution of the commands. To specify the sequence connect the blue connecting node (arrow head) on the right side of a command symbol with the blue node on the left side of the successive one. When pointing with the mouse tip over a right-sided connection node the mouse tip turns from an arrow (or the symbol you selected in the MSWindows settings) into a cross. Press the left mouse button, drag the mouse tip to the blue arrow head on the left side of the successive command icon and release the left mouse button. The two commands are now connected with an arrow indicating the succession of the commands; see the image below. Arrows can be deleted after activation as above.

The time axis within Experiment Plans runs always from left to right, i.e., commands cannot be connected from right to left (that is, from a left-sided blue node to a right-sided one).
If a command symbol is activated connections cannot be drawn, the mouse tip does not turn into a cross. To deactivate a symbol click on an empty area of the editor surface.

In a valid Experiment Plan all commands need to be connected.

5.3.2 The Command Symbols and Their Properties Pages

5.3.2.1 Image acquisition

**Image Acquisition**; command icon; the color and the subtitle depend on the **Image Type**, the exposure time is displayed in the little box on the right: **Use for** the acquisition of a single color image.

Execution of this command in an experiment will cause the following actions:

1. The illumination of the sample is switched on by opening the shutter.
2. Immediately afterwards image acquisition starts (upon a trigger pulse to the camera).
3. Immediately after image acquisition is terminated, the illumination of the sample is switched off by closing the shutter.
4. The acquired image data are transferred to the database.

**Properties, Image**

**Image Type.** Select the type of image to be acquired from a list of pre-defined types, specified in the **Image type** dialog box of the OV100 Configuration Software (see Chapter 15, *OV100 Configuration*). This selection determines the excitation filter (and thus controls the filter wheel of the Illumination System MT10) used for acquisition. Depending on the **Image type** chosen, the icon is displayed in a predefined color, the same color used afterwards to display the image on the screen.

**Light Intensity.** Adjust the intensity of the incoming light by selecting the percentage of transmitted light from the list of 14 intensities. This selection sets the attenuator wheel of the Illumination System MT10.
Objective. This function appears only if a motorized microscope is configured. Select an objective from the pick list.

Aperture. This function is active only if the zoom objective is selected. Select a value from the pick list.

Exposure Time. Control the image intensity range by selecting an appropriate exposure time. Exposure time adjustment can easily be done under visual control while acquiring images in Live mode (see Chapter 4, Image Acquisition and Hardware Control). The exposure time also determines the opening and closing of the shutter of the Illumination System MT10.

Acquisition time. This read-only information gives the time necessary for the system to acquire the image according to the selected parameters and transfer the data to the OV100 Imaging PC.

Name. Specify the name for the acquired image. The image will be stored under this name in the database. If this image becomes one of the color bands of a multi-color image (upon usage of a color frame, see next Chapter 5.3.2.2), this will be the name of the band. The default name is the name of the image type.

Get Current Camera Settings. Click this button to read in the exposure time, the binning factor and the ROI settings as currently set in the Camera Control dialog box (see Chapter 4.2, Camera Control). This is only necessary when modifying an Experiment Plan. If an Image Acquisition icon is newly added to the Experiment Plan the current settings are used by default.

Properties, Frame
By default the current settings in the Camera Control dialog box (see Chapter 4.2, Camera Control) are read in at the time of placing the icon. See the same chapter for a description of these parameters.

Binning. The factor can be changed by selection from the pull-down list.

Frame. A sub-frame, that is, a Region-of-Interest (ROI) to be read out from the camera, can be defined by setting the X and Y coordinate of the top left corner and the width (W) and the height (N) of the ROI.
However, it is much more convenient to define the ROI in the Camera Control dialog box and read it in via Get Current Camera Settings in the Properties > Image page.

Properties, Display

Display. If this (default) option is selected, an on-line image will be displayed and constantly updated on the Viewport during the experiment (for example, a time-lapse or a Z-stack acquisition). In this case the Image Acquisition icon shows a monitor symbol. If this option is deselected, no images are displayed on the Viewport during the experiment. The following controls are not required in this case and are disabled.

- On-line display is only possible in time-lapse or Z-stack experiments. If the option is activated in single image experiments, an error message is generated prior to the experiment execution.

Brightness. This mapping function is mainly used to adjust the brightness of the image display on the computer monitor. Note that mapping does not change the image data. You have two options to define which mapping applies to your online image display:

- Automap: The mapping range (min. to max. values) is automatically determined according to the minimal and maximal intensity values of the acquired image.
- Map fixed from ... to: Predefine the mapping range (min. to max. values) manually.

Coloring. This specifies the coloring of the online image display during image acquisition within the previously defined intensity range.

- Gray Scale: The image intensities are displayed in a linear gray scale.
- Image type color: The image intensities are displayed using the Fluorescence color defined in the Image type dialog box of the OV100 Configuration Software (see Chapter 15, OV100 Configuration). For example, it may be set so that GFP images will be displayed in green scale.

5.3.2.2 The Multi-Color Frame

Multi-Color Frame

Use for the acquisition of multi-color images of multi-labeled specimen or samples with dual excitation or dual emission dyes (e.g. Fura-2, Indo).

This command causes the storage of the acquired images of different Image Type (coded by different Image Acquisition icons encircled by the multi-color frame) within one file in the database:
- Any number of single images within the Multi-Color Frame is combined into one multi-color image.
- Each image within the multi-color frame will make up entirely and exclusively one color channel of the resulting multi-color image.

The multi-color frame can only be used if all Image Acquisition commands inside the frame have the same binning factor and ROI settings (Frame properties). Otherwise an error message will be generated upon execution of the Check! command.

Properties: The only parameter to be set here is the Name to be given to the multi-color image set in the folder of the current experiment in the database. If no name is given it will be stored under a default name. Each color band will carry the name set in the corresponding Image Properties page; see the previous Chapter 5.3.2.1.

5.3.2.3 The Z-Stack Frame

Z-Stack frame

Use for subsequent acquisition of images at different focus (Z-)levels.

Execution of this command will cause the following:

- The commands within the 3-D box are repeated on subsequent focus (Z-)levels.
- The images will be stored as Z-stacks.
- Multi-color Z-stacks can be acquired if the Z-Stack Frame contains a Multi-Color Frame with more than one Image Acquisition icon.

Properties
**Absolute Movement.** If the check box is **checked**, the Z-stack will be acquired between the positions set in the top and bottom boxes. If the box is **not checked**, the values in the top and bottom boxes will be ignored. The Z-stack will be acquired with its center being the current position of the Z-drive. Thus, one does not have to change the settings if the Z-drive is moved after the Experiment Plan has been set-up.

**Z-Device.** Z-Drive is the only possible selection in OV100.

**Current pos.** This read-only information displays the current position of the selected Z-device.

**Set top.** This parameter sets the highest position (focal plane) the selected Z-device will reach during the acquisition of the Z-stack. It can either be typed in or the current position of the selected Z-device can be read in by clicking on the **Set top** button. Clicking on the arrow buttons next to the box changes the position in increments of 10 nm.

**Set bottom.** This parameter sets the starting position of the selected Z-device during the acquisition of the Z-stack; it is the lowest focal plane. It can be set as above.

**Top layer slider** and **bottom layer slider.** These two sliders in the center of the page can be used as well to change the respective positions.

**Height.** This read-only information lists the total height of the Z-stack to be acquired.

**Layers.** The total number of layers to be acquired can be typed in or changed by clicking on the arrow buttons next to the box.

**Step Width.** The distance between successive image levels in the stack can be typed in or changed in increments of 10 nm by clicking on the arrow buttons next to the box. If the set values are not reasonable, for example if the bottom layer has a higher number than the top position, the pale green background of the dialog boxes turns into pale red.

The above parameters are not independent. A subset of them can be defined freely and the remaining parameters are changed accordingly automatically. The parameters **bottom level** and **top level** have the highest priority, which means, they restrict the parameters **Layers** and **Step Width.**

Once the **top** and **bottom** positions are defined any change in the number of **Layers** will automatically lead to a corresponding change of the **Step Width** and vice versa so that the **Height** is maintained. In case of an arithmetic mismatch between **Step Width**, number of **Layers** and **Height** (caused by the step size limits of the selected Z-device a fit of the bottom and top positions will be done automatically with minimal possible changes.

This is a convenient way to set the top and bottom position:

1. Start a Live View acquisition (see Chapter 4.1, Simple Image Acquisition).

2. Move the Z-drive slider in the Microscope window (see Chapter 4.4, Microscope Control) until the desired position is reached.
3. Transfer the settings to the Experiment Manager with the Set top or Set bottom button in the Z-stack Properties page, respectively.

4. Stop the Live View acquisition by clicking the Snapshot button.

5.3.2.4 The Time Loop Frame

Use for time-lapse experiments.

Execution of this command will cause the following:

- The commands within the Time-Loop Frame are repeated a specified number of times with a specified time interval.
- The images are arranged into time sequences and stored as one file.
- Time sequences may consist of single or multi-color images or entire z-stacks.

Properties

A Time-Lapse sequence is defined by the number of times the commands will be repeated and the time a single cycle lasts.

**Repeat.** This determines the number of times the set of commands within the Time Loop Frame has to be executed.

**Cycle time.** This parameter sets the repetition time and its unit. If this time is larger than the sum of the duration of the commands within one cycle, the system automatically adds a delay between the end of the last command of one cycle and the first command of the next one. The Total loop duration is the cycle time multiplied with the number of repeats and displayed as read-only information.

**Approximate minimal cycle time.** This read-only parameter informs you about the minimal possible duration of a single cycle. The minimal cycle time depends on the time requirements of all commands in the Time-loop frame.
5.3.2.5 The Stage Frame

**Stage frame**
**Use for** experiments that are to be repeated at different stage positions.

Execution of this command will cause the following:
- The commands within the **Stage Frame** are executed at the first position of a specified positions list and then repeated at each other position.
- The image sets are stored in separate files for each position but within the same experiment folder. The sets have the same name but carry the stage position number as prefix.

**Properties**

**Position List.** Select the positions list (see Chapter 4.5, *Motorized Stage Control*) from the shortlist.

The following options are only relevant if the online **Display** option is chosen for the **Image Acquisition** commands within the stage loop, see Chapter 5.3.2.1, *Image acquisition*.

**All positions in one display.** Select this option if you want to have just one online Viewport that always shows the most recently acquired image of the respective image type. If a stage loop contains more than one **Image Acquisition** command, each of them will have its own Viewport.

**Each position.** Select this option if you prefer to have the online images for each stage position displayed in individual Viewports.

The **Images** window is limited to 4x4 Viewports by default. (This setting can be increased to 5x5 as maximum, see Chapter 3.1.3, *The Viewport*). If the Experiment Plan calls for more Viewports, for example if the positions list contains ten positions and the **Stage** frame three **Image Acquisition** commands, an error message that states *Could not allocate requested number of displays* will be generated upon experiment evaluation (see Chapter 5.4.2, *Executing an Experiment*).
5.3.2.6 Online ratio image

**Ratio** command icon (with store option activated)

**Use for** the calculation of the ratio image of two images acquired during one cycle of the experiment.

This function is mostly used for calcium ratio imaging with the calcium sensitive dye FURA-2 and images acquired with 340 nm and 380 nm excitation wavelength. For more details see Chapter 10.8, *Ratio Analysis*.

**Properties, Ratio**

**Background Subtraction.** Three different modes are available: a constant, a background image or the average intensity of a ROI can be subtracted. See Chapter 10.5.2, *Subtracting the Image Background* for more details.

**Thresholds** and **Output Scaling.** See Chapter 10.8.2, *Generating a Ratio Sequence* for details.

**Properties, Calibration**

See Chapter 10.8.2, *Generating a Ratio Sequence* for details.

**Properties, Store**

If the option Store is marked – this is indicated by the storage symbol in the top right corner of the icon – the ratio sequence that is being calculated online will be stored on the hard disk after the experiment has been finished otherwise it will be trashed.

The calculation of a ratio images – and their online display – is a time consuming command for the PC processor. The software estimates the additional CPU usage and changes the minimal cycle in dependence of online analyses. However, in rather fast and complex experiments it still may happen that the acquisition of image pairs...
is faster than the calculation of the ratio images by the PC – especially for 1x1 binning and full frames with online display. In such a case the image acquisition timing has the highest priority and the analysis will remain incomplete. That means, while certain ratio images will be missing, all images will be acquired as designed in the Experiment Plan and stored in the database. The ratio calculation has then to be repeated offline.

Properties, Display
For a description, see Chapter 5.3.2.1, *Image Acquisition*.

**5.3.2.7 Online kinetics**

**Kinetic** ![Kinetic command icon](image)

*Use for* the online quantification of fluorescence intensity changes within ROIs over time and their display as a graph. See also Chapter 10.6, *Intensity Kinetics in Time and Z*.

**Properties, Kinetic**

**Use ROIs From Image.** The ROIs have to be drawn into a snapshot (or any image of the same XY dimension as the image to be acquired) before the start of the experiment. Choose this snapshot from the list in this box.

**Z Stack layer.** In a 3-D Time-Lapse series only one Z-layer can be chosen for the online calculation of a kinetic. Set this layer here.

**Stage Position.** An online kinetics analysis is possible only for one of the stage positions in an experiment to be carried out at different positions. Set this position here.

**Properties, Store**

If the option *Store* is marked – this is indicated by the storage symbol in the top right corner of the icon – the kinetics graph that is being calculated online will be stored on the hard disk after the experiment has been finished otherwise it will be trashed.

The display of the online kinetics is automatic and does not need to be activated as in case of the online ratio image calculation. It is possible to analyze several image sets in one experiment (in other words, to connect *Online Kinetics* commands to several *Image Acquisition* commands in one Experiment Plan). However, same as for the offline analysis, only one graph (with several ROI curves) of one image set can be displayed at a time. The graph to be displayed can be chosen and changed in the Graph gallery of the Image Manager box at the left side of the user interface during the experiment.

The calculation of a kinetics analysis is a time consuming command for the PC processor. The software estimates the additional CPU usage and might change the minimal cycle in dependence of online analyses. However, in rather fast and
complex experiments it still may happen that the image acquisition is faster than the
generation of online analysis results by the PC. In such a case the image acquisition
timing has the highest priority and the analysis will remain incomplete. That means,
while certain data points will be missing in the graph, all images will be acquired as
designed in the Experiment Plan and stored in the database. The analysis has then
to be repeated offline.

5.3.2.8 The Wait command

Wait command icon

Use for interrupting the experiment for a specified time before execution of the next command.

OV100 is a real-time system and thus the timer (elapsed / remaining time) continues to count
during the pause.

Properties

Delay time. This parameter sets the delay before the execution of the subsequent command.

5.3.2.9 The Autofocus command

Autofocus command icon the color indicates the Image Type to be used,
the exposure time is displayed in the little box on the right.
Use to automatically find the focus during an experiment

The Autofocus is a very useful feature in many experiments, especially in those where a) thermal
focus shifts are to be expected over time and b) a motorized stage is used to image the sample
at different stage positions. In the latter, case it cannot be expected that the focal position will be
the same over the entire sample.
For general explanations of the Autofocus, see Chapter 4.6, Autofocus. As explained there, the
initial Autofocus scan will always be followed by a second, finer one.

Properties

Autofocus
Z-Device. Z-Drive is the only possible selection in OV100.

Range. Set here the range of Z-positions to be scanned during the Autofocus process. The
range is centered around the current Z-position or – in case the Experiment Plan features a
Stage loop– the Z position defined in the positions list. The narrower the range is, the shorter will
be the time required for the Autofocus scan to finish. However, the focus cannot be found if it is
outside the range. Thus, a certain cautiousness is necessary when setting the range.
**Big Step.** Set here the step width to be made between neighboring Z-positions during the first of the two **Autofocus** scans. Whenever the **Range** is newly set, a default step size is being set in dependence of it.

**Fine Step.** Set here the step width to be made between neighboring Z-positions during the second of the two **Autofocus** scans. Whenever the **Range** is newly set, a default step size is being set in dependence of it.

**Use entire range.** If this box is NOT checked, the following will be done: if the focality initially increases during an **Autofocus** scan and then worsens again, the process will be terminated and the found focality maximum will be set as reference position for the second, finer, scan. If the box is checked, however, the process will not be terminated after a local focality maximum is determined, but the entire range will be examined. Obviously, this causes the **Autofocus** scan to last longer, but reduces the possibility that a wrong focal position is being detected.

**Ensure constant time.** It is not always possible to foretell how many positions will be examined during an **Autofocus** scan. Consequently, the time required for it is unsure to a certain degree as well. If the subsequent command in the Experiment Plan is to be executed immediately after the focus is found, the exact point in time cannot be told in advance. As a result, the acquired images will not be equidistant. If the option **Ensure constant time** is checked, the maximal time for an **Autofocus** scan will be calculated by the Experiment Manager and a delay will be added if the scan terminates before the maximal time is expired. Thus the timing of the experiment is fixed, however, at the cost of a certain loss in speed.

**Low Signal mode.** If this option is checked, a Mean filter (see Chapter 8.2.8) will be applied on each image before evaluation of the sharpness.
5.3.2.10 Additional "atomic" commands – the Microscope Commands toolbar

**Microscope Commands**

<table>
<thead>
<tr>
<th>Command icon</th>
<th>Action</th>
<th>Parameter to set</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Stage" /></td>
<td>move stage</td>
<td>relative movement or movement to absolute position</td>
</tr>
<tr>
<td><img src="image" alt="Filterwheel" /></td>
<td>switch filter</td>
<td>filter</td>
</tr>
<tr>
<td><img src="image" alt="Filtercube" /></td>
<td>switch filter cube</td>
<td>filter cube</td>
</tr>
<tr>
<td><img src="image" alt="Transmission lamp" /></td>
<td>switch transmission lamp on/off</td>
<td>intensity (voltage displayed in icon)</td>
</tr>
<tr>
<td><img src="image" alt="Nosepiece" /></td>
<td>switch nosepiece position</td>
<td>objective</td>
</tr>
<tr>
<td><img src="image" alt="Z-drive" /></td>
<td>move Z-drive</td>
<td>relative movement or absolute position</td>
</tr>
</tbody>
</table>

5.3.2.11 Additional "atomic" commands: the Lightsource and CCD Camera Commands

**Light Source Commands**, **CCD Camera Commands**

<table>
<thead>
<tr>
<th>Command icon</th>
<th>Action</th>
<th>Parameter to set</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Attenuation" /></td>
<td>change attenuation</td>
<td>light intensity</td>
</tr>
<tr>
<td><img src="image" alt="Excitation filter" /></td>
<td>switch excitation filter</td>
<td>filter cube</td>
</tr>
<tr>
<td><img src="image" alt="Shutter" /></td>
<td>open or close shutter of MT10</td>
<td>status</td>
</tr>
<tr>
<td><img src="image" alt="Acquisition" /></td>
<td>acquire image</td>
<td>binning, ROI, exposure time, synchronization, display</td>
</tr>
</tbody>
</table>
Acquisition, Not synchronous. This option causes the camera to operate without each image being triggered. The advantage of this mode is that camera exposure occurs while the data of the previous image are being read-out. The cycle time can thus be reduced to the read-out time.

This mode is only supported by certain cameras and available only for monochromatic experiments. It does not make sense to combine this command with any other command because they will not be synchronized.

5.3.3 Types of Experiments

5.3.3.1 Single images – monochromatic or in multiple colors

monochromatic single image
The Image Manager indicates a single monochromatic image by a "black&white" cell symbol.

The simplest possible Experiment Plan consists of a single Image Acquisition icon. Obviously, the result would be a single image file taken with a certain excitation filter, intensity and exposure time – the camera exposure being synchronized with the MT10 shutter.

Of course, with OV100 it is easy to acquire images subsequently with different excitation, illumination settings, exposure times and even different ROIs and binning factors. Such an Experiment Plan would consist of a series of Image Acquisition icons, connected with arrows to indicate the order; see the example below. The result would be three monochromatic image files respectively named "Dapi", "Fitc" and "TxRed".

This simple Experiment Plan of three icons codes for a quite long list of commands and actions. They shall be listed here as an example. The train of commands is based on the usage of a triple band fluorescence filter cube that is already in position. If not in a first step the filter turret would move the cube into position. If three single band filter cubes would be used the movement of the filter turret would be executed automatically as well without any further commands in the Experiment Plan.

1. Filter wheel moves into Dapi filter into position

2. Attenuator sets intensity
3. Shutter opens

4. Camera gets exposed and acquires the image

5. Shutter closes

6. Camera reads out the Dapi image data

7. Filter wheel moves into Fitc filter into position

8. Attenuator sets intensity

9. Shutter opens

10. Camera gets exposed and acquires the image

11. Shutter closes

12. Camera reads out the Fitc image data

13. Filter wheel moves into TxRed filter into position

14. Attenuator sets intensity

15. Shutter opens

16. Camera gets exposed and acquires the image

17. Shutter closes

18. Camera reads out the TxRed image data

In order to store the images together in one multi-color file the icons have to be framed by a **Multi-color Frame**; see below. In this case the ROI selection and the binning factor have to be identical for all images. The other settings, that is, exposure time and intensity, can differ. A single multi-color image is indicated by a colored cell icon in the **Image Manager**.

---

**multi-color single image**

The Image Manager indicates a single multi-color image by a colored cell icon.
Once an **Image Acquisition** command has been placed and defined on the editor surface outside the **Multi-Color Frame** it cannot be subsequently moved into the frame and connected with another command placed in there. It would be necessary to delete the frame, connect the icons and redraw the frame. Similarly, the commands within a multi-color frame cannot be connected with commands outside. However, it is possible to add an **Image Acquisition** icon to an existing multi-color frame or to draw an empty multi-color frame into the editor surface and subsequently fill it with **Image Acquisition** commands.

### 5.3.3.2 Single images – transmission

Transmission light is usually much less intense and less harmful than fluorescence excitation light. For this reason microscopes often do not feature any electronic shutter in the transmission light path. In such setups transmission imaging in praxis cannot be combined with fluorescence imaging in one experiment because the transmission illumination causes such a strong background that any fluorescence would be largely or entirely overpowered.

If, however, the system is equipped with a transmission shutter and the software is correctly configured (compare Chapter 15.3, *Configuring the Microscope*, and Chapter 15.4, *Definition of Image Types*) the acquisition of a transmission image will be preceded automatically by the opening and succeeded by the closing of the transmission shutter. In other words, it is not required to consider the shutter movements when setting up an Experiment Plan. Such a system allows combining transmission and fluorescence imaging in one experiment.

### 5.3.3.3 Z-Stack acquisition – monochromatic or in multiple colors

To setup a Z-stack acquisition a **Z-Stack Frame** has to be drawn around one – or several – **Image Acquisition** icons; see the examples below. The result will be data files (one – or several, respectively) that contain all the images taken at the different focal planes.

**monochromatic Z-stack**

The Image Manager indicates a Z-stack acquired with a single excitation wavelength with a "black&white" stack icon.

The order of image acquisitions in the triple-color experiment plan is the following: First a Dapi image is taken at the lowest stack position, then a Fitc image at the same position, then a Texas Red image. Afterwards, while the TxRed image data are still readout from the camera the motorized Z-drive moves to the second lowest position. Once the system is ready again a Dapi image is taken first, then a Fitc and finally a TxRed image. This sequence is repeated for each layer. After the last image of the last layer – the top position of the stack – is acquired the motorized Z-drive moves back to the position it was at before the experiment started with the first layer.
If it is desired that the stacks of different color are stored together within one four-dimensional data set (XYZ + color) so that the colors are displayed together as multi-color images for each layer, a **Color Frame** has to be drawn around the **Image Acquisition** icons. The experiment will be the same as above but for the way of data storage.

multi-color Z-stack

The Image Manager indicates a Z-stack acquired with a multiple excitation wavelengths with a colored stack icon.

It is not possible to interchange the order of frames, that is, to have the **Multi-Color Frame** as outer and the **Z-Stack Frame** as inner frame. Upon **Plan Verification** (see 5.4.2, *Executing an Experiment*) an error message will be generated: ‘A "Time-Lapse" or "Stack" command must not be inside a "Multi-Color" command.’

5.3.3.4 **Time-lapse experiments – monochromatic or in multiple colors**

A time-lapse Experiment Plan is similar to that of a Z-Stack Plan: here a **Time Loop Frame** has to be drawn around one – or several – **Image Acquisition** icons, see the examples below. The result will be data files (one – or several, respectively) that contain all the images taken at the different time points.

monochromatic time sequence

The Image Manager a time sequences acquired with a single excitation wavelength with a film stripe icon containing a "black&white" cell.

In a multi-color time sequence the OV100 system will perform the following. Images will be taken subsequently: first with DAPI illumination, then with FITC and finally with TxRed illumination; if desired with different exposure times, illumination intensities, binning factors and sub-frame readout regions. Each image capture is synchronized with the opening and closing of the shutter to minimize photo-bleaching. This series of acquisitions will be repeated over and over again as often as defined in the **Time Loop Properties** and at exactly specified points in time. Let’s imagine the capture and readout of the three images and the movement of the filter wheel from the TxRed position back to the DAPI position (to be ready for the next cycle) take a total of 500
ms and the Cycle Time is set to 2000 ms. In this case the system will be idle for 1500 ms before the next cycle starts with a DAPI image acquisition.

In most cases, it will be convenient to store the images of different color within one multi-color data set. In order to do this – same as for multi-color Z-stacks – a Multi-Color Frame has to be drawn around the Image Acquisition icons. Similar to the Z-stack acquisition described in the previous chapter, the Multi-Color Frame must be placed inside the Time Loop Frame – not vice versa – or the same error message as above will result upon Plan Verification (see Chapter 5.4, Conducting Experiments / Data Acquisition).

multi-color time sequence
The Image Manager indicates a multi-color time sequences with a film stripe icon containing a colored cell.

It is also possible that a Time Loop frame contains another Time Loop frame. The result will be a time-lapse sequence that contains blocks of equi-distant images. These blocks result from the “inner” Time Loop frame and are separated by the time-lapse resulting from the loop duration set for the “outer” Time Loop frame.

5.3.3.5 3-D Time-lapse experiments – acquisition of series of Z-stacks
In so-called 3-D time-lapse experiments the acquisition of Z-stacks is repeatedly carried out. To set this up in an Experiment Plan, a Time Loop Frame has to be drawn around a Z-Stack Frame. The latter may contain a single Image Acquisition icon or several – combined with a Multi-Color Frame or not. For the color management the same principles apply as in the chapters above, they will not be repeated here. A typical multi-color 3-D time-lapse Experiment Plan is shown in the example below.

monochromatic and multi-color 3-D Time-lapse sequence
The Image Manager indicates monochromatic 3-D time-lapse data sets with a monochromatic stack within film stripes. For multi-color data sets it is a colored stack within film stripes.
5.3.3.6 Experiments with online analyses

The OV100 software allows to calculate a ratio image and an intensity kinetic online during the execution of an experiment.

The Ratio commands can only be placed after a Multi-Color Frame containing exactly two Image Acquisition commands. In other cases a corresponding error message will be generated upon verification of the Experiment Plan.

A Kinetics command can be placed either behind an Image Acquisition or a Ratio command; the calculation will be done for this very command.

The example below shows an Experiment Plan for a Fura-2 calcium ratio time series with online display of the images acquired with 340 nm excitation, online calculation, display and storage of the (340 nm : 380 nm) ratio images and online calculation, display (by default) and storage of the intensity kinetics of the ratio image.

5.3.3.7 Experiments with image acquisitions and different stage positions

If the OV100 imaging station contains a motorized stage it is possible to automatically execute experiments at different stage positions that have to be defined in a positions list beforehand (see Chapter 4.5.1, Defining a Positions List).

An example would be to acquire z-stacks with two different Image Types at each stage position – the Stage frame has to be drawn around the Z-stack frame – and this has to be repeated several times – the Time Loop frame has to be the outmost one. The Experiment Plan would look like shown below. Within the same experiment folder in the database, individual dual-color 3-D time-lapse series will be stored for each stage position.

Both the positions list of the stage and the Z-stack properties (see Chapter 5.2.3.2, The Z-Stack Frame) contain parameters for the Z-positioning of the system. In order to avoid conflicts in an experiment like the one above the absolute position information for the top and bottom position in the Z-stack properties will be ignored. The relevant information is the Height of the Z-stack as
defined in the Z-stack properties. The center position of the Z-stack of this height to be acquired at each stage position, is the Z value set for each position in the positions list.

A **Stage** frame can also be drawn around a **Time Loop** frame. In that case, a time-lapse sequence is first acquired entirely at the first stage position, then the stage moves to the second position where another time-lapse sequence is acquired and so on.

It is also possible that a **Time Loop** frame contains a **Stage** frame that again contains another, "inner" **Time Loop** frame. For each stage position the result will be a time-lapse sequence that contains blocks of equi-distant images. These blocks result from the "inner" **Time Loop** frame and are separated by the time-lapse resulting from one loop through all stage positions.

### 5.3.3.8 Experiments with autofocus

Long lasting experiments always carry the risk of focal shifts over time. It is not uncommon that, say, after a few hours the specimen is out of focus, for example because of temperature drifts. This can be avoided by inserting an autofocus scan after certain intervals during the experiment. For the setup of the Experiment Plan it is convenient that the Experiment manager supports the placement of time loops within time loops.

The Experiment Plan shown below defines a long time-lapse experiment with an image acquisition once a minute and autofocus scans once every hour.

Experiments that use a motorized microscope stage for image acquisitions at different XY positions would be problematic without the possibility of an autofocus scan at each position. In most every case, the focal position will be different at each stage position, at least if larger stage areas are included.

The Experiment Plan below describes an experiment with dual-color image acquisitions at different stage positions. At each position first an autofocus scan will be performed. The entire stage loop will be repeated every 10 minutes.
5.4 Conducting Experiments / Data Acquisition

5.4.1 Opening a Database

Before the start of image acquisition with the Experiment Manager, it is necessary to open an OV100 database. There are two possibilities: to open an already existing cell^-R database or to create a new one.

To open a database select **Database > Open...** (or **File > New Database** in the Experiment Manager). In the **Open Database** window select a OV100 database with the extension *.apl* and click the **Open** button. Recently opened databases can be selected from a list at the bottom of the **Archiving** menu.

To create a new OV100 database, select **New Database...** in either the **File**, the **Acquisition** or the **Archiving** menu. Type a name in the **Database name** field of the **New Database** window and click on the now enabled **Next >** button. In the following dialog box select **Finish** to create the new database with the highlighted parameters.
5.4.2 Executing an Experiment

Control Center
Use these commands to run an experiment.

Execution of an Experiment Plan compiled with the Experiment Manager involves three steps:

1. Check!
2. System Ready!
3. Start!

5.4.2.1 Check!

Before an Experiment Plan can be executed, the Experiment Plan needs to be validated. The system has to check whether all interconnections of the commands are consistent, the parameter settings reasonable, etc. If the experiment plan passes the check, the System Ready! button changes to the enabled state. Once validated, an opened Experiment Plan may be repeated several times without additional checking.

Loading an Experiment Plan from the database requires validation before execution, even if the plan had been used before (and, consequently, was valid).

5.4.2.2 System Ready!

Press the System Ready! button to “arm” the system. This downloads the Experiment Plan to the cell^M System Coordinator and sets the parameter for the camera. Also, the memory required for image acquisition is allocated on the hard disk. The arming of the system may take several seconds depending on the amount of data to be acquired. Once the system is ready the Start! button will be enabled.

If no OV100 database is open the System Ready! command fails and the following OV100 Error message will appear:
Open or create a OV100 database (see above) and then press the **System Ready !** button again. It is not necessary to **Check !** again.

> **i** If the Experiment Plan includes online display of images, the Viewport is automatically rearranged at this point. The images will be arranged one above the other by default, the first one to be acquired being displayed in the top position. The arrangement can be changed as usual via the **Arrange Viewport** button.

5.4.2.3 **Experiment start**

**Start!**

Once the **Start!** button is enabled the information **Prepared** is displayed in the status bar at the bottom of the Experiment Manager window. Upon pressing the button, the experiment starts immediately. In order not to slow down the data transfer, only a limited number of user interactions, which might be required for online data inspection, are allowed during the course of the experiment. These include:

- Viewport settings: all functions in the Viewport toolbar.
- Display settings: all functions in the **Image Analysis** > **Image Display** dialog box of OV100

Likewise, the two buttons in the Image Display toolbar (**Display Intensity** and **False-Color**) remain active.

All other functions as well as all other programs are blocked during the course of image acquisition.

The status bar of the Experiment Manager window displays information about the acquisition status. After starting the experiment the second field from the left in the status bar shows the information **Running**, indicating that images are acquired. The field in the middle displays the experiment time (**hh:mm:ss.ms**). Information about the actual number of **Frames Acquired** and **Stored** and the **Total** number of frames of the experiment is shown in the right field of the status bar.
5.4.2.4 Pausing an experiment

Pause

To interrupt an experiment, press the Pause button. As a consequence, experiment execution will be interrupted immediately. If the Pause button is pressed while the system is taking an image the interruption will take place after the process is completed. In the paused state, the experiment can also be aborted (see below).

To resume the experiment, press the Start button.

The experiment time will continue to elapse during an interruption, meaning that:

- The total experiment time will increase by the duration of the interruption. If the experiment is interrupted during acquisition of an image sequence (Time-Lapse command) the cycle time of the current loop as well as the total loop time will increase by the duration of the interruption.
- The time information attached to the image data will reflect the interruption. Therefore, the break will be reflected also in post-acquisition temporal analysis of the images.
- The experiment time display in the status bar continues counting.

5.4.2.5 Setting markers during an experiment

Set markers

To mark a certain event during the course of an experiment (e.g. the application of a substance to your sample during a time-lapse experiment), press the Set Marker button in the Control Center field. You can mark several events during an experiment. A time trace of all markers (numbers) will be stored in the experiment folder of the database. The markers can be displayed in all offline analyses (if the Image Analysis Display Markers and the Graph Analysis Markers and Labels Display Markers options are selected).

Setting a marker does not interrupt the experiment.

5.4.2.6 Aborting an experiment

Stop! button

To abort an experiment, use the Abort button. After abortion all image data acquired during the experiment as well as the Experiment Plan and event markers are automatically transferred to the database and will not be lost.

Even in the worst case that a hardware malfunction error occurs during experiment execution all the data acquired so far will be stored and not lost.
5.4.3 Data Storage

Images acquired in experiments via the Experiment Manager – unlike snapshots or live images – are stored automatically in the active database in a folder that is generated automatically and carries the name of the experiment. The folder will contain at least two objects afterwards: the Experiment Plan and a set of images. The number of image sets depends on the experiment setup. For example, an Experiment Plan with two time loops with each containing a color loop with several acquisition commands will result in two image sets (see Chapter 5.3.3.7, Complex experiments with trigger pulses and several time loops).

If the Experiment Plan contains a Ratio Image command (connected to a color frame with two acquisition commands, see Chapter 5.3.3.6, Experiments with online analyses) with activated Store option, the ratio data will be stored as child object of the parent image data – one level lower in the data hierarchy, see the screenshot below.

**Online Kinetics** with activated Store option are stored as child objects of the image set that was being analyzed. Additionally, the image used to predefined the ROIs of the kinetics will be stored (Tv1 in the screenshot below).
6 Image Display and Navigation

The software interface features a special window, the Viewport, to display up to 16 images. Raw images usually need a little touching up in the display to look appealing, contrast, brightness and color can be adjusted. Images series created in multi-dimensional experiment may contain dozens or even hundreds of individual images taken at different points in time, different Z-positions or with different excitation wavelengths. Such data sets require tools for navigation and animation. All this is explained in the following sections.

6.1 The Viewport

Image(s) acquired with the Experiment Manager or loaded from a database are displayed onscreen in Viewport(s) within the Image window. This window features a number of buttons, the functions of which will be explained below.

You can set the number of Viewports to be displayed and their arrangement using the Arrange Viewports button in the toolbar of the Image window. Just mark the columns and rows by moving the mouse cursor over the schematic grid with 16 Viewports that open. The selected Viewport display will be shown in the field beneath the grid (2 x 2 Images in the example).

The favored images to be displayed can be selected via drag-and-drop from the Image Manager. You can easily switch between the display of a single Viewport or the tiled display of all selected Viewports by pressing the Single View/Tile View button.
**Zoom Factor**

From the shortlist you can adjust the size of the displayed images, given as % of the original image size. If you select Auto the image size is automatically adjusted to fit into the size of the Viewport.

**Zoom In**, **Zoom Out**

Clicking on the **Zoom In** button doubles the size of the displayed image while the **Zoom Out** button reduces the size by half.

**Adjust Zoom**

This allows adjusting the zoom factor to the current Viewport size. It has the same function as Auto in the **Zoom Factor** shortlist.

**Adjust Window**

This function fits the Viewport size to the size of the displayed image. This command is only available in the single view mode.

**Full Screen**

This function generates a full screen view of the active image. Additionally the Menu bar, the Full Screen button bar, the Acquisition toolbar and the button bar of the active document (Viewport, database or graph) remain available.

- **Close Full Screen**: returns to standard view.
- **Select previous buffer**: displays the image in the Image Manager buffer atop the current image.
- **Select next buffer**: displays the image in the Image Manager buffer below the current image.
- **Select a document**: displays – via selection from the pick list – any other open document, for example, the database or the graph window.
Show additional components: displays – via selection from the pick list – the Image Manager or Viewport Manager.

Viewport title bar

Some basic information is given here about the active data set. From left to right it lists: The Viewport number (here: 5), the name of the data set (here: GFP), the current point in time out of a total number of time points (here: T(4/10)) in case of a time sequence, the current layer out of a total number of layers (here: Z(8/17)) and the magnification (here: 100%).

6.2 Image Display

6.2.1 General

The commands in the Image → Image Display menu are image-processing functions that do not alter the image data. Only the appearance of an image on the screen, the image’s display, will be changed while the original image parameters remain untouched in the source image buffer.

6.2.2 Adjust Display…

Display Intensity

Use this command to adjust the onscreen display of image sets (without changing the data).

General. A 16 bit gray-value image consists of gray values ranging from 0 to 65535. A (nx16) bit image sets has (potentially) the same amount of intensity levels in each and every color channel. Most monitors can only display 256 gray values (8 bit), which is already far beyond the number of gray levels the human eye can differentiate. Color monitors generate colors by mixing the
three existing color channels, red, green, and blue, with different intensities. Each channel is able to provide 256 levels of intensity (8 bit each). The result is a (3x8) bit image composed of more than 16 million possible colors. This is the so-called true color format.

6.2.2.1 The Adjust Display tab

Using the Adjust Display dialog box you can define which range of intensity values of the data is to be displayed on the monitor for each channel the images consist of – using the 256 available brightness values per channel of the monitor. What you’re actually doing is defining a so-called display palette or LUT (lookup table). This palette correlates intensity values of the data with color intensities on the screen. Its range goes from the minimum value (the lowest displayable intensity value) to the maximum value (the highest displayable intensity value).

Display Channel (colored square) and Adjust Channel (bar below)

Color channels field (top).
This field contains colored Display Channel buttons to select channels to be displayed and narrow Adjust Channel buttons underneath to select channels to be adjusted.

Display Channel buttons. The white button causes the display of all color channels while the colored buttons select the corresponding color channel for display. To display more than one channel, use <Shift> and click.

Adjust Channel buttons. These buttons select the corresponding channel for individual adjustment when more than one channel is being displayed. The histogram of the selected channel is moved to the foreground.
**Histog**

*Currently active channels are displayed. The scaling is automatically set so that it encompasses only the range between dimmest and brightest pixels.*

If a single channel is being displayed or if one channel has been selected for adjustment with its **Adjust Channel** button, **vertical lines** indicate the lower and upper thresholds of each channel: **Min** and **Max**, respectively. Every value below the **Min** and above the **Max** will be displayed with the dimmest (most often black) or brightest (most often the pure spectral) color of the channel’s palette, respectively.

---

**Min / Max.** For a single active channel the minimum and maximum values are set either by dragging the vertical lines in the histogram, by typing the values in the respective fields, or via the **Min** and **Max** scroll bars.

**Auto.** Click here for an automatic adjustment of the active channels. The software checks each channel for the minimum and maximum intensities and scales linearly in between – under consideration of the **Clip** values.

**Clip.** This group is available if a single channel is active. The values inputted for **Min.** and **Max.** will influence calculation of minimum and maximum values. To make automatic calculation more effective when noise or bright impurities are present, you can define how many pixels (as a percentage of the total number of pixels) will be displayed with maximum or minimum brightness. Percentage values can be anywhere between 0% and 50%. 0.1% is usually a good value to start with – a slight increase in contrast and brightness results.

---

**Brightness, Contrast and Gamma Correction**

These bars become active if one channel is activated. The values can be increased or decreased by increments of 0.1 by respectively clicking into the bar above or below the sliders.

**Brightness.** Values above 50 increase the overall brightness by reducing both the **Min** and the **Max** value, values below 50 cause the opposite.

**Contrast.** Values above 50 increase the contrast by reducing the span between **Min** and **Max**, values below 50 cause the opposite.

The **Gamma Correction** allows a non-linear adjustment of the display. Values above 1.0 increase the middle intensities while values below 1.0 decrease them.
6.2.2.2 Detail Mapping

Use this function for non-linear intensity adjustments. The field shows the histogram of the selected channel and its intensity scaling curve. The shape of the curve can be changed by mouse drag or by clicking into the field – the curve will be fitted to reach the point that was clicked.

**Linear.** Click here to get back to a linear scaling from Min to Max.

**Reset.** Click here to get back to the scaling that was active before the Adjust Display window was opened.

6.2.2.3 Shift Correction
Use this function to move individual color bands interactively in multi-color image sets in X and Y relative to the other bands.

The **Shift Correction** is useful when multi-color images are acquired with several single band filter sets (instead of multi-band filter sets). It may be that the dichroic mirrors in different cubes do not have exactly the same angle relative to the optical path. As a consequence, the resulting images may be slightly shifted relative to each other. The function is also especially useful for dual-emission images acquired with the beam-splitting device DualView MicroImager™.

**Horizontal / Vertical Shift.** Use the arrow buttons to shift the selected channel relative to the others.

**Center.** Use this button to move the active channel back to the original position.

![Info]

This command does not affect the image data, it only alters the on-screen display. In other words, while the display changes the original data remain untouched. Thus, if for example the **Pixel Values** are determined or a **Ratio** calculated, the pixel shift will not be taken into account.

Execute the function **Process  Image Geometry  Apply Pixel Shift** in order to generate a copy of the image set with the **Shift Correction** values stored in the data. The software automatically crops the image cutting off the area that becomes empty in the shifted channel.

### 6.2.3 Auto Adjust Display

**Auto Adjust Display**

This is a quick way to adjust the channel intensities of multi-dimensional image sets. The entire data set – not just the current image – is checked for the brightest and the dimmest pixel and their intensity is used to set the minimum and maximum values of the display. Additionally, the current clipping settings in the **Adjust Display** dialog are considered.

### 6.2.4 White Balance

Many cameras tend to adulterate (falsify) image colors at acquisition. This kind of color displacement can be corrected retroactively. To do so, you need to have an image that has an area where you know it should be white. Instead, it looks, for example, yellowish. This yellowish tinge - the color tinge - can be corrected throughout the whole image.
Available. This function is only available for single images of the RGB format and not for (n x 16) bit images acquired with the Experiment Manager. In microscopy it is only useful for transmission images acquired with a color camera.

This command does not affect the image data, it only alters the on-screen display.

To apply the white-balance, a circular image area has to be defined where it is not that the pixels should be white, black or gray - but at present are tinged. Afterwards, three correction factors will be calculated based on the pixels within this circle – one each for the three color components. These correction factors are defined such that the pixels within the circle will be gray on average. Using these correction factors, the whole image will be corrected.

This is the procedure:


2. Left-click within the image. A red circle will appear in the overlay.

3. Position this circle with the mouse. To resize it, keep the left mouse button pressed as you move the mouse.

4. Right-click to confirm the circle and apply the white-balance.

6.2.5 Black Balance

This function is similar to the white balance. That difference is that here a dark image area can be defined that should be displayed in black. All other colors will then be corrected with the same correction value.

Available. This function is only available for single images of the RGB format and not for (n x 16) bit images acquired with the Experiment Manager. In microscopy it is only useful for transmission images acquired with a color camera.

This command does not affect the image data, it only alters the on-screen display.

The execution of the command Image ▸ Image Display ▸ Black Balance is done in the very same way as the white balance described above.
6.2.6  Gray Scale

This command turns a false-color image display back into the original gray-value image display. The image’s false-color palette will be deleted from the Viewport. It will be lost if the palette itself is not part of the provided library and has not been saved as a separate file.

Available. This command is only available for single-channel 8 bit or 16 bit false-color images.

⚠️ This command does not affect the image data, it only alters the on-screen display.

6.2.7  Fluorescence Color

This command is used for displaying single-channel images or individual channels of a multi-channel image with the monochrome palette defined in the OV100 Configuration Software (see Chapter 15, OV100 Configuration) for the corresponding filter of the Illumination System MT10 used for acquisition (for more details, see Part B Hardware Manual).

Available. This command is only available for single-channel 8 bit or 16 bit images and for (n*16) bit images in the single-channel display mode (via the Select Color Channel button).

⚠️ This command does not affect the image data, it only alters the on-screen display.

6.2.8  Edit Fluorescence Color…

Images acquired via the Experiment Manager are automatically displayed in the color defined with the Image Type in the OV100 Configuration Software (ObsConfig.exe), see Chapter 15.4, Definition of Image Types. Snapshots, however, are displayed with a gray palette.

Use the Edit Fluorescence Color… command to modify the color of snapshots or of individual color bands of multi-color images.
**Hue.** This parameter sets the color tone (spectral color). The display underneath the colored field shows the approximately corresponding wavelength.

**Saturation.** Reducing this parameter adds "whiteness" to the color. In the RGB color space this corresponds to linearly increased intensity in the non-saturated channels.

**Brightness.** Reducing this parameter adds black to the color. In the RGB color space this corresponds to linearly decreased intensity in all channels.

### 6.2.9 False-Color...

**False-Color button**

Use this command to select a color palette from the list in the dialog box **RGB Lookup Tables of Color Channel '<...>'**.

The library of palette files provided with OV100 is stored in ...\OV100\LUT.

**Available.** This command is available for all image types, however, the false-color palette will only be used if a single color channel of the image is being displayed.

False-color palettes or lookup tables (LUTs) enable to display gray-value images or individual color channels of (n*16) bit images in predefined "false" colors, also called pseudo-colors. This is done in that the palette assigns each gray value of the image a certain color. For example, in an 8 bit image with the Rainbow3 palette (see below) the intensity 23, which is a near-black gray in the standard linear black-to-white gray palette, is displayed as blackish blue, while 226, otherwise a very light gray, is displayed in an orange tone.

False-color palettes are often used to increase contrast. This is because the human eye distinguishes only about 50 different gray values but many more colors. Another application is to highlight certain intensity values.
How palettes alter image display.

<table>
<thead>
<tr>
<th></th>
<th>Red</th>
<th>Green</th>
<th>Blue</th>
</tr>
</thead>
<tbody>
<tr>
<td>02</td>
<td>02</td>
<td>02</td>
<td>02</td>
</tr>
<tr>
<td>03</td>
<td>03</td>
<td>03</td>
<td>03</td>
</tr>
<tr>
<td>04</td>
<td>04</td>
<td>04</td>
<td>04</td>
</tr>
<tr>
<td>05</td>
<td>05</td>
<td>05</td>
<td>05</td>
</tr>
<tr>
<td>06</td>
<td>06</td>
<td>06</td>
<td>06</td>
</tr>
<tr>
<td>07</td>
<td>07</td>
<td>07</td>
<td>07</td>
</tr>
<tr>
<td>08</td>
<td>08</td>
<td>08</td>
<td>08</td>
</tr>
<tr>
<td>09</td>
<td>09</td>
<td>09</td>
<td>09</td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>10</td>
<td>10</td>
</tr>
<tr>
<td>11</td>
<td>11</td>
<td>11</td>
<td>11</td>
</tr>
<tr>
<td>12</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>13</td>
<td>13</td>
<td>13</td>
<td>13</td>
</tr>
<tr>
<td>14</td>
<td>14</td>
<td>14</td>
<td>14</td>
</tr>
<tr>
<td>15</td>
<td>15</td>
<td>15</td>
<td>15</td>
</tr>
</tbody>
</table>

The intensity values (counts) of monochrome images' pixels comprise the palette's input – e.g., 0 – 255 for 8 bit images. These intensity values are listed according to their respective line (number) – (see the example table above). Each intensity value is assigned to a certain intensity of the three colors Red, Green and Blue. The three color intensities put together 'add up' to the color that all pixels of that particular intensity value are displayed in on the monitor. If all three color components have the same intensity (R = G = B), the pixels are displayed in a shade of gray.

Possible Colors. If all intensity values and combinations thereof are used, each pixel can be displayed on the monitor in one of (256*256*256 =) 16,777,216 colors. Pixels of false color images (8 bit or 16 bit, in contrast to (3x8) bit true-color images) are restricted to one of (2^8 =) 256 different colors – this is a limitation of the false-color palettes. These 256 can, however, be selected from all 16,777,216 colors.

Using palettes to alter gray-value images. An image's palette only defines how gray values of an image are displayed onscreen. The original gray values ('under' the palette) remain unchanged.

The collection of palettes. The palettes Blue, Cyan, Green, Magenta, Red and Yellow are simple, linear monochrome black-to-color palettes. Polaris, Solaris, Thermal, Gamma3 and Dither are kind of standards that are probably of limited use in fluorescence imaging.
The *Rainbow1/2/3* palettes (first, second and third from left, respectively) shown above are especially useful for contrast enhancement. The most appealing one might be *Rainbow3* that begins with a black-to-blue gradient. *SemRainbow1* and *2* (fourth and fifth from left, respectively) with their inherent dark-to-light gradient are particularly nice for displaying small features on a black background.

The *ColdHot* palettes below are designed to highlight extremes in intensity, i.e. the dimmest and brightest features of the image. They also allow judging optically the dynamic ranges of image areas. *ColdHot4* (fourth from left) with a rather narrow gray center was designed to easily distinguish – if scaled accordingly – areas of increasing and decreasing signal intensities in $\Delta F/F$ plots.

The palette currently loaded is marked with a tag in the menu *Image Analysis > Image Display* and in the shortlist of the *Select Color Channel* button.

### 6.2.10 Edit False-Color…

Use this command to edit an existing color palette or to create a new one. The library of palette files provided together with OV100 Imaging Software is stored in the folder `\OV100\LUT` on the hard disk.

**Available.** This command is available for all image types with the exception of (3x8) bit true-color images.

False-color palettes or lookup-tables (LUTs) make it possible to display gray-value images as well as individual color channels of (nx16) bit images in color. This is done by the palette assigning a certain color to each gray value of the image. (For details see previous section 6.1.5)

**Different palette types.** There are three different ways to define palettes, these includes:

- Type all palette values directly into a sheet.
- Generate palettes interactively by defining polygons.
• Use formulae to have the palette computed.

The **Edit False-Color**... command opens a dialog box, which provides tabs for each of the above-mentioned methods. Each of the three methods generates a different palette file format, *.LUT*, *.LUP* and *.LUF*, respectively.

In effect, you’re editing a separate palette in each of the three tabs (see below) in the **Edit LUT** dialog box, i.e., each time you go to another tab, you will not only switch to a different editing method, but also to an altogether different palette of the image itself. In general it is not feasible to automatically convert between the three palette editing methods. In fact, there are only a few exceptions where this would make any sense. There is, however, one important exception: if you switch from either the **Polygon** or **Formula** method to the **Sheet** tab, the palette you have defined in the former will be inserted into the sheet. This exception enables you, for example, to have a whole palette generated using a formula, and then to edit individual values in the sheet.

---

![Image Display and Navigation](https://example.com/ov100-software-manual/chapter-6/image-display-and-navigation.png)

---

A switch to the **Sheet** tab deletes the sheet values of the previous palette. You always should save (see below) any palette you have defined before you switch to another tab.

---

Imaging C functions can only use the LUT format to alter the lookup table of an image. Therefore it becomes necessary, that all LUTs originally saved in the polygon or formula format are saved as *.LUT* files as well (see below). Furthermore, only *.LUT* files are listed in the **False-Color**... dialog box (see above).

---

**Saving/Loading palettes.** A palette can be saved as a separate file, independent of its image. This allows reloading the file at a later time and using the palette on the same image or transferring it to another image. To do this, click on the File... button (contained by all three tabs).

---

### 6.2.10.1 The **Sheet** tab
Sheet. You can edit sheet values manually. Click into the sheet field and select any particular field using the mouse or the cursor keys. The input can be terminated by the <Tab> key, moving you on to the next horizontal field, or by the <Enter> key, which will move you to the next row. Click within the left column with the cross-shaped cursor if you wish to select one or more rows. You can copy the contents of the rows using <Ctrl+c> and <Ctrl+v>. Use the clipboard to copy these contents into other applications.

The Red, Green and Blue scrollbars will be available, if one or more rows have been selected. Use these scrollbars to define specific value(s) for all selected rows. Please note that only the fields corresponding to the relevant color are changed. All changes will be displayed on the monitor immediately.

File... Click on the File... button to open the standard dialog box to open and load files. Files will be saved using the LUT format.

Linear. When you click on the Linear button, the values of the linear standard LUT will be inserted into the sheet.

Interval... If you click this button, the Set Thresholds dialog box will open. Here’s where you can define a gray value interval for the definition of LUT values. When you exit the Set Threshold dialog box via OK, the corresponding interval in the sheet will be selected. Then you have to set the color for the selected rows manually with the Red, Green and Blue scrollbars.

Fill down. When you click on the Fill down button (in the Edit LUT dialog box), all values of the first selected row will be transferred to the other selected rows. Using this command, you can enter new values into one row and then have them copied to successive rows.

Sheet. Click on the Sheet button to generate a separate sheet document using the dialog box’s current LUT. The columns of the sheet are: Index, Red, Green and Blue. Such a sheet can, for example, be exported in the Excel format via File > Save As....

6.2.10.2 The Polygon tab

Diagram. Within the diagram, lines (or “polygons”) of the respective colors represent the three primary colors of the LUT. The horizontal axis represents gray values from 0 – 255. The vertical axis represents LUT entries, i.e., color intensities from 0 – 255.
Mouse Functions. A LUT polygon is defined by its points, which are represented by small white squares joined by lines. There will always be at least two points at the left or right edge of the diagram that cannot be shifted horizontally.

To add a new point to the polygon, simply click on any arbitrary point within the diagram. If you move the mouse cursor over any point of a polygon, the cursor will turn into a hand. Then, pixel value and corresponding intensity of this point will be displayed at the right edge of the diagram. If you keep the left mouse key pressed, you can alter the position of this polygon point. All changes made in the diagram will be displayed on the monitor immediately. A polygon point can be shifted between the two neighboring points (to the right and left of the point in question). This makes it easy to define a rectangular or saw-tooth-shaped polygon.

Right-click on any point of a polygon to delete it.

<Shift> and <Ctrl> keys. If it is necessary to define a point of a polygon with greater precision: keep the <Shift> key pressed while positioning the mouse – you will only be able to move the cursor vertically; to be able to move it only horizontally keep the <Ctrl> key pressed while positioning the mouse.

Color. Select the color you want to change here. The polygon representing this color will be placed in the foreground – not covered by the other polygons.

Count and Define. Define here the number of points your polygon will contain. First you enter the number into the Count field. Then click on the Define button. All polygon points will be plotted equidistantly (with respect to the x-axis). Up to 32 points can be defined for a single polygon.

Monochrome. If you select the Monochrome check box, the polygon will become yellow. All changes will be applied to all three colors simultaneously, thus enabling you to define a monochrome gray value LUT.

File... Click on the File... button to open the standard dialog box for the opening and loading of files. Files will be saved using the LUP format.
**Linear.** This function sets the polygon of the active color back to linear (0 – 255).

> The LUP format cannot be used by Imaging C functions to alter the lookup table of an image. As a consequence, you should save the LUP-type palettes as LUT files as well (see above). Additionally, only the LUT files but not the LUPs will be listed in the False-Color... dialog box (see above).

### 6.2.10.3 The Formula tab

**Red, Green, Blue** check box. If the check box on the left side is not selected, the corresponding LUT will be given a constant value of "0". Otherwise, enter the formula, which defines the function of the corresponding palette in the fields **Red**, **Green** and **Blue**.

**Writing a Formula.** The pixel value \( n \) is the variable for the X-axis. If you change a formula, the function will be computed with all values between 0 and 255 and the result displayed in the diagram. Simultaneously, the image is continuously updated on the monitor using this palette. You can use all expressions allowed in Imaging C. Note the following guidelines:

- In case all constants in the formula are whole numbers (without decimal point) all results will be treated as integers instead of floating point numbers, i.e., the digits after the decimal point will be ignored. The result may be steps instead of smooth curves. Thus, all constants should be provided with a point (e.g., 100. or 100.0) to enable calculations with the precision of floating decimal point operations.
- Multiplication and division operations will be performed before addition and subtraction. If necessary, use brackets.
- \( n \) may have a value of "0". Thus you should avoid using \( n \) as a denominator. You could divide by \((n+1)\) instead.
- Take note of any error messages that appear in the status bar of the OV100 window after you’ve completed inputting your formula. Messages appearing while writing the formula can be ignored.
- You can also use Imaging C expressions such as the operators "\%", "&" and "?"
- The pixel value $n$, normally an integer ("long" format), can be converted into a decimal number ("double" format) by typing `(double)n`.

**Examples.**

Power: $n$ to the power of three = `pow(n, 3.)`
Square root: `sqrt(n)`
Logarithm: `log(n)`

Use the following examples for applying the "%", "&", and "?" operators to create some typical curves:

- `(n & 64) * 4`: rectangular signal (in binary format, all bits of $n$ that are not identical to those of the constant will be ignored)
- `(n % 64) * 4`: sawtooth signal (the constant, here 64, will be subtracted from $n$ multiple times as long as no negative value results)
- $n / 32 * 32$: step function (unless the divisor is converted into a floating point number by typing a decimal point, see above)
- `(n < 128) ? 0 : (n-128)*2`: different formulas, section-wise (read: if $n < 128$ then set to 0, otherwise...)

**Limit.** Select the **Limit** check box to have your result set to "255" in case of an overflow and to "0" in case of an underflow. If **Limit** is not marked, the values over 255 will all be set to "0". Values below "0" will be set to "255".

**File...** Click on the **File...** button to open the standard dialog box for the opening and loading of files. Files will be saved using the LUF format.

---

The LUF format cannot be used by Imaging C functions to alter the lookup table of an image. Therefore, it is necessary to save LUF-type palettes as LUT files as well (see above). Again, only LUT files but not the LUFs will be listed in the **False-Color...** dialog box (see above).

**Linear.** When you click on the **Linear** button, all formulas will be reset to $n$. This corresponds to the linear standard LUT coordinates of $(0,0)$ and $(255,255)$. 

6.3 Image Navigation

6.3.1 General

In most cases the acquired images are multi-dimensional, i.e., they consist of image stacks of different color channels, time sequences or z-stacks. With the commands in the Navigation toolbar you can easily select single images out of an acquired image sequence to be displayed in the Viewport.

6.3.2 Multi-Color Images

Multi-color images consist of sequentially acquired images with different illumination settings. For example: A sample is labeled with three different fluorochromes. The resulting multi-color image acquired with three different excitation filters is displayed as an overlay of the three different color bands. To view the individual color bands, click with the left mouse button on the arrowhead of the Select Color Channel button and select from the shortlist that opens. To select additional color bands use <Shift> + left-click. The currently displayed color channels are marked in the shortlist. The selected color bands will be displayed exclusively in the Viewport; the other channels will be hidden.
6.3.3 Displaying Different Color Bands in the Tile View Mode

It is possible to individually display all color bands of a multi-color image at the same time in different Viewports. To do so a suitable Viewport arrangement has to be chosen with the **Arrange Viewports** button in the Viewport button bar (see Chapter 6.1, *The Viewport*). Consider a triple-color image: a 2x2 Viewport arrangement could be useful. The image can be displayed in each Viewport via drag&drop selection from the Image Manager list. Then the **All Color Channels** view can be selected for one Viewport while each of the individual channels can be selected in one of the three others.

**Note.** If more than one Viewport is activated via `<Shift> + click`, navigation through time and Z – as explained in the next chapters – will be carried out for all Viewports simultaneously.

6.3.4 Time-Lapse Sequences

**Navigate Time**

In time-lapse experiments the images are subsequently acquired, according to the parameters defined in the time-lapse properties page, and stored as an image stack. Selection of a time sequence in the Image Manager enables the **Navigate Time** button in the **Navigation** toolbar.

**First, Previous, Next and Last**

With the **Previous** and **Next** buttons in the **Navigation** toolbar, you can navigate frame by frame backward or forward, respectively, through the time sequence. The **First** and **Last** buttons can be used to display the first and the last image, respectively, of the acquired time series. The number within the field represents the number of the currently displayed frame. You can directly go to a specific frame by typing the respective number into the **Go to** field and pressing the **Return** key. Alternatively you can click with the mouse into the Viewport to update the image displayed.

**Animate**

An additional feature enables the user to animate the acquired image sequence. Pressing the **Animate** button opens the **Animate Image Stack** window.
Here you find the buttons to start (Play) the animation, to Stop it and to play it in the Revers mode.

**Reverse, Stop and Play**

Alternatively you can navigate frame by frame through the image stack, or go directly to the first and the last frame, respectively.

**First Frame, Previous Frame, Next Frame and Last Frame**

The slider displayed at the bottom of the window indicates the position of the currently displayed frame within the sequence. Furthermore, the Animation tool gives you the possibility to mark a subset of frames within the image stack to be animated. To do so, move the slider to the desired starting frame position and click on the Mark In button. Then move the slider to a subsequent frame, click on the Mark Out button to set the end frame for the slide show. The selected frame scan will be highlighted in blue in the slider bar.

**Mark In and Mark Out**

If you now press the Play button only the range of frames within the blue bar is animated. The parameters for the animated slide show are defined in the Options of the Animate Image Stack window. To open this dialogue press the Options button. Here you can set the parameters, which define how the image stack is animated.

**Options**

**Frame rate.** In the field you can adjust the number of frames displayed per second.
Loops. In this dialog box you can choose how often the image stack is to be played. Choosing Play, you can define how many time(s) the loop is played. Selecting the Auto Repeat button, the image stack animation is continuously repeated until stopped.

Direction. In this field you can select the direction of the animation. Choose here whether the stack is animated uni-directionally (→) or meandering back and forth (↔).

6.3.5 Z-Stacks

Navigate Z

In Z (3D) experiments stacks of images are acquired at different focal planes. If a Z-stack is in the active Viewport the Navigate Z button is enabled in the Navigation toolbar. You can navigate and animate the Z-Stack in the same way as described for time-lapse experiments in the previous chapter.

6.3.6 Multi-dimensional Sequences

Data sets are not limited to three dimensions in the OV100 Imaging Software. You can acquire image sequences with up to five dimensions: the three spatial dimensions plus time and color. The Navigation toolbar allows selecting through which dimension to navigate: either time or Z. If the Navigate Time button is activated the navigation tools work with respect to the time axis, if Navigate z button is activated they work with respect to the Z-axis. The Select Color Channel button is always active to enable the selection of individual color channels.

Navigate Time selected

6.3.7 Parallel Navigation in Multiple Viewports

If a multiple Viewport arrangement is selected (see Chapter 6.1, The Viewport), it is possible to navigate through several data sets (or different color band selections of the same set) in different Viewports simultaneously. To do so more than one Viewport has to be active. Multiple activation is achieved via <Shift> + click.
The data dimensions have to match for this operation. For example, one cannot navigate through a Z-stack and a time-series simultaneously. However, it is not necessary that the dimensions present in the data sets have the same size in X, Y, Z and time. It thus is possible, for example, to navigate through a short and a long time series at the same time – up to the last frame of the short series.

6.4 Projections and Extended Focal Imaging

6.4.1 Projections Along the Z and Time Axes

Projections are a means to condense the information of an entire Z-stack or time series into a single image. Most useful, probably, is the Maximum Intensity projection. The algorithm checks each single image of a stack or series for the brightest intensity at any given X/Y position and uses this for the projection. The Minimum Intensity projection and Average Intensity projection are calculated analogously. The functions can be selected from the pick lists of the Navigate Z and Navigate Time buttons.
The projection functions in the pick lists of the Navigate Z and Navigate Time buttons do not create a new image. The projections are only displayed temporarily. In order to generate new projection image data choose the projection commands from the Process ➤ Projection menu.

### 6.4.2 EFI – Extended Focal Imaging.

The EFI function can be regarded as "sharpness projection" for Z-stacks (time sequences are not accepted as source files). The algorithm extracts the image features with the sharpest contrast from all layers of the stack and merges them into a single image. To execute the command select Process ➤ Extended Focus Projection.

EFI works well for transmission images and deconvolved fluorescence data. However, the out-of-focus blur in fluorescence widefield images often impedes useful results.

### 6.5 Fluorescence and Transmission Image Overlay

The selective fluorescence labeling of sub-cellular structures causes – consequently – that often a cell is not visible entirely. To see where the fluorescent structures are located in the cell, it is possible to overlay fluorescence and transmission images – possibly taken with contrast enhancing methods – in the display. This requires identical X/Y dimensions of both images. Multi-dimensional image sets can be overlaid either with single images (snapshots) or with multi-dimensional image sets that have the identical number of time points and Z-layers. The procedure is straightforward:

1. Activate the fluorescence image; it can be monochromatic or multi-colored.

2. Open the short-list of the Select Color Channel button and choose Select Transmission. A dialog box opens that lists the images that would fit for an overlay.

3. Choose the desired image and click OK. The Viewport shows the resulting overlay image.

4. Deselect the option Overlay Transmission in the shortlist mentioned above to remove the overlay.
The overlaid image is not a new data set; it only exists on-screen. No new file is written into the database. To create an overlaid image as new data set use Edit > Copy and Edit > Paste (<Ctrl+c> and <Ctrl+p>) and store the new image. This image is a (3x8) bit RGB image, not an (nx16) bit image.

### 6.6 Intensity Modulated Display

Images sets that are created by pixel-by-pixel division of source images or color channels, most significantly those resulting from Delta F / F or Ratio calculations (Chapter 10.7, Delta F / F (ΔF/F) Analysis, and 10.8, Ratio Analysis) have one disadvantage: they do not reveal if a certain ratio results from an area of originally rather intense or rather dim fluorescence. The ratio of two small numbers may, after all, be similar to that of two large numbers. This effect often causes a loss of structural information in the ratio images.

To give an example, the Intensity Modulated Display allows to modulate the intensity of a false-color ratio image (middle image below), may be one with a Rainbow palette (Chapter 6.2.9, False-Color…), with the brightness information of the original image (left image below). The resulting intensity modulated ratio image is on the right and has an appearance that is much more similar to that of the original image than the standard ratio image.
7 Image Data Handling

If the system is configured thoroughly all images will have the correct size calibration automatically. Nevertheless, here it is explained how to adjust the calibration. The software offers the possibility to show a scale bar and a color palette bar in an image overlay. Objects and texts can be added manually to an image overlay. It is possible to extract sub-sequences out of multi-dimensional image sets or to combine images.

7.1 Calibrate Images

7.1.1 Why Calibrate Images?

Without a proper image and input calibration you cannot expect to obtain correct distance measuring results when using the commands of the Image Analysis > Measurement menu. Even drawing the scale bar into the image assumes correct image calibration. Sometimes it is necessary to recalculate an image, e.g., after loading third party images, or if the system calibration is no longer valid but the dimensions of specific structures in the image are known. If the system does not have a communication link to the microscope, it is the user’s responsibility to adjust the magnification to correspond to the true magnification. The term magnification can be defined as the ratio of original specimen size / hard copy or original specimen size / screen display or some other standard. This has to be decided by the user and will reflect the application.

7.1.2 Calibrating the Camera Channel

It is very convenient to calibrate the channel with a magnification of 1. Thus, if the magnification of the different objectives is set correctly in the OBS Configuration software, see Chapter 15.3.3, Configuration of the Objectives, all images acquired will automatically have the correct XY-calibration (ignoring certain slight variations in the magnification of individual objectives due to the manufacturing process). In order to do the calibration, the camera CCD chip pixel size has to
be known. Both for the FView-II-T camera as for the Orca ER camera the pixel size is 6.45 microns.

1. Open the XY Calibration tab in the Acquisition ➤ Camera Configuration dialog window.

2. Click the Unit button to open the Set Unit dialog window and select m as Basic unit and µ as Scale and confirm with OK.

3. Back in the Configure Input dialog window set Magnification to 1 and X calibration and Y calibration to 6.45.

4. Click Save to open the Magnification Table.
5. Click **Add** to load the new settings. The following message will appear; it refers to the default settings. Click **Yes** to accept.

![Image Data Handling](image.png)

6. Click **OK** to confirm the new Magnification Table.

7. Click **OK** to confirm the new XY Calibration settings.

### 7.1.3 XY-Calibration

Using the **Calibrate Image** dialog box (to be opened via **Image > Calibrate Image...**) you can recalibrate the image of the active image buffer. Please proceed as if you were calibrating an input channel. The **XY-Calibration** tab is designed like the corresponding tab of the **Configure Input** dialog box (see the previous chapter).

![Calibrate Image](calibrate_image.png)

If the exact magnification of the objective is known (there is a certain tolerance here caused by the manufacturing process) calibration is straightforward. Image pixel size is CCD chip pixel size (as specified by the manufacturer) divided by magnification. If the magnification is not known a calibration specimen of known size can be used.

**Example.** The cameras F-ViewII and Hamamatsu Orca ER both have CCD pixels size of 6.45x6.45 microns. An image pixel size of 6.45/60 = 0.1075 microns in X and Y results in case of a 60x objective.
How to calibrate the active image with a fixed X/Y ratio and unknown pixel size:

1. Select the image.

2. Execute the Image ▶ Calibrate Image... command.

3. Set the magnification in the Magnification box.

4. Click on Unit... and select an appropriate Basic unit (usually meter) and Scale (usually micro) in the Set Unit dialog box.

5. Select the Fixed check box and enter the X-to-Y axis ratio in the X/Y ratio field, most always it will be 1.

6. If the calculated value (CCD pixel size/magnification) is sufficiently accurate, type it into the X calibration box. The Y calibration value will be automatically set. Exit with Ok.

7. Otherwise enter the Calibration length for the length of the calibration object or structure.

8. Check the box Horizontal or Vertical or Arbitrary.

9. Start the calibration with the Calibrate button.

10. Select the beginning of the calibration structure with the line cursor and click; select the end of the calibration structure with the second line cursor and click again.

11. Click on OK to confirm the calibration.
7.1.4 Z-Calibration

**Z-Offset.** This parameter refers to the absolute position of the lowest layer Z-stack and is of minor importance. It is read in automatically when loading OV100 data.

**Z-Spacing.** This is the step width between two neighboring layers of a stack. It is read in automatically when loading OV100 data.

**Unit...** This function opens the same Set Unit dialog box as in XY Calibration tab.

---

7.2 Scale Bar

7.2.1 General

Use this command to display a scale bar in the overlay plane. In all scientific reports, the calibration of an image must be specified which can be done with this command. This tool is useful for making video prints, hard copies, or exporting images to word processing applications, because the inherent calibration is visualized in the image. It may be necessary to choose a different location or a specific length for the scale bar. Both can be defined in the Scale Bar Properties dialog box. The scale is part of the overlay plane (see Chapter 7.5.1, Overlays – General) and does not interfere with the image data, thus it can be activated and deactivated any time.
7.2.2 Setting the Scale Bar Properties

The Properties dialog for the Scale Bar is opened via Image Analysis ➔ Scale Bar ➔ Properties....

Display page:

Scale bar Selection field. Here you select if a Horizontal and/or a Vertical Scale Bar are to be shown. A Palette bar depicts the color/gray scale coding of the light intensities and is especially useful for images displayed with a pseudo-color palette.

Show scale bar for field. In case images are to be printed or exported to the clipboard with the scale the respective boxes have to be checked.

Format and Size pages. Here the style and size of the bar and the dimension units can be set.

7.2.3 Show in Viewport

The display of the scale bar is activated and deactivated by clicking on Image Analysis ➔ Scale Bar ➔ Show in Viewport or using the short cut <Shift+F4>. The same can be done in the Show scale bar for Viewport box on Image Analysis ➔ Scale Bar ➔ Properties... ➔ Display.
Unlike the **Draw into Overlay** option, the **Show in Viewport** option effects that the Scale Bar is shown in each field of the Viewport.

### 7.2.4 Draw into Overlay

As opposed to the **Show in Viewport** option, with the **Draw into Overlay** option in **Image Analysis > Scale Bar**, the Scale Bar is shown only in the currently active image.

### 7.3 Show Markers, Time and Z Information

The Experiment Manager allows the user to set markers by hand (mouse click) during the execution of an experiment. This is useful to mark certain actions that are carried out or events that happen during an experiment.

While the markers are always shown in a Kinetics graph, they are displayed in the images only if the option **Image Analysis > Show Markers** is activated by mouse click.

With this option activated, the time and Z information of the displayed image will shown at the bottom left corner as well.

![Marker Example](54.49µm 00:12:351)

### 7.4 Grid...

Use this command to place a measuring grid – of arbitrary size – over an image. A dialog box is opened by this command for determining the size of the grid frames and the color of the grid lines.

**Imagesize**. The **Imagesize** field contains the size of the active image in the calibration unit.

**Gridsize**. Determine the size of grid frames in the **Gridsize** field. Enter the width and height of the grid frames in the **Horizontal** and **Vertical** fields – in the unit of image calibration. Values between a minimum of 10 pixels and a maximum of the image size can be selected. The minimum value of 10 pixels will be calculated automatically if you type 0. The grid size is displayed in the upper left corner of the overlay, as long as the Label fields check box has not been selected.
Normally one digit after the decimal is displayed. If you would like more than one, make the following entry in the ANALYSIS.INI file in the OV100 program folder on the hard disk for as many places desired – e.g., 2:

```ini
[SYSTEM]
MesGridDigits=2
```

**Options** group.

**Use starting point.** Select the Use starting point check box – along with the Interactive button – to determine grid frame position in the image. If you clear the check box, the grid will always start in the upper-left corner of the image at the coordinates 0,0.

**Label fields.** Select the Label fields check box to have grid frames numbered in the overlay: Rows are designated by the letters A, B, C, ... AA, AB, AC, ..., WW; columns by the numbers 1, 2, 3, ..., 99. Each frame can be precisely identified, e.g., CF12. Grid frames are not numbered, if the text does not fit into the frames. To have grid frames labeled, the grid frames will have to be in that case enlarged. If you select the Label fields check box the grid size will not be displayed.

**Automatic gridsize.** Select the Automatic gridsize check box to have height and width of grid frames automatically adjusted to fit the minimum number of grid frames. Enter this value in the minimum of fields box. This number is based on the width of the whole image. The lowest value possible is 2 frames, the highest 50. With the Automatic gridsize, the grid frames' shape will correspond to the X/Y proportions of image calibration. An X/Y proportion of 1 results in square grid frames. The current values for height and width are displayed in the Gridsize group. Not all adjustments to the minimum number of fields result in a differing frame size because height and width are restricted to standard sizes such as 1, 2, 5, 10, 20 in the unit of image calibration and so on. For example, an image of 125 mm in width will have frames of 20 mm width if the minimum value entered is 3-6. For values between 7-12, the frames will be 10 mm wide.

**Colors** group. Here you can determine the color of the grid and the overlay text.

**Draw** button. Click on the Draw button to have the grid at its current settings drawn into the overlay. In addition, cell size or alternatively numeration of the grid frames will be written into the overlay, depending whether the Label fields check box has been selected or not. The dialog box will remain open so that various settings can be tried and immediately checked on screen. Each
new setting will delete the previous grid and its settings. Depending on the position of the dialog box, it may have to be moved per mouse to be able to view results of setting changes in the image document.

**Interactive** button. Click on the **Interactive** button to be able to determine grid frame size and position interactively within the image document. A red rectangle will appear in the overlay displaying the dialog box settings. If a grid has been written into the overlay it will be deleted when you click Interactive. Keeping the left mouse button pressed, move the mouse to enlarge or diminish the rectangle to set the size of the grid frames. If the **Use starting point** check box has been selected, the starting grid frame, - i.e., the red rectangle - can be positioned as desired within the image. The grid will then start not in the upper left corner but rather where the red rectangle has been positioned. Right-click to have the grid drawn as defined and to return to the dialog box. The current values for height and width are displayed in the Gridsize group.

### 7.5 Overlays

#### 7.5.1 General

The **Overlay** is used to add information in form of text, markers, or other graphical elements to an image. Although image and overlay form a unit, the data are stored independently on the computer’s hard disk. Imagine the overlay as a transparent foil covering the image. Drawing and changing the overlay does not affect the image data. Moreover, you can fade out or delete the overlay at any time. So you can be sure to get the true data if you compute a histogram or if you measure the pixel values of your image, even though you have overlay elements present.

**Overlays are vector graphics**

Images are stored in a bitmap-like format that contains information about each individual pixel. In contrast to the image, the overlay is stored as a vector graphic. A line, e.g., is characterized by a starting point, an ending point and a color. This vector graphic is then converted to a scanned graphic to be displayed with the image on the screen. Exceptions are the overlay elements **Image** and **Symbol**. These are bitmaps added to the overlay.

#### 7.5.2 Activating the Overlay Toolbar

![Overlay Toolbar](image)

Activate the toolbar by selection in the pick list that appears when right-clicking on any button bar or via **Image Analysis > Overlay Toolbar**.
7.5.3 Creating and Editing Overlays

Edit Overlay

This button allows you to select an existing object in an overlay. Upon clicking the button the cursor automatically moves into the image and is confined to this area until a right mouse click terminates the Edit function. Any object active at this point can be edited with the overlay tools. Clicking into an empty area of the overlay while being in the Edit mode deactivates any active object. Once active you can change size and shape of objects by mouse drag. To select more than one object use the shift button while clicking.

Select All , Select None

A mouse click toggles between the two buttons used to select or deselect all objects.

Object Properties

This button opens the corresponding dialog, which is different for Text, Lines and Highlight fields. The tools are self-explaining and similar to those in other common software programs and need not be explained here.
This button opens a pull down menu with the following commands:

**Image And Overlay.** Use this command to display the image and the overlay simultaneously.

<table>
<thead>
<tr>
<th>Warning: This is a global setting, i.e., this flag determines the display of the image overlay for all images loaded. It is recommended to remove this flag only at specific times and for particular purposes.</th>
</tr>
</thead>
</table>

**Image Only.** Use this command to show the image without the overlay. When this command has been selected, only the current image will be displayed on the screen without any overlay. This is a global setting, i.e., this flag determines the display of the image overlay for all images loaded. **Effect on other commands:** The overlay display mode has an effect on the following functions: If the **Only Image** display mode is active, all images will be printed without overlays. The image only will be copied into the clipboard, i.e., if you paste the contents of the clipboard into another application, the image will be inserted without overlay. Use the **Copy** command (in the **Edit** menu) or the `<Ctrl+c>` keys to copy the image into the clipboard.

**Overlay Only.** Use this command to show only the overlay (without the image). When this command is selected the defined overlay will be displayed without any background image. You will see the overlay superimposed on a black screen. **Warning:** This is a global setting, i.e., this flag determines the display of the image overlay for all images loaded. The overlay display mode has an effect on the following functions: If the display mode **Overlay Only** is active, OV100 will only print image overlays.

**Burn Overlay**

This function is currently disabled.

**Delete Layers**

This command deletes the entire overlay. The command **Image Analysis ➔ Delete Overlay** has the same function.
**Load Objects**

This command enables you to load a previously stored overlay file (*.ovl) from a storage medium. Other object types that can be loaded are bitmaps (*.bmp), icons (*.ico) and enhanced meta files (*.emf).

**Save Objects**

This command stores all objects selected into an overlay file (*.ovl). The button remains disabled if no object is active.

**Cut Objects, Copy Objects, Paste Objects**

These commands work only on the overlay objects but otherwise have the same functions as in any common software. The typical key combinations **<Ctrl+x>**, **<Ctrl+c>**, **<Ctrl+p>** do NOT work here but start the Cut, Copy and Paste commands, respectively, for texts and single images. If no object is selected the entire overlay will be cut or copied.

**Bring to Front, Send to Back, Bring Forward, Send Backward**

If several layers of overlays exist, positions can be changed with these commands in case of overlaps. This only applies if several objects have been loaded. Objects created with the overlay drawing tools are always located in the same layer.

**Text**

This command allows writing a text into the overlay. Initially a rectangle is displayed on the image to indicate the size and position of the text. This box has to be positioned by mouse. With the pressed left button the size can be adjusted by dragging. A right mouse click opens the **Object Properties** dialogs for **Text** where the text can be typed in and the fonts, colors etc. chosen.

**Rectangle**

Enables rectangular boxes to be drawn. Position the top left corner of the rectangle as desired, then depress the left mouse button to create a rectangle of the desired size. Right-click to superimpose the box.

**Ellipse**

Enables ellipses to be drawn. Position the top left corner of the rectangle that describes the
ellipse as desired, then depress the left mouse button to create an ellipse of the desired size. Right-click to superimpose the box.

---

**Line**

Enables straight lines to be drawn. Position the mouse cursor at one end of the desired line, left- or right-click, and move the cursor to the opposite end, then click again.

---

**Arrow**

Enables variable arrows to be drawn. Position the mouse cursor at the desired start position of the arrow. Pressing the left or right mouse button and moving the mouse, the arrow length and its direction can be varied. Click the mouse button again to superimpose the arrow.

---

**Polyline**

Click on this button to draw a polyline into the overlay. Keep the left mouse button pressed and move the mouse to draw freehand. Define the polygon pointwise by clicking the left mouse button on each point. Straight lines then connect points automatically. Right-click to confirm the polygon.

---

**Polygon**

Click on this button to draw a polygon into the overlay. Keep the left mouse button pressed and move the mouse to draw freehand. Define the polygon pointwise by clicking the left mouse button on each point. Straight lines then connect points automatically. Right-click to connect the end points of the drawn line automatically to form the polygon.

---

**Highlighter**

Click on this button to place a colored transparent foil on an image section. Using this option you may effectively emphasize special image features. Drawing is done as for Rectangles. If you choose "Invert" instead of a color in the Object Properties dialog for a highlighter, the highlighted image section will be inverted.
7.6 Separate

This operation allows dividing a multi-dimensional data set within one dimension (time, Z or color) into several independent subsets. Available. The commands for dimensions not contained in the data set are disabled, like Z-Layers in the screenshot above.

- **Color Channel.** This command decomposes a data set into its color bands.
- **Z-Layers.** This command decomposes a data set into its Z-layers.
- **Time.** This command decomposes a data set into its time points. For example, a series of Z-stacks will be separated into the individual Z-stacks.

7.7 Extract...

This command enables you to extract a subset of data out of a multi-dimensional data set.
The ROIs tab
It is possible to crop a single image or an image set in the XY plane. The area to be cropped is defined via an ROI (see Chapter 10.4, Regions of Interest – ROIs). If the image contains already ROIs select one from the list. Otherwise define a ROI with the ROI drawing tools (via the Define button; it has the same function as the ROIs button of the Complex Analysis toolbar). If an elliptical or free-hand ROI is used a rectangular area that circumscribes the ROI will be used for the cropping.
To enlarge the cropping area by a number of pixels in the ±X and ±Y directions type a value into the Border [pixel] box.
Execute the cropping by clicking OK.

The Dimensions tab
Here you have to define the Color Channels and range (From / to) of Z-Layers and time points (Time-Frames) to be extracted. By setting a step size higher than 1 you can opt to extract only every 2nd, 3rd and so forth layer or frame.
Execute the cropping by clicking OK.

7.8 Combine...

7.8.1 General

OV100 allows to fuse individual data sets within the color, time and z dimensions to generate larger data sets. Prerequisite for such an operation is that the data sets have the same size in the two other dimensions and in X and Y (width and height). For example, it is possible to combine two full frame time sequences of 50 images each into one sequence of 100 images as long as both contain the same number of color channels. On the other hand, let’s assume the two series are monochrome, a combined time series of 50 dual color images could likewise be generated.

7.8.2 Combining Data Sets

The Combine box is opened with the Combine button or via Image Analysis » Complex Analyses » Combine...
**Combine Mode** field: Determine here in which dimension the combination is to be performed. For example, to create a multi-color image out of several snapshots select **Color**.

**Feasible image objects** field: All loaded data sets with the same frame size as the active data set and the same size in the two dimension that are not chosen in the “Combine Mode” field, are listed here. For example, sequences with different number of images cannot be combined into a series of z-stacks. By default no data set is selected. The data sets to be combined with the active data set have to be selected by mouse click. The active data set will become the first part of the new set with the other sources being merged according to their data slot number.

**Sort according to real time / z-position**: Imagine the combination of several time sequences to one long sequence. If the sorting option is not selected the active sequence will become the first part of the combined sequence and the others will be added in order of the **Feasible image objects** list. If the sorting option is selected the software will check the time information of each sequence and combine the sequences chronologically. Analogously, in case of the combination of Z-stacks the Z-position will determine the final order if the option is activated.

### 7.9 Convert Image

#### 7.9.1 General

This command opens another menu containing the command to generate a negative image and three commands for increasing or reducing the number of bits per pixel – i.e., bit depth. This might be necessary if you wish to use images in other application programs. Images acquired with OV100 are stored and handled in a proprietary (nx16) bit format. Other application programs often are only able to read a certain bit depth. (3x8) bit (“true color”) is the standard bit depth for many graphical and image processing software. Here 8 bit of information is stored in each of the three color channels red, green and blue. The interplay of the three channels generates the colors displayed on a computer screen.
Another use for reducing the bit depth is to reduce an image’s bit depth to save memory. When you do this, however, you generally lose image information.

### 7.9.2 To 8-Bit

Use this command to convert OV100 proprietary (nx16) bit multi-color images into (nx8) bit multi-color images (with up to 256 colors per channel) or 16 bit gray-value images into 8 bit gray-value images (with up to 256 shades of gray).

**Info**

This conversion doubles the required storage space.

### 7.9.3 To 16-Bit

Use this command to convert (nx8) bit multi-color images into (nx16) bit multi-color images or 8 bit gray-value images into 16 bit gray-value images. This might be important if you want to carry out certain arithmetic operations.

In certain cases there is a different result between a conversion into (nx8) bit format where n=3 with the To 8-Bit command and a conversion into RGB ((3x8) bit) format. For example: consider a (nx16) bit image with a cyan, a yellow and a red channel. With the To 8-Bit command the result is an (nx8) bit [here (3x8) bit] image with a cyan, a yellow and red channel. With the To RGB (3x8-Bit) command, however, the data of the three original channels are distributed after rescaling into the red, the green and the blue channel so that the display remains the same (seemingly a combination of cyan, yellow and red). The contents of the three RGB channels, however, are not identical to the contents of the three channels resulting in the other case.

### 7.9.4 To RGB (3x8-Bit)

This command converts all other image types into the standard 24 bit (true color) RGB format. This might be necessary for the export of data because many other software programs can only read this format and 8-bit gray scale images.
7.9.5 Invert

Use this command to generate a negative of the original image. **Available.** This command is available for all types of images. It is, however, only available for false-color images if the False Color Images check box has been selected in the Image tab (in the Preferences dialog box, in the Special menu).

**Transfer function.** If the greatest number for gray value display is $G_{\text{max}}$, and $G$ stands for a pixel’s gray value in the resulting image, then, this pixel’s gray value will have the following value in the resulting image:

$$G = G_{\text{max}} - G$$

**What will happen...** For 8 bit images, $G_{\text{max}}$ equals 255. For 16 bit images, $G_{\text{max}}$ equals 65535. In binary images, the white areas will become black and vice versa.

7.10 Image Information

Use this dialog box to change the name of the active image buffer, to enter an image comment, and/or to have image information displayed.

How to open the Image Information dialog box:

- **Double-clicking on the image manager.** Double-click on any image buffer within the image manager to view information on that image – you can also alter this information. Double-clicking on an image buffer will automatically activate that image buffer.

- **<Alt+Enter> key.** Use these keys to view information on the image within the active image buffer.

**Image Manager context menu.** Right-click on any image buffer to open the corresponding context menu and then click on Image Information... The information then displayed refers to the image you right-clicked on – it doesn’t have to be the active one.

**Viewport Manager context menu.** Once an image is being displayed on the monitor, simply right-click on the relevant Viewport within the Viewport Manager to open the corresponding context menu and then click on Image Information... The information then displayed refers to the image you right-clicked on – it doesn’t have to be the active one.

**Image Document context menu.** Once an image is being displayed on the Windows monitor, simply right-click on the relevant Viewport within the image document to open the corresponding context menu and then click on Image Information... Besides basic image information – i.e., gray or color-values – you will see other information having to do with the image as well. This includes, for example, calibration data and/or any comments you may have made concerning the image. All this information is saved along with the image. You can access it via the Image Information dialog box.
7.10.1 The General Tab

The General tab contains general image information. This tab is accessible for any image loaded. The kind of information you get will depend on where you got the image from, and its file format.

**Image name.** The name can be changed; it can be up to 31 digits long.

**File name.** When you load an image, the File name field will contain that image file's complete path. An image you've processed in OV100 will retain the file name of the original image – as long as the processed image has not been saved under its own name. When acquiring an image using OV100 this field will be blank – until you have saved the image.

File names can be copied into the clipboard. Select the complete file name – using the mouse – and use the <Shift+Delete> keys. Use the <Shift+Insert> keys to get the file name from the clipboard – and put it, e.g., into a text document. This can be quite useful if you wish to refer to an image within a document.

When saving an image, OV100 will automatically suggest the image name for use as the name of the file.

**Warning.** Image name and file name are not the same within OV100. For example – say you name an image "yeast 02.25.2003 image 23" (its image name); you can save this same image under a file name such as "02250323.tif". Then, when you later re-load this image, the original image name will appear within the image buffer.

**Image buffer.** The Image buffer field displays the number of the image buffer currently containing the image. This number will of course change when you, for example, put the image into another image buffer.

**Memory size.** Displays the size of the computer memory used by the image.
File size. Gives the information about the file size if the image is stored as a file.

Frame. The Frame field displays the number of the current image and the total number of images of a data set.

Created. The Created field displays the time and date at which OV100 images were created – the date and time an image file was last altered will be displayed for other (non- OV100) images.

Channel. The Channel field displays the camera used to acquire a OV100 image. This field will be blank for images not acquired via OV100.

Magnification. The Magnification field displays the magnification used when the image was acquired via OV100. For some microscopes, OV100 can directly read out the magnification from the microscopes' remote control. Magnifications of images acquired in other application programs will always be defined as 1. Use the Image Analysis → Calibrate Image... command to adjust the magnification of an image acquired in another application program.

Resolution. The Resolution field displays image size (in pixels) and information depth (bits/pixel). For example, an entry of 768 x 576 x 16 would mean that the image width is 768 pixels; the image height is 576 pixels; and the image can have up to $2^{16}$ different color values per channel.

Width, Height. The Width and Height fields display absolute dimensions of OV100 images. These values are determined using the current image calibration. For other (non- OV100) images, these fields will simply display image width and height (in pixels).

Comment. The Comment field is for any comments you wish to make on an image.

7.10.2 The Dimensions Tab

The General tab contains general image information. This tab is accessible for any image loaded. The kind of information you get will depend on where you got the image from, and its file format. Dimensions field. Here the extension of a multi-dimensional data set in the dimension Time, Z, and Color are listed: number of points in time, number of layers and number of color channels.

Color Channels. The table lists the channels by name as well as wavelength (WL) in nm, exposure time during acquisition (Exp.) in ms and the binning factors in X and Y.

Markers. In case markers were set during the execution of an experiment they are listed here with Start and End times in ms and the given comments.
7.11 Record Image History

7.11.1 General

Processing and analysis of images often leads to modification of the data. With Record Image History..., OV100 provides you with a tool which will record the changes done to the original image.

7.11.2 Define Image History

Selecting Image ▶ Record Image History... opens the Define Image History dialog, where you can select the command groups to be recorded if applied to the acquired image.

Activating the recording adds an additional tab, called History to the Image Information dialog box. In this tab the modification applied to the acquired image is recorded, according to the previously defined command groups.

Currently only the type of modification is recorded – without the used parameters.
8 Image Processing

The following sections explain how images can be improved by data manipulation. This is in
difference to the display adjustments explained in the previous chapter. The shading correction
corrects for regular intensity gradients. A host of arithmetical filters is available to reduce noise,
enhance contrast or sharpen object edges. Deblurring algorithms filter out-of-focus haze.

8.1 Shading Correction...

8.1.1 General

Gradual noise and sensitivity variations across the CCD chip and the corresponding inherent
intensity gradients in the images are termed shading. The cause is a gradual mismatch of
photodiodes and on-chip microlenses. Shading correction is a type of background correction in
an image meant to compensate for irregular illumination effects.

8.1.2 Define Shading Correction

The Define Shading Correction dialog box is opened via Process ▶ Define Shading Correction
and used to set the parameters for a shading correction.

Assumed Deterioration
In the Assumed Deterioration field you can define the appropriate correction method for the
assumed cause of shading.

Multiplicative. Check here if it is assumed that the shading results from a multiplicative effect.
The shading correction will divide the current image by a correction image, the Source for
shading image.
Additive. Check here if it is assumed that the shading results from an additive effect. The shading correction will subtract the correction image from the current image. A new field will appear (in the lower center of the dialog box). Select the Invert check box to have the resulting image intensity-inverted after filtering, i.e., to get a negative image. Enter a gray value to be added to each pixel in the resulting image in the Offset field. This may help to adjust the display nicely afterwards, especially in case of transmission images.

Source for shading image
In this field you determine which image is to be used as correction image. This can be either the image itself that is being corrected itself (Source 1), or it can be a reference image from the Src 2 image buffer in the Image Manager (Source 2).

Preparation of shading image
Define here how the how the correction image, the Source for shading image, is to be preprocessed before the correction.

Use this option, if a reference image for correction has been acquired and does not need further processing. Such an image might either be taken without a sample or without illumination. The Source 1 option is disabled in case of this option because
otherwise the active image would either be divided by itself or subtracted from itself resulting in empty images consisting entirely of pixels with the value 1 or 0, respectively.

**NxN average filter.** The NxN filter is a smoothing filter to eliminate noise as explained in Chapter 8.2.15. It averages the pixel values in a square area – defined by the value in the **Size** field – around each pixel and assigns the result to it. This process can be repeated several times depending on the number set in the **Iterations** box. The resulting shading correction is also known as unsharp masking.

![NxN average filter](image)

**Interactive zero-level.** This is a useful option if obvious illumination gradient is visible in an image, for example due to the illumination not being centered correctly; see the left cell image below as a typical example.

**What will happen.** This method allows the user to select three background areas – called **Hotspots** here – in the raw image. The algorithm determines the average intensities in these areas and temporarily generates a background image with a corresponding regular intensity gradient and uses this for the correction.

**How to use this method.**

1. Select the **Additive** mode in the **Assumed deterioration** field of the **Define Shading Correction** dialog for this kind of shading correction.

2. Select the **Interactive zero-level** option, the **Define interactive zero-level** field will appear in the lower-left corner of the dialog box.

3. Set the size of the **Hotspot radius** (from 1 – 64).

4. Execute the **Processing ▶ Shading correction** command. The mouse cursor will carry a red cross surrounded by a red circle of the size set above.

5. Click in to a background region. The circle will be fixed in the image overlay.

6. Repeat this step twice in other background areas.

7. After the third **Hotspot** is set, the shading corrected image will be generated automatically.
Select the **Polynomial fit** option to have the correction image calculated based on a two-dimensional fit of the original image ("least-square fit"). If this option has been selected, a new group will appear in the lower left corner of the dialog box in the **Polynomial fit** group. This is where you determine whether the two-dimensional fit is **Linear**, **Square** or **Cubic**.

### 8.1.3 Executing a Shading Correction

The **Shading Correction** is executed via **Process > Shading Correction**. The shading correction as defined under **Define Shading correction** will be applied.

In case of multi-dimensional images the **Dimensions** dialog box opens. Here you can choose the range of images in the different dimensions (**Color Channels**, **Z-Layers** and **Time-Frames**) for which the analysis shall be performed in case only a subset of the data is of interest. By default the entire data set is selected. With the option **Step** in **Z-Layers** and **Time-Frames** you can select every second, third, fourth image and so on to be analyzed.
8.2 Filters

8.2.1 General

A **Filter** modifies the intensity of each pixel according to the intensity of neighboring pixels. **Why filter images?** Filters can be used to prepare the actual image analysis, for example by correction of image errors resulting from acquisition. Filter operations have the following possible applications:

- correction of image interference due to statistical noise,
- reduction of acquisition errors, e.g., CCD cameras sometimes provide erroneous gray values for individual pixels,
- restoration of poorly-focused images,
- suppression or accentuation of minute image detail,
- accentuation of basic structures such as gray value edges.

**Convolution filters.** Many of the filters in this menu are convolution filters. A convolution filter is defined using a **filter matrix.** A matrix can be described as a geometrical array of positive or negative whole numbers that serve as a mask placed over individual pixels. Any pixel that is to be re-calculated is situated at the center of the filter matrix. Most filters employ a 3x3 matrix. In this case the intensity of a pixel will be influenced by 8 of its neighboring pixels. Every pixel within a 3x3 matrix will be multiplied by the matrix element above it – by the so-called weight factor. For the filtering of the whole image the filter matrix will be shifted across the original image and the gray value of each pixel will be recalculated.
What will happen... \( W_1, ..., W_9 \) are the weight factors of a 3x3 filter matrix. \( I_1, ..., I_9 \) are the original intensities of an image area comprising 3x3 pixels. The intensity of the central pixel, \( I_5 \), after filtering, is calculated as follows:

\[
\text{filtering}(I_5) = \frac{W_1 \cdot I_1 + W_2 \cdot I_2 + \ldots + W_9 \cdot I_9}{\text{normalization factor}} + \text{offset}
\]

**Normalization.** In order for the filter operation not to alter average image brightness the result can be divided by a normalization factor. Normalization usually consists of the division of the sum of all weight factors, \(|W_1| + |W_2| + \ldots + |W_9|\). If the result is negative it will be set to a gray value of “0” [i.e., black]. Negative weight factors in the filter matrix will yield negative intermediate results. When an offset is added, negative values will be displayed in the resulting image. If the result turns out to be greater than 255, it will be set to 255 [white].

Example. The application of a filter for a numerical example is calculated as follows:

**Filter classes.** The various types of filters can be divided into various classes. This division has more to do with the application of the filters than their mathematical realization.

**Derivative filters.** Negative weight factors are admitted in the filter matrix of derivative filters and the sum of the weight factors equals zero. The result for homogeneous gray value areas is 0: a black area. On the other hand side, gray-value edges – i.e., the edges of objects within an image – and intensity gradients become accentuated. These filters can aid you as far as edge extraction is concerned. The occurrence of differential terms will however increase image noise.

**Rank Filters.** The Rank Filters comprise a filter class of their own. An environment of the central pixel is defined here – with the filter matrix – specifying the adjacent pixels to be included in the rank operation. All gray values of the area surrounding the central pixel will be sorted according to magnitude – in descending order. The various rank filters differ as to which element of the ordered sequence is to replace the central pixel. The adjacent area in the following example consists of 5 pixels arranged in the shape of a cross. The rank filter then generates an ordered sequence and assigns the mean value of that sequence to each central pixel. The Sigma filter is for filtering out statistical noise. Individual pixels of gray values which deviate greatly from their surrounding area will, however, not be affected by the Sigma filter.
**Smoothing filters.** The Smoothing filters class comprises filters for averaging gray values surrounding a pixel. This eliminates minor gray value peaking as well as statistical noise. At the same time, any gray-value differences that contain image information will be flattened out. The resulting image will thus seem somewhat blurry due to this type of filtering.

**Applications of various smoothing filters.** The diagram below comparatively shows the effects of various filters used for smoothing purposes. The original image consists of a simple rectangle of light shading upon a dark background. The image has strong noise amplitude interference. In addition, the image contains so-called ‘shot-noise’ – i.e., individual pixels have an intensity deviating strongly above and below the image’s average gray value. Each image has its intensity profile displayed superimposed on the rectangle within the image. The Mean filter and the NxN filter broaden the structure of the rectangle. The more powerful the smoothing effect, the more noticeably will the morphology of the object within the image be altered. Shot-Noise will not be removed, rather these noise pixels will simply be broadened and their intensity will be adapted to the image’s average intensity. The extent to which the NxN filter broadens edges will depend on the parameters set. The Median filter reduces noise without broadening the rectangle and eliminates Shot-Noise completely.

**Filter parameter.** There is a distinction between predefined and (user-) definable filters. Parameters of definable filters can be set, thus allowing you to adjust the filter’s effect.

In the following chapters the available filters (Process ▶ Filter) will be explained in detail. Before using the User Filter and the NxN filter certain parameters have to be set in the respective
Define dialog boxes (Process > Define Filter), otherwise the settings of the last usage will be taken by default.

8.2.2 Sharpen I

**Application.** Detail emphasis

The Sharpen I filter belongs to the class of derivative filters and amplifies the central pixel relative to the X- and Y-axes. Image details become emphasized by an enhanced contrast. Thus the image will seem to have increased focus. The Sharpen I filter enhances, however, noise as well.

Matrix.

\[
\begin{pmatrix}
0 & -1 & 0 \\
-1 & 5 & -1 \\
0 & -1 & 0 \\
\end{pmatrix}
\]

**Comparison.** The overall effect is opposite to that of a smoothing filter.

8.2.3 Sharpen II

**Application.** Detail emphasis

Matrix.

\[
\begin{pmatrix}
-1 & -1 & -1 \\
-1 & 9 & -1 \\
-1 & -1 & -1 \\
\end{pmatrix}
\]
Comparison. This filter is similar to the Sharpen I filter but has a more pronounced effect.

8.2.4 Differentiate X

Application. Extraction of gray value edges in the Y dimension
Use this derivative filter to detect gray value edges parallel to the Y-axis; gray-value modulations will be enhanced horizontally while they become filtered out vertically. Image noise should be rather limited as this filter is susceptible to image interference.

Matrix.  
\[
\begin{pmatrix}
0 & 0 & 0 \\
2 & -2 & 0 \\
0 & 0 & 0 \\
\end{pmatrix}
\]

Comparison. If you wish to extract all edges of an object then select either the Laplace I or Laplace II filter.

8.2.5 Differentiate Y

Application. Extraction of gray value edges in the X dimension

Matrix.  
\[
\begin{pmatrix}
0 & 2 & 0 \\
0 & -2 & 0 \\
0 & 0 & 0 \\
\end{pmatrix}
\]

Comparison. This filter is analogous to the Differentiate X filter but enhances edges parallel to the X-axis.

8.2.6 Laplace I

Application. Extraction of gray value edges
The Laplace I derivative filter accentuates edges and smaller image structures in both the X and Y dimension. It enhances, however, noise as well as.

Matrix.  
\[
\begin{pmatrix}
0 & -1 & 0 \\
-1 & 4 & -1 \\
0 & -1 & 0 \\
\end{pmatrix}
\]
Comparison. If you wish to have image edges accentuated only along one axis then select the either the Differentiate X or the Differentiate Y filter. Compare the Sobel filter as well.

8.2.7 Laplace II

Application. Extraction of gray value edges

Matrix. 
-1 -1 -1
-1  8 -1
-1 -1 -1

Comparison. This filter is similar to the Laplace I filter but has a more pronounced effect.

8.2.8 Mean

Application. Smoothing
The Mean filter replaces every pixel with the arithmetical mean of that pixel and its eight neighboring pixels. This results in noise reduction. Abrupt gray-value transitions will also be smoothed over however, thus appearing blurry after averaging. The Mean filter is a particular NxN filter based on a 3x3 neighboring pixel area.

Matrix. 
1  1  1
1  1  1
1  1  1

8.2.9 Median

Application. Removal of "bad" pixels
The Median filter removes isolated – "bad" – pixels with intensities that differ strongly from the surrounding pixels. Neighboring constant gray-value ranges (to these pixels) as well as edges remain untouched. The filtered image thus loses none of its original sharpness.

What will happen... The Median filter is a smoothing filter from the rank filter class. A pixel’s value as well as the values of its eight neighbors will be ranked according to their magnitudes. The middle value – the 5th one out of nine – will be assigned to the central pixel. Extreme gray values will always be located either at the top or bottom of this listing - and will thus never be
assigned to any of the pixels. They thus disappear from the image. This suppresses noise points – and non-extreme unevenness will be smoothed out.

**Comparison.** The Median and Mean filters are directly comparable. When neighboring pixels’ gray values are distributed symmetrically with respect to the average value, both filters will yield the same results; asymmetrical gray value distribution will yield varying results with the two filters. The Median filter is numerically more stable – i.e., it reacts less sensitively to individual, greatly deviating values.

### 8.2.10 Pseudo Filter

This command is based on the definitions set in the **Processing > Define Filter > Pseudo** dialog box.

**Application.** Relief-like appearance with "shadows"

Filtered images will appear topographical as if a relief-like surface is illuminated by an oblique light source. Dark objects will appear as depressions, and light objects as elevations. This 'pseudo' three-dimensional display of image structure gives the filter its name.

**Matrix.**

```
0  -1  0  +128;
-1  2  0
0   0  0
```

The Pseudo filter registers transitions from light to dark pixels. Transitions going from light to dark are considered positive and transitions going from dark to light negative. The image will be normalized such that the zero level is assigned to the value 128. This means that gray values between -127 and +128 are available.

**Comparison.** The pseudo filter is a derivative filters but not be compared with the other derivative filters **Sharpen, Differentiate** and **Laplace** filters.

**Define Pseudo: Contrast.** Set a contrast factor (0.01 – 100) – this will be multiplied by the weight factors of the filter matrix. The preset value is 2. The larger the factor, the larger the 3-D effect.

**Preview:** If this option is selected, the image will show sub-frame window with a preview of the filter result. The sub-frame can be set with the **Window** function.
8.2.11 Sobel

Application. Edge detection
The Sobel filter is a genuine edge detector and does not react so sensitively to noise effects. This is because differentiation is conducted using the lines and columns beyond the next-immediate ones. Thus any interference in lines and columns directly next to the central pixel cannot influence the results.

What will Happen. The Sobel filter employs a non-linear method for edge enhancement. This filter is comprised of a set of differentiation filters. Gray value modulations that are either horizontal or vertical will be especially enhanced. The Sobel filter generally yields the magnitude and direction of the most significant intensity gradient.

Matrix.\[
\begin{pmatrix}
  -1 & 0 & 1 \\
  -2 & 0 & 2 \\
  -1 & 0 & 1 \\
\end{pmatrix} \Rightarrow a;
\quad
\begin{pmatrix}
  1 & 2 & 1 \\
  0 & 0 & 0 \\
  -1 & -2 & -1 \\
\end{pmatrix} \Rightarrow b \Rightarrow \sqrt{a^2 + b^2}
\]

Two matrices are applied independently and then their geometric mean is taken.
Comparison. The results are comparable to those of the Laplace filters. Laplace II leads to a clearer accentuation of edges but increases the noise.

8.2.12 Roberts

Application. Rapid edge detection.

What will happen. The Roberts filter employs a non-linear method for edge enhancement and registers transitions from light to dark pixels. This filter is comprised of two basic differentiation matrices. Of importance is the difference in brightness in the diagonal of the four upper-left values. Large differences result in high values; areas with small gradients will be suppressed. Due to the low number of computations, this filter functions well as a rapid edge filter.

Matrix.\[
\begin{pmatrix}
  1 & 0 & 0 \\
  0 & -1 & 0 \\
  0 & 0 & 0 \\
\end{pmatrix} \Rightarrow a;
\quad
\begin{pmatrix}
  0 & -1 & 0 \\
  1 & 0 & 0 \\
  0 & 0 & 0 \\
\end{pmatrix} \Rightarrow b \Rightarrow |a| + |b|
\]

Comparison. The results are comparable to those of the Sobel and the Laplace filters but somewhat less precise, however, faster to compute.
8.2.13 Reimer

This command is based on the definitions set in the Processing ▶ Define Filter ▶ Reimer dialog box.

What will happen. The Reimer filter subdivides the entire image into areas of pixels with the same intensity within a certain tolerance range. The borderlines between the areas are displayed in white, all the rest in black. It results an image that resembles the isobars in a weather chart – a so-called equidensitometric image of the second order.

Why the Reimer Filter? The Reimer filter is able to subdivide continuous gray value ranges within an image, which the naked eye alone has difficulties to distinguish. Superimposing the filtered image and the original helps determine areas of similar intensities.

Define Parameter ▶ Interval. The Interval sets the gray value tolerance range (1-254) for pixels to be grouped into one area. The preset interval value is 32. The lower the selected interval, the more image details are visible in the filtered image.

8.2.14 User Filter

This command is based on the definitions set in the Processing ▶ Define Filter ▶ User Filter dialog box.

Application. A user-defined filter provides you with the opportunity to select all filter parameters yourself. A user-defined filter can be used, e.g., for combining different filters – this is done by adding the weight factors of the individual factors. Another application is modification of existing filters – this is done by increasing mean image brightness by adding an offset.
What will happen... If you apply the user filter the following operation will be applied to each image pixel:

\[
\frac{W_1 \cdot I_1 + \ldots + W_Z \cdot I_Z + \ldots + W_n \cdot I_n + \text{Offset}}{\text{Normalization factor}}
\]

where
- \( I_z \) = intensity of the central pixel in the original image
- \( I_1-I_n \) = intensity of neighboring pixels in the original image
- \( W_1-W_n \) = matrix elements or weight factors of the user filter

Define Parameters

Size. To determine the size of the editable matrix field select one of the following options: 3x3, 5x5, 7x7 or 9x9. For hexagonal matrices the numbers define the number of fields in the middle matrix line.

Filter matrix. You can enter the individual weight factors [via keyboard] into the fields in the middle of the dialog box. Positive or negative whole numbers are permissible.

Sum field. The sum adds up all matrix current elements. Use this sum as a scale for the brightness of the resulting image: "0" will mean your image is quite dark. Mean brightness will not have changed if your sum is "1".

The value in the Normalization field determines the range of gray values of the resulting image (according to the above-mentioned formula). Positive whole numbers greater than zero are permissible. The sum of all weight factors is used for image normalization when user-defined filters are in use.

The value in the Offset field determines the gray value to be added to the resulting image. When you select the Hex. lattice check box, the square matrix will be replaced by a hexagonal matrix. The following diagram shows determination of neighboring pixels using either a square or hexagonal filter matrix.
8.2.15 NxN

This filter is based on the definitions set in the Processing Define Filter NxN dialog box.

**Application.** Reduction of statistical noise

**What will happen...** The NxN filter averages the gray values of all pixels surrounding a central pixel and assigns them to that central pixel. The name of the filter refers to the size of the image area whose pixels’ gray values are average.

When determining filter size "N" you should keep generally the following in mind: the smaller the matrix, the finer the details you can edit. These details can include artifacts or interference. Larger matrices suppress these effects but yield blurrier resulting images – mean value filters smooth out gray-value peaks. The higher the number of iterations, the greater is this smoothing effect will be. You may end up blurring edges.

**Comparison.** The NxN filter, a smoothing filter, is most closely related to the Mean filter. The NxN filter permits you to determine the size of the averaging area, and thus the extent averaging is to take – this is not possible with the Mean filter.

**Define NxN.**

**Iterations.** Enter the number of times the filter is to be applied successively to the image. Select an entry between 1 and 25. The preset value is 3. The greater the number of iterations, the greater is the extent of the averaging.

**Size.** Enter filter matrix size into the Size field. The preset matrix size is 51. If you choose to make your matrix very large, the filter will affect large image structures.

The number of iterations and matrix size also determine the time required to complete the filter operation.
8.2.16 Lowpass

Application. A Lowpass filter transmits space frequency in a highly unadulterated form. High space frequencies – generally image noise or fixed pattern camera noise – will be suppressed and strong contrasts will be smoothed. Low space frequencies, which generally carry the actual image information, pass the filter.

8.2.17 Edge Enhance

This filter is based on the definitions set in the Processing > Define Filter > Edge Enhance dialog box. 

Application. Edge enhancement

The term "edge" refers here to an image area in which gray values either rise or fall sharply. This filter can be used as pre-processing before particle detection. However, noise may also be enhanced.

What will happen... The filter examines the gray values of all pixels within an image area comprising NxN pixels and determines if the central pixel of the matrix is within a certain percentage range of either the minimum or the maximum value of its neighboring pixels using the following algorithm:

\[
\begin{align*}
I > \left( I_{\text{max}} - \left( \frac{\text{Percent}}{100} \right) (I_{\text{max}} - I_{\text{min}}) \right) & \Rightarrow I = I_{\text{max}} \\
I < \left( I_{\text{max}} - \left( \frac{\text{Percent}}{100} \right) (I_{\text{max}} - I_{\text{min}}) \right) & \Rightarrow I = I_{\text{min}} ; \text{ where} \\
I &= \text{intensity of the central pixel} \\
I_{\text{max}} &= \text{maximum intensity inside the NxN pixel area} \\
I_{\text{min}} &= \text{minimum intensity inside the NxN pixel area}
\end{align*}
\]

Define Edge Enhance

Size. Enter the dimensions of the NxN pixel area (3 – 9). The larger the area, the less detailed the resulting image will be. The preset size is 5.

Percent. The Percent (1 – 99) field defines the threshold for the central pixel to the assigned either the minimum or maximum value of the surrounding pixels. With a lower percentage, darker gray values of the original image will predominate while a higher percentage will result in the predomination of lighter gray values. The preset percentage is 50%.
8.2.18 Rank

This filter is based on the definitions set in the Processing › Define Filter › Rank dialog box. Application. Image smoothing

It primarily filters out isolated pixels with gray values, which differ greatly from their immediate surroundings. Rather homogeneous gray value areas and edges are retained. In contrast to filtering with a median filter, the filtered image loses none of its original clarity.

Define Rank Filter.

Size. Enter the radius of the area to be considered. You can select radii from 1 to 11 at intervals of 0.5. The preset value is 3.

Rank. The pixel intensities within the area are ranked. Enter the rank in percent with which the central pixel is to be replaced. When Rank is 0%, central pixels will always be replaced with the lowest gray value of the surrounding pixel area, when Rank is 100%, by the highest gray value. With the preset rank of 50%, the central pixel will be set to the median gray value of the rank sequence.

8.2.19 Sigma

This filter is based on the definitions set in the Processing › Define Filter › Sigma dialog box. Application. Statistical noise filtering

Assumption. Local noise in an image follows a Gaussian distribution. The Gaussian curve can be described by its half width 2σ. A small σ indicates a narrow curve with high maximum; this is the intensity distribution in a homogeneous object with low noise. A large σ indicates a flat and wide shape; this is the intensity distribution in a homogeneous object with high noise.

What will happen... The algorithm examines all pixels within an area of a set size and calculates the average value of all those pixels, which are within a certain intensity range (I_{central} ± 2σ) relative to the central pixel. All pixels with gray values outside this intensity range very likely belong to another set of object information and are therefore ignored. If the number of pixels within the intensity range is less than or equal to half the square root of the number of all neighbors the central pixel will be replaced by the mean value of the four directly adjacent pixels.
Comparison. Unlike the Median filter, the Sigma filter does not remove isolated – "bad" – pixels with intensities that differ strongly from the surrounding pixels.

Define Sigma Filter.

Size. Enter the radius of the area to be considered. You can select radii from 1 to 11 at intervals of 0.5. The preset value is 3.

Sigma. Enter the value that defines the intensity range to be considered.

8.3 Arithmetic Operations...

This command opens a dialog box containing commands to execute various predefined arithmetical functions.

What happens if there’s a pixel value overflow? Commands execute the arithmetical operations one pixel at a time, thus processing all gray values. 8 bit channels have values between 0 and 255; 16 bit channels have values between 0 and 65535. When applying addition, subtraction, multiplication or division, the gray value range of the result(s) may be greater than that of the original image(s). When the 8 bit or 16 bit value range is exceeded that gray value will be displayed as 255 or 65535, respectively. Negative values will be set to 0. To avoid this effect, we recommend you reduce the gray value range of the sources first, for example by dividing by suitable factor.

Boolean Operators. The operators AND, OR and XOR work on images bit by bit. For each bit of gray value, the corresponding logical operation will be carried out. For gray-value images, the binary representation of 8 or 16 bit numbers must be taken into consideration.

Arithmetic Operations

Addition. A Constant or the Source 2 image (set) will be added to the active image (Source 1). Overflow clipping will be performed at 65535 for 16 bit data and at 255 for 8 bit data.

AND. Pixel values in binary form are compared bit by bit. If the bit is 1 for both images the result will be 1, otherwise it will be 0.

Example (8 bit). Source 1 = 170 = 10101010, Source 2 = 15 = 00001111, Result = 00001010 = 10.

Division. The active image (Source 1) will be divided by a Constant or by the Source 2 image (set). Digits after the decimal sign will be clipped.
**Maximum.** The images in the source and the source 2 image buffers will be compared and the greater pixel value selected from the respective image. The resulting image will thus have maximum intensity.

**Minimum.** The images in the source and the source 2 image buffers will be compared and the lesser pixel value selected from the respective image. The resulting image will thus have minimum intensity.

**Multiplication.** The active image (Source 1) will be multiplied with a Constant or with the Source 2 image (set). Overflow clipping will be performed at 65535 for 16 bit data and at 255 for 8 bit data.

**OR.** Pixel values in binary form are compared bit by bit. If a bit is 1 for either of the sources the result will be 1.

Example (8 bit): **Source 1 = 170 = 10101010, Source 2 = 15 = 00001111, Result = 10101111 = 175.**

**Subtraction.** A Constant or the Source 2 image (set) will be subtracted from the active image (Source 1). Negatives will be set to 0.

**XOR ("exclusive OR").** Pixel values in binary form are compared bit by bit. If the bits differ the result is 1, if the bits are identical, the result is 0.

Example (8 bit): **Source 1 = 170 = 10101010, Source 2 = 15 = 00001111, Result = 10100101 = 165.**
8.4 Image Geometry

8.4.1 Resize

The function **Process ➤ Image Geometry ➤ Resize** creates a copy of different size of the active image without cutting of parts like the **Extract ROI** cropping function does (see Chapter 7.7, *Extract…*). The original data remain untouched.
Factor. Set here the resizing factor for the spatial dimensions X, Y and – in case of Z-stacks – Z can be set. The corresponding Size will be set automatically.

Size. Alternatively, set the resulting size in the spatial dimensions X, Y, and – in case of Z-stacks – Z. The corresponding Factor will be set automatically.

Ratio.
Maintain XY-ratio. If this option is selected, a change of the X Factor or X Size causes automatically a corresponding setting of the Y Factor or Y Size and vice versa.
Zoom axes independently. If this option is selected, it is possible to set, for example, different Factors for X and Y. Doing so leads to a distortion of the resulting image.
Zoom axes homogeneously. This option is available for Z-stacks only. Here all three Factors X, Y and Z will always have the same size.

Interpolation
Resizing images will result in a reduction in image quality. This is because the color of each original pixel must be redistributed across a different number of pixels and the result will be less precise than the original. There will be an inevitable loss of sharpness, regardless of whether the image is enlarged or made smaller.
Nearest Neighbor. This method doubles or removes pixels. The appearance of the new image may be somewhat coarse.
Trilinear. This method interpolates the color of the original pixels to come to the new pixels.
Bicubic (XY), Linear (Z). This method interpolates the color of the original pixels to come to the new pixels using a different algorithm in the X and Y dimensions as compared to the trilinear method. The appearance of the resized image will be slightly less blurry.

8.4.2 Rotate

The function Process ▶ Image Geometry ▶ Rotate allows to rotate single images and entire data sets in the XY plane. By doing so it creates a new data set so that the original images remain untouched.

Angle. Set the rotation angle in this box.

Set Angle. This command allows to set the rotation angle interactively using two lines initializing from the same point.

1. After clicking the button, position the mouse cursor at the origin of the angle and left-click.

2. Position the mouse cursor onto a point of the angle’s ‘first’ arm. A straight line will appear in the overlay.

3. Left-click to fix the first arm. It will be drawn into the overlay.
4. A second arm will appear starting from the initial point of the first arm upon movement of the mouse. Draw the second arm in the same way.

5. The **Rotate** window will open again with the interactively defined angle set in the **Angle** box.

6. Continue with setting the **Direction** and the **Options**.

7. Execute the rotation by clicking **OK**.

**Direction.** Chose between a left (counterclockwise) and right (clockwise) rotation.

**Interpolation.** If this option is selected, pixel colors may be created by mixing the colors of original pixels. This will give the rotated image a smoother appearance (middle image below). If the option is not selected, the result may make the features look coarse (right image). However, in case of biological samples, the interpolation effect will hardly ever be visible. It is of greater importance in case of graphics with sharp borders between areas of different colors (left image below).
8.4.3 Mirror

The function Process → Image Geometry → Mirror allows to reflect single images and entire data sets at four predefined axes of choice: the central Vertical, the central Horizontal or any of the two Diagonal axes. Check the radio button of the desired axes and then click OK.

8.4.4 Align

The Process → Image Geometry → Align function performs a rotational alignment of the Source 1 image relative to the Source 2 image. Make sure that the Source images are set correctly in the Operand box of the Imager Manager. After starting the function set the first reference point by mouse click in the active image (Source 1). Upon doing so source 2 becomes active automatically. Set the corresponding reference point there. Source 1 becomes active again for you to set the second reference point. Again Source 2 becomes active again for you to set the corresponding second reference point. You may continue setting reference points or finish the process by a right click. Upon finishing a rotated copy of Source 1 will be generated with its reference points lined up as good as possible with those of Source 2.

8.4.5 Auto Align Z

Especially in long term time-lapse experiments it may happen that the sample is moved in the XY plane. This may be caused by an accidental push of the microscope or the table or upon intentionally manipulating the sample, may be after injection of an agonist. Such a movement makes certain analyses difficult, for example intensity kinetics. An ROI defined in the first image will no longer contain the same structural features after the movement and the resulting numbers may become meaningless.
The Process Image Geometry Auto Align Z function performs an object detection and detects movements of the objects in X and Y from one image to the next. It then corrects the movement by shifting the images so that the objects are positioned in the same XY position again. The resulting images are smaller than the original ones because the areas vacated by the shift are cut off.

8.4.6 Apply Shift Correction

The Process Image Geometry Apply Shift Correction function is available only if a shift correction has been performed in the Adjust Display / Shift Correction dialog, see Chapter 6.2.2.3, Shift Correction. This shift correction is purely a display property that is not reflected in the actual image data. The Apply Shift Correction function creates a new image with the shift correction applied and stored in the data.

8.5 Deblurring and Deconvolution

8.5.1 General

Deblurring and deconvolution both are software tools to remove out-of-focus light from images to sharpen the contours of the imaged structures. They should, however, not be confused with each other.

3-D deconvolution is an image restoration method, which moves out-of-focus light from each slice of a Z-stack back into the slice where it originates. It thus conserves all light information of the Z-stack, sharpens the resolution, improves the signal-to-background ratio and allows and improves quantitative intensity analyses. Deblurring, however, is not a restoration method but works subtractive and doesn't allow any meaningful quantitative analysis afterwards but should be regarded as a purely cosmetic method. Side effects are increased background intensity, increased noise, decreased signal-to-background ratio and possible sharpening of out-of-focus structures.
8.5.2 No Neighbor

The No Neighbor algorithm is the faster algorithm as compared to Nearest Neighbors. As a trade-off in order to achieve this speed, it is less accurate. It works by deblurring one image slice at a time.

The principle. An unsharpened image of the image that is being processed (source image) is created and then subtracted from the source image. The unsharpened image is taken as an approximation of the out-of-focus information. Thus the unsharp image contents are being removed while the sharp contents remain.

Available. All OV100 image types can be deblurred: single images, time series, Z-stacks and 3-D time-lapse series, all either monochromatic or multi-colored.

8.5.3 Nearest Neighbors

The principle. The two neighboring layers (one above and one below) of the Z-stack layer that is being processed are temporarily unsharpened and then subtracted from the layer that is being processed. Similar to the No Neighbor approach the unsharp images are approximations of the out-of-focus information. However, in the Nearest Neighbors algorithm the supposed out-of-focus information in fact stems from out-of-focus layers and is thus considered as a superior input for the calculation.

Available. Z-stacks and 3-D time-lapse series, both either monochromatic or multi-colored.

8.5.4 Deblurring Images

Requirements. The images need to be calibrated in the X, Y and Z dimensions, see Chapter 7.1, Calibrate Image, otherwise an error message will be generated.

Channel Settings
Click the Deblurring button (or select Image Analysis ▶ Complex Image Analysis ▶ Deblurring). If deblurring was not applied before on the active image the Channel Settings dialog will open.

Color Channel. Select the channels one after the other in order to set their Microscope Parameters.

Emission Wavelength. This is the maximum intensity wavelength of the light emitted from the specimen but also dependent on the transmission properties of the emission filter in the fluorescence cube of the microscope. If running a brightfield setup, enter 540 nm.
Numerical Aperture. This parameter is printed on the objective. It determines the light gathering capacity and resolution of the objective. The (theoretical) upper limit of is the Refractive Index.

Refractive Index. This is an optical characteristic of the immersion medium and can be selected from the pick list for each Color Channel.

Calibration. This field list the scaling in the three spatial dimensions as set in Chapter 7.1, Calibrate Image. If necessary the settings can be changed in the Scale X/X/Z boxes.

OK. Confirm the settings and return to the Deblurring dialog window.

Deblurring, Filter Selection. Select either No Neighbor or Nearest Neighbor from the Filter Selection shortlist.

In case of single images and time series only No Neighbor is available.
Noise Reduction. This parameter is expressed as a percentage value and determines the power of the deblurring. The higher the number, the more blurring is removed from the images. The effect will hardly be visible with values below 50 while the default of 85 gives moderate results. Very high values like 98 or more result in rather grainy images with very pronounced contrasts and can introduce artifacts. Be sure to carefully check the results.

Transmitted Brightfield. Mark the, if you use a brightfield setup. The check box Phase Object becomes available.

Phase Object. Mark the check box, if the specimen is a phase object. A phase object is any specimen with little light absorption, e.g. living Mitochondria, chromosomes, bacteria, or cytoplasm.

Execute. This button in the Deblurring dialog window starts the calculation. A window opens that shows the progress of the calculation.

OK. Exit the Deblurring dialog after the calculation is finished.

8.5.5 Inverse Filter

The Inverse Filter is a one step non-iterative deconvolution method based on inverse-filtering theory. It utilizes optimal linear filtering and is a simple deconvolution method. It is very useful for obtaining quick results, but is not as accurate as Blind Deconvolution (as offered, for example, in the AutoDeblur software package by AutoQuant). Inverse Filtering is typically more robust than the Nearest Neighbor or No Neighbors deconvolution methods. The execution speed of the Inverse Filter is between that of Nearest Neighbors and Blind Deconvolution.

Available. Z-stacks and 3-D time-lapse series, both either monochromatic or multi-colored.

Requirements. The images need to be calibrated in the X, Y and Z dimensions, see Chapter 7.1, Calibrate Image, otherwise an error message will be generated.

Tiling. Mark the check box to enable tiling. The algorithm produces huge temporary data, the size of which will easily exceed the computer RAM, even with Z-stacks of only moderate size. Tiling allows the application to subdivide the large datasets into a size the processing computer’s RAM can handle. The advantage of larger subdivisions of data being processed is
the increase in processing speed and therefore a decrease in the amount of time it takes to deconvolve a dataset.

If the Tiling option is disabled and the size of the data exceeds the available RAM the software will give an error message referring the failure of memory allocation and then abort the execution stating The deconvolution failed due to lack of dynamic memory. In this case enable tiling with an appropriate Overlap and execute again.

Overlap (Pixels). Tiling often results in clearly visible, rectangular artifacts at the borders of the sub-volumes. This side effect can be reduced by increasing the Overlap of the sub-volumes. This, however increases the processing time. The sub-volume overlap setting determines the number of pixels that the montaged sub-volumes will overlap. The possible values are integers from 0 to \( N/2 \), where \( N \) is the width or height of the XY field in pixels whichever is smaller. An overlap of 10 or 25 pixels usually works best. If the result of the deconvolution with a value of 10 contains artifacts having rigid lines, edges or an obvious grid structure start with a value of 10, then increase this number. Overlapping regions are deconvolved twice, so making this number too large (e.g. 100) will increase the deconvolution time.
9 Measurements

The OV100 software provides a designated environment for length and area measurements with its own button bar and the Measurement View in the Image Manager. All measurements become linked with the parent image and are automatically stored as part of it and can be displayed and modified at will.

9.1 Measurements Toolbar

Select Measurement ▶ Measurements Bar or press <Alt+4> to open the measurement button bar. The measurement functions of the button bar and the different analyses in the menu are explained in the following chapters.

All the measurement functions can be found on the Measurements button bar. There is one button for each function. Begin a measurement by clicking on the button with the desired measurement function. You can measure as many values on the image as you like. You end the measurement by a right-click or the <Esc> key. Several measurements can be conducted successively. The results will be displayed in the overlay and written into a sheet, which will be generated automatically.

If you do not want the results to be shown in the overlay select Show labels ▶ None in Special ▶ Preferences ▶ Measure (or Measurement Properties button in the Measurement View or key F8).
9.2 Drawing Tools for Length and Area Measurements

9.2.1 Point

Point

Use this command to measure parameters of single pixels. With each left mouse click a colored cross "+" is drawn in the overlay. The XY coordinates of pixels are measured by default. The X coordinate is then shown in the images overlay while the X and Y coordinates are displayed in the measurement display in the Image Manager. To determine further positions click left. A right-click lets you exit the Point function. The results are displayed in the overlay. One can then start to count a second set of objects or terminate the command with another right-click.

9.2.2 Touch Count

Touch Count

Use this command to count objects in an image. Several measurement series can be conducted successively to count objects of various classes.
With each left mouse click a colored cross \(^+\) is drawn in the overlay at the position of the tool tip and the count is increased by 1. A right-click stops the counting. The result is displayed in the overlay and written into a sheet generated automatically. One can then start to count a second set of objects or terminate the command with another right-click.

9.2.3 Length

9.2.3.1 Vertical line

Use this command to measure a vertical distance between two horizontal lines.

**Measurement Results.** The distance to be measured will be denoted by a vertical line labeled with the length by default. This vertical distance will also be listed in the measurement display.

**How to define a vertical distance.**

1. Upon clicking the button a horizontal red line appears at the mouse cursor. Position it at the horizontal distance’s starting point.

2. Left-click and the red line will be drawn in the overlay.

3. A second vertical line will appear at the mouse cursor. Position it at the horizontal distance’s end point.

4. Left-click and a vertical line representing the distance measured will be fixed in the overlay and labeled with the length. The fixed horizontal line will vanish. The remaining horizontal line at the mouse cursor can be used for a new measurement.

5. Continue the measurement in the same way.

6. Terminate the measurement with a right click.

9.2.3.2 Horizontal line

Use this command to measure a horizontal distance between two vertical lines.

**Measurement Results.** The distance to be measured will be denoted in the overlay by a horizontal line labeled with the length by default. This horizontal distance will also be listed in the measurement display.
How to define a vertical distance. A horizontal measurement is done using the same steps as for the vertical distance.

9.2.3.3 Arbitrary line

Arbitrary line

Use this command to measure distances between two parallel lines of arbitrary orientation. Measurement Results: The distance to be measured will be denoted by a straight line labeled with the length by default. This "arbitrary distance" will be listed in the measurement display.

How to define a vertical distance. The measurement is done using the same steps as for the Horizontal Distance command.

9.2.3.4 Polyline

Polyline

This command allows determining the length of irregular structures of an image. The distance to be measured will be denoted by a polygonal line made up of straight-line segments in the overlay labeled with the length by default.

1. Position the mouse cursor at the starting point of the distance to be measured and left-click. A red line will appear in the overlay between the starting point and the moving mouse cursor.

2. Move the mouse and left-click at the corner positions to draw a multi-segment line.

3. In case corrections are necessary, keeping the <Shift> key pressed, left-click to delete previous figure segments one by one from the overlay.

4. Right-click to finish the line. Its length will be displayed in the overlay and written into the measurement display.

5. Draw a second line or click <Esc> to terminate the measurement.
9.2.4 Angle

9.2.4.1 3 Points Angle

Use this command to measure an arbitrary angle using two lines initializing from the same point. It is called 3 Points Angle because each line has a separate end point but the same starting point. The angle will be displayed in the overlay and listed in the measurement display. OV100 measures angles clockwise between the angle’s first and second arm. Thus the order of drawing is decisive.

1. Position the mouse cursor at the origin of the angle and left-click.

2. Position the mouse cursor onto a point of the angle’s ‘first’ arm. A straight line will appear in the overlay.

3. Left-click to fix the first arm. It will be drawn into the overlay.

4. A second arm will appear starting from the initial point of the first arm upon movement of the mouse. Draw the second arm in the same way.

5. Right-click to terminate the measurement.

**Note** again that the angle is measured clockwise exclusively and does not depend on a clockwise or counter-clockwise movement of the cursor.

9.2.4.2 4 Point Angle

4 Point Angle

Use this command to measure the angle between two lines. It is called 4 point because each line has a separate starting and end point. The intersection divides each line into two segments. The angle is measured clockwise between the longer segment of the first and the longer segment of the second line. Thus the order of drawing and the length of the lines are decisive. The angle will be displayed in the overlay and listed in the measurement display.

1. Position the mouse cursor at the origin of the first line and left-click.

2. Move the mouse cursor; a straight line will appear in the overlay.

3. Left-click at the end of the first line.

4. Draw the second arm in the same way, starting at any given point.
5. Right-click to terminate the measurement.

**Note** again that the angle is defined according to the length of the line segments and measured clockwise exclusively.

### 9.2.5 Area

#### 9.2.5.1 Rectangle

Use this command to measure a rectangular object. Default measurements are area and perimeter. Several measurement series can be conducted successively. As soon as the button is clicked a red rectangle appears in the image overlay.

1. Drag the mouse to move the rectangle.

2. Drag the mouse with the left button pressed to change the size and shape of the rectangle.

3. To fix the rectangle right-click, and a new rectangle will appear. Proceed as before.

4. To exit the measurement press `<ESC>`.

The result will be displayed in the overlay and listed in the measurement display.

#### 9.2.5.2 Rotated Rectangle

Use this command to measure a rectangular object of arbitrary orientation. Default measurements are area and perimeter. Several measurement series can be conducted successively. As soon as the button is clicked a red rectangle will appear in the image overlay. The left mouse button toggles between the Move and the Rotate modes, indicated by the crosshair and the circular arrow, respectively, in one corner. Dragging without a mouse button clicked performs the moving and rotating. In either mode a left button drag changes size and shape. The best way to draw is the following:

1. Open a rectangle at any position and switch to Rotate with a single click (on the corner of the rectangle).
2. Rotate the rectangle so that the edges are parallel to the desired position.

3. Change to Move with another single click (on the corner of the rectangle) and position the corner opposite to the crosshair to its final position.

4. Finally adjust the size of the rectangle via left button mouse drag.

5. To exit the measurement press <ESC>.

The result will be displayed in the overlay and listed in the measurement display.

9.2.5.3 3 Points Circle

3 Points Circle

Use this command to measure a circular object by selecting 3 points on the arc of the circle. Default measurements are area and perimeter. Several measurement series can be conducted successively.

1. Mark a point at the arc of the circle of interest with a left-click; an x will appear.

2. Select a second point at the arc of the circle of interest with a left-click; another x will mark this position.

3. Move the mouse and a circle passing through the two marks will be displayed.

4. To fix the circle select a third arc point with a left click.

5. Continue by drawing a second circle or exit via right-click or <ESC>.

The result will be displayed in the overlay and listed in the measurement display.

9.2.5.4 Circle with Center and Radius

Circle with Center and Radius

Use this command to measure a circular object by selecting the circle’s center and one point of the arc. Default measurements are area and perimeter. Several measurement series can be conducted successively.

1. Select the center of the circle with a left-click, an x in the center and a circle will appear.

2. To adjust the size, move the mouse. Fix the circle by clicking on a point at the arc of the circle of interest.
3. To fix the circle right-click when desired size has been achieved. A new circle appears with the sizes of the previous one. Proceed as before.

4. Proceed as before or exit with <ESC>.

The result will be displayed in the overlay and listed in the measurement display.

9.2.5.5 Ellipse

Use this command to measure an elliptical region of arbitrary orientation. Default measurements are area and perimeter. Several measurement series can be conducted successively. As soon as the button is clicked a blue ellipse circumscribed by a red rectangle between four blue lines will appear in the image overlay. The left mouse button toggles between the Move and the Rotate modes, indicated by the crosshair and the circular arrow, respectively, in one corner. Dragging without a mouse button clicked performs the moving and rotating. In either mode a left button drag changes size and shape. The best way to draw is the following:

1. Click the Ellipse button to open an ellipse and move it roughly to the desired position.

2. Adjust the size by dragging with the left mouse-button pressed.

3. Switch to Rotate by a single left-click.

4. Rotate the ellipse to the desired position.

5. Switch back to Move by another single left-click.

6. Adjust the size of the ellipse via left button mouse drag.

7. Fix the ellipse with a right-click. A new ellipse with rectangle will appear.

8. Proceed as before or exit with press <ESC>.

The result will be displayed in the overlay and listed in the measurement display.
9.2.5.6 Closed Polygon

Use this command to measure an irregular area with straight border segments. Default measurements are area and perimeter. Several measurement series can be conducted successively.

1. Left-click on a point at the border of the area. A red line will appear in the overlay between the starting point and the moving mouse cursor.

2. Move the mouse and left-click at the corner positions of the area to draw a multi-segment line.

3. Drag the mouse with the left button pressed to draw a freehand line or left-click at the corner positions to draw a multi-segment line.

4. In case corrections are necessary, keeping the $\text{<Shift>}$ key pressed, left-click to delete previous figure segments one by one from the overlay.

5. Right-click to automatically draw a line to close the polygon.

6. Draw a second polygon or click $\text{<Esc>}$ to terminate the measurement.

The result will be displayed in the overlay and listed in the measurement display.

9.2.5.7 Interpolated Polygon

Use this command to measure an irregular object with rounded corners. Default measurements are area and perimeter. Several measurement series can be conducted successively.

1. Left-click on the border of the area. A red line will appear in the overlay between the starting point and the moving mouse cursor.

2. Mark two more border points relatively close by. A red triangle circumscribed with a blue interpolated line appears.

3. Continue by marking more border points.

4. Right-click to automatically draw a line to close the structure.

5. Draw a second polygon or click $\text{<Esc>}$ to terminate the measurement.

The result will be displayed in the overlay and listed in the measurement display.
9.2.5.8 Fitted Polygon

This command is identical to the Interpolated Polygon command with the difference that the segmented polygon will circumscribe the interpolated line instead of vice versa. A right-click automatically draws a line to close the structure.

9.2.5.9 Free Hand Polygon

This command is identical to the Interpolated Polygon command with the difference that the outline of the area has to be drawn freehand with the left mouse button pressed. A right-click automatically draws a line to close the structure.

9.3 Magic Wand

Use this command to measure objects defined based on similarities in intensities or colors of neighboring pixels. Default measurements are area and perimeter. Several measurement series can be conducted successively.

1. Click on an image point. The software determines its intensity and color and compares it with the neighboring pixels. Pixels with values that match the selection criterion (see next chapter) will be included into the selected area.

2. Right-click to confirm the selected area.

3. Select another area or terminate the measurement via right-click or <Esc>.

The result will be displayed in the overlay and listed in the measurement display.
9.3.1 Magic Wand Options

Measurement Properties (in the Measurement View)

The Magic Wand Options are part of the Measure Preferences, to be found on the Measure tab in Special Preferences. Shortcuts to these options are the F8 key and the Measurement Properties button in Measurement Display of the Image Manager.

Tolerance. This parameter decides the degree of similarity to the origin that a pixel must have to be selected. The match has to very good in case of low values: a small number of pixels will be selected. For high values the similarity can be rather remote and a large area will result.

Smoothing. Depending on the dynamic range and the evenness of labeling within the selected image object the borders of the area selected by the magic wand can be raggedy. A smoothing factor larger than 1 will effect the selection of objects with more regular shape.

Color Space. The color space used determines the general criterion for the pixel selection with respect to color and intensity.

RGB

RGB. Monitor colors and images acquired with color cameras are composed of the three primary colors red, green and blue in different intensities. Multi-color images acquired with OV100 may contain channels of different colors but are converted into RGB images upon display. With the RGB space the similarity criterion has to be fulfilled in all three channels for pixels to be selected. This color space is especially useful for multi-color fluorescence images.

HSI

HSI. This is a more abstract color space than RGB. Hue, the color tone, is explained below. Saturation can be seen as the difference between a set color and white. Similarly, Intensity is the difference to black. Selected areas may differ considerably in multi-color fluorescence images as compared to the RGB selection.

Hue

Hue. Hue is the color tone in a scale of pure *rainbow* colors ranging from red over yellow, green, cyan, blue to magenta and back to red. Onscreen these colors are composed of binary mixtures with different proportions of the monitor colors red, green and blue. These conditions are often visualized by a colored ring with red at 12 o’clock (0°), green at 8 o’clock (120°) and blue at 4 o’clock (240°). With hue as similarity criterion artifacts may result in fluorescence images because the pixel intensity is not considered at all.
Intensity

Intensity. Here the similarity criterion is the overall pixel intensity added up from all color channels. In other words, the image is analyzed as if it was a monochromatic (black&white) image.

9.4 Results

9.4.1 Move Origin

Move Origin

Use this command to change the origin of the coordinate system. By default, the origin of the coordinate system can be found in the upper left corner of the image. Click the Move Origin button to move the coordinates origin to a desired position on the image. All values already measured are adapted to the new origin.

1. As soon as the Move Origin button is clicked the mouse cursor will move to the red coordinate arrows on the left top of the image overlay.

2. The arrows color will change to yellow indicating the ability to move them.

3. Move the arrows to the desired location and left-click to set the new coordinates. The function terminates automatically.

9.4.2 Create Measurement Sheet

Create Measurement Sheet

All executed measurements create an entry in the measurement display. These results remain linked to the image after the image has been saved. Additionally it is possible to list the measurement results in a spreadsheet. Such a sheet can then be exported in different formats via File > Save as....

Click on the Create Measurement Sheet button located in the measurement button bar to open the Create Measurement Sheet dialog box.
**Image.** All images are listed that contain any measurement objects. Select the images the measurements of which are to be converted into sheets.

**Show image name in the first column.** This option is useful if the measurement results of several images are to be combined in one sheet.

**Generate statistics of the sheet(s).** This function is currently disabled.

**One sheet per image.** Select this option if the results of several images are to be combined in one sheet.

The unit of the measurement values in the measurement sheet corresponds to the unit in which the image has been calibrated. To change this unit, use the **Image ▶ Calibrate Image...** command, for details see Chapter 7.1, *Calibrate Image.*

**Editing sheets.** Several editing functions are available in the Sheet Context Menu that can be opened by right-clicking on a sheet.
9.4.3 Deleting Measurement Results

Delete Measurement from Image

Use this command to delete individual objects and their measurements interactively.

1. Click the Delete Measurement from Image button and select the object to be them in the image overlay.

2. Delete another object or terminate the function via right-click or <Esc>.

Objects and their measurements can also be deleted by selecting them in the measurement display and pressing the <Del> key.

Delete Measurement button

Use this command to delete the entire measurement results of the active image.

9.4.4 Image Link

Image Link

Use this command to locate measurement values in the Measurement display by selecting them in the image overlay. This command is useful when many measurements have been taken.

1. Click the Image Link button located in the Measurement Display. The pointer moves to the image window.

2. Click on any measurement object in the image overlay.

3. The respective measurement value becomes highlighted in gray in the Measurement Display.

4. Terminate the function with the <Esc>.
9.4.5 Show/Hide Statistic

Show/Hide Statistics

Use the Show/Hide Statistics toggle button to hide or show the Statistics field in the lower part of the Measurement Display. See also Chapter 9.4.7, Define Statistics.

9.4.6 Select Measurements

Select Measurements

For the different types of measurement objects different measurement functions are available. By default different measurement functions are selected for each type, for example, Area and Perimeter for 2D objects (rectangles, circles, polygons etc.), Length for Lines. Use the Select Measurements function to open the respective dialog window.

Tree View. It is located in the upper left hand part of the dialog box and lists the different types of measurement objects. Click on any type to list all measurements possible for this type in the Measurement Parameters list.

Measurement Parameters list. Add new measurements to the Selected Measurements list by marking the respective check box or remove measurements by unmarking the check box.

Selected Measurements list. Click on a measurement function in the list to show the description and a schematic drawing in the dialog box. Move the selection up or down with help
of the *Arrow Up* or *Arrow Down* buttons on the right or deselect the measurement by clicking the *Delete* button. It can be added anew to the list any time.

---

**Delete**

If changes are made the Measurement Display becomes updated automatically upon closing the dialog with **OK**.

### 9.4.7 Define Statistics

**Define Statistics**

This button opens the *Define Statistics* window.

**Available.** All available statistics parameters that are not yet selected are listed here.

**Current.** All statistics parameters to be shown in the *Statistics* field of the Image Manager are listed here.

**Add >>.** Select a parameter from the *Available* list and click this button to add the parameter to the *Current* list.

**<< Remove.** Select a parameter from the *Current* list and click this button to remove the parameter from the list.

**Description.** This gives and explanation of the parameter currently selected.
9.4.8 The Preferences ‣ Measure Tab

Use this function to open the Preferences ‣ Measure Tab. For a detailed description refer to Chapter 13.5.4, The Preferences ‣ Measure Tab.

The Magic Wand Options are described in Chapter 9.3.1, Magic Wand Options.
10 Intensity Analyses

The analysis features explained in this chapter are very important for cell biological applications. Line intensity profiles illustrate intensity changes along arbitrary lines within an image. Commonly regions of interest are defined to determine average intensities and follow their changes through image series to quantify dynamic processes and display the results in graphs and sheets. Meaningful quantification usually requires background subtraction. Special image ratio algorithms are used to quantify ion imaging experiments. Spectral bleed-through in multi-labeled specimen skews quantitative analyses but can be corrected with spectral unmixing. The enhanced chromatic resolution provided by this technique also allows to clearly distinguish spectrally very similar fluorochromes.

Image Analysis
The analysis features explained in this chapter are very important for cell biological applications; many can be called with the buttons in the Image Analysis toolbar.

10.1 Pixel Value

Checking the values on the flight. Right-click on the image and click on Pixel Value in the appearing Context Menu. The status bar in the lower left corner of the OV100 window displays the gray value for each color channel at the current mouse cursor position.

Stop. You can terminate the action by opening the respective dialog with a right mouse click.
Measurement Results. Mark the pixels whose coordinates and gray values you wish to determine. A cross in the overlay will denote each pixel marked. The pixel’s X/Y coordinates and the gray value of each color channel will be listed in the sheet.

Pixel Measurement Settings. Select the Show Labels: Numbering check box in the Measure tab of the Special > Preferences dialog window to numerate each pixel measured. This way the pixels in the overlay will clearly correspond to the values in the sheet.

10.2 Histogram

Use this command to have an image’s gray-value distribution calculated and plotted on a graph.

Definition. The Histogram is an X/Y diagram in which an image’s gray-value distribution is displayed in a graph – i.e., number of pixels per gray value versus the gray value itself.

Results. The histogram will appear as a graph.
The graph will be written by default into the first slot of Graph View in the Image Manager. To avoid overwriting an existing graph, just click into an empty slot before calculating the histogram.

10.3  **Line Profiles: Intensity**

### 10.3.1  **Horizontal Line Profile**

Use this command to determine the gray value intensity along a horizontal line.

**How to measure a horizontal intensity profile:**

1. Select the Horizontal Intensity command. A horizontal red line will appear in the overlay.

2. Position the red line where you wish to measure gray-value intensity, and then left-click. The line will be drawn into the overlay.

3. If you drag the mouse, another red line will appear and can be placed as wanted.

4. Terminate the command with a right click and confirm yes.

The line profiles of all color channels will be drawn into a separate graph for each of the lines drawn into the image overlay.

This command works currently only on the active frame, not on an entire multi-dimensional image set.
10.3.2 Vertical Line Profile

Use this command to determine the gray value intensity along a vertical line. Conduct the measurement as with the Horizontal Intensity command.

This command works currently only on the active frame, not on an entire multi-dimensional image set.

10.3.3 Arbitrary Line Profile

Use this command to determine the gray value intensity along a line of arbitrary orientation. How to measure an arbitrary intensity profile:

1. Select the Arbitrary Intensity command.
2. Left-click on the starting position of the line to be drawn.
3. Move the mouse toward the end position. A blue line marks the current length and orientation of the line being drawn. At each end an orthogonal red line is displayed.
4. Left-click on the end position.
5. Continue with drawing another line or terminate the command with a right click and confirm yes.

This command works currently only on the active frame, not on an entire multi-dimensional image set.

10.3.4 Average Intensity of Neighboring Pixels

Use this command to set a line of arbitrary orientation and determine the mean gray value intensity of the neighboring pixels within a certain range on both sides of it. How to measure an intensity profile of a line of arbitrary orientation and thickness:

1. Select the Average Intensity command. A blue double-cross with a central rectangle appears. In its center is a pink arrow indicating the direction of the line to be drawn.
Note that the left mouse button toggles between the **Resize** and the **Rotate** modes, indicated by the crosshair and the circular arrow, respectively, in one corner.

2. Roughly place the end of the pink arrow to the designated starting point of the line.

3. Left-click to activate the **Rotate** mode and re-orientate the arrow.

4. Left-click to activate the **Resize** mode and drag the mouse cursor with the left button clicked. Adjust the length of the pink arrow as desired. The width of the red rectangle determines the range that will be averaged.

5. Repeat the rotating and resizing actions until position, length and thickness are as required.

6. Right-click to fix this line. A graph with the intensity profile will be created.

7. Draw another line by continuing with step 2) or terminate the action with the **Esc** button.

### 10.4 Regions of Interest – ROIs

#### 10.4.1 General

Regions of Interest or ROIs are parts of images that are defined by the user for subsequent analyses. The ROIs do not become part of the images even if being displayed, that is, they do not change the data and can be removed at will.

#### 10.4.2 Drawing ROIs

![ROI](image)

The ROI dialog box is opened with the **ROI** button or via **Image Analysis › ROIs...**

**Label**: By default, i.e., if no name is typed into the box, the ROIs are labeled “ROI <consecutive number>“. ROIs with identical names will likewise be numbered consecutively. Labels can be deleted or changed by clicking on the respective commands in the sub-dialog that is opened with the arrow adjacent to the Label box.
**Color.** ROIs are colored differently by default. The color can be changed by selection from the pull-down palette prior to drawing. To change the color of an existing ROI use the respective command in the sub-dialog that is opened with the arrow adjacent to the Label box.

**Active ROIs.** This list displays the current ROIs. Clicking on the check box deactivates individual ROIs. Such ROIs are not displayed.

**Tools.** These buttons activate different drawing tools and close the dialog box. ROIs are drawn with the left mouse button using the first six tools. With the right mouse button the two ends of polygon-defining lines are connected to generate closed polygons, the drawing command is terminated and the dialog box reopens.

**Polygon.** Mark the corner points of a polygon; straight lines then connect the corners.

**Interpolating polygon.** Mark the corner points of a polygon and the software automatically generates a perimeter curve around it.

**Freehand polygon.** Delineate the ROI by marking its boundaries by continuously dragging the mouse cursor.

**Ellipse.** Mark the center of the ellipse and adjust size and form by dragging the mouse. Additionally press the Shift key to draw a circle. After releasing the left mouse button the position can be changed. By clicking anew the shape can be adjusted again. As always, a right mouse click terminates the command.
**Rectangle**

**Rectangle.** A rectangle opens, the size and shape of which can be adjusted by dragging with the left mouse button.

**Rotated rectangle**

**Rotated rectangle.** With this command rectangles of arbitrary orientation can be drawn. The left mouse button toggles between the Move and the Rotate modes, indicated by the crosshair and the circular arrow, respectively, in one corner. Dragging without a mouse button clicked performs the moving and rotating. In either mode a left button drag changes size and shape. The best way to draw is to open a rectangle at any position and rotate it so that the edges are parallel to the desired position. Then change to Move mode and position the corner opposite to the crosshair to its final position and finally adjust the size of the rectangle via left button mouse drag.

**Virtual**

**Virtual.** This button is currently without function.

**From Particle**

**From Particle.** This button is currently without function.

**Move**

**Move.** This enables to move any ROI highlighted in the "Active ROI" list.

**Delete**

**Delete.** This removes the ROI highlighted in the "Active ROI" list

### 10.4.3 ROI Measurements (2-D)

> If the ROIs are already drawn when any of the measurement commands is called you have to select the ROIs to be measured by mouse click. If no ROIs drawn the start of any of the commands will automatically open the Define ROIs dialog described in the previous chapter.
10.4.3.1 Area

**Measurements ▶ ROI Measurements ▶ Area.** Use this command to measure the area of a Region of Interest. The line that defines the border of a ROI is counted as part of it. The results are listed in a sheet that is generated. The area unit depends on the image calibration; see Chapter 7.1, *Image Calibration*.

10.4.3.2 Perimeter

**Measurements ▶ ROI Measurements ▶ Perimeter.** The area unit depends on the image calibration; see Chapter 7.1, *Image Calibration*.

10.4.3.3 Average Intensity

**Measurements ▶ ROI Measurements ▶ Average Intensity.** Use this command to determine the average intensity of all pixels within a Region of Interest (including the pixels that define the border of it). Pixels with 0 intensity are ignored because they result from thresholding (background subtraction) processes and would skew the result in a meaningless way. This avoids having to be extremely careful when drawing a ROI close to the border of a cell, for example in a ratio image. The measurement results are listed in a sheet that is generated.

10.4.3.4 Average Value

**Measurements ▶ ROI Measurements ▶ Average Value.** This is the same function as *Average Intensity* with the exception that, for example, in ratio images the actual ratio value will be given instead of the scaled display intensity which depends on the *Scaling Factor* used in the ratio calculation; see Chapter 10.8.2, *Generating a Ratio Sequence*.

10.5 Background Subtraction...

10.5.1 General

Background intensity is unavoidable in wide-field fluorescence spectroscopy. Working in a dark room can eliminate environmental light, but there will always be a certain amount of excitation light that reaches the camera. Causes are imperfect filter sets and the reflection of light at interfaces, the cover slip and the specimen. Background intensity reduces the contrast of the image and consequently background subtraction should be a routine operation.
10.5.2 Subtracting the Image Background

The **Background** dialog box is opened with the **Background** button or via **Image Analysis** ▶ **Complex Analyses** ▶ **Background Subtraction**...

This function will create a new data set. The original (source) data remain untouched.

**Background Settings** page

If **Constant** is selected a fixed background value is subtracted from all pixel intensities in all images of all channels. This constant has to be typed into the box or can be changed by using the adjacent scroll arrows.

**ROI**. The most useful way is to mark a ROI in an image area that contains only background intensity and use the average intensity in this ROI as background value. This value is determined individually in each image of each channel.

**Image**. This option allows to subtract a predetermined background image set from each of the images of the data set. The background image has to have the same X/Y size and the same number of channels as the data set to be corrected. It can be either a single image or a time series or Z-stack as long as it has the same number of frames respectively layers as the data set of interest.
Dimensions page

In the fields **Color Channels**, **Z-Layers** and **Time-Frames** you can choose the range of images in the different dimensions for which the analysis shall be performed in case only a subset of the data is of interest. By default the entire data set is selected. With the option **Step** in **Z-Layers** and **Time-Frames** you can select every second, third, fourth image and so on to be analyzed.

**Copy non-processed data**: If this option is NOT selected the newly created data set will contain only the selected subset of the source data. If the option is selected a copy of the original (source) data will be created in which the selected subset range is processed (background subtracted) while the rest is identical to the source data.

**10.6 Intensity Kinetics in Time and Z**

**Kinetics**

The Kinetic dialog box is opened with the **Kinetics** button or via **Image Analysis  Complex Analyses  Kinetic (Time Lapse)**...

This tool is used to quantify the changes of fluorescence intensity within ROIs over time or within a Z-stack and display the results graphically.
Intensity Profiles page

In case of a multi-dimensional data set you have to select in the **Direction** field if the intensity changes are to be calculated over **Time (Kinetics)** or as a **Z-Profile**. For "simple" time series or z-stacks no choice is necessary. The software recognizes the dimensions automatically.

In the **Parameters** field you have to select from which data set the ROIs shall be taken and which ones the analysis shall be performed. If the option **Highlight selected ROIs** is activated, those ROIs are shown with bold lines. If **Sheet** is activated, in addition to the graph also the corresponding spreadsheet is generated.

Dialog page **Dimensions**

See the description in Chapter 10.5, *Background Subtraction*.

### 10.7 DeltaF / F (ΔF/F) Analysis

#### 10.7.1 General

While few fluorochromes allow the determination of absolute ion concentrations via ratiometric methods, the majority of ion sensitive dyes only allow the qualitative observation of changes in concentration. A convenient way to monitor such changes is to relate each image of a time series to the state at the beginning of the experiment and to analyze dynamic processes with a (ΔF/F) plot. The actual algorithm is rather (ΔF/F * const1 + const2). Here F refers to the reference fluorescence intensity (usually the first image or the average of the first couple of images). ΔF is the difference between the current intensity and the reference (F_{current} – F). The ratio is usually normalized (const1 = const2 = 100 or 1000) so that changes in intensity are given in percent or tenth of percent, respectively, with a value of 100% or 1000 %/10 at the start.
Why (ΔF/F)? The advantage of this plot is that it often more clearly displays the change of signal intensities regardless of the absolute value of the fluorescence. Hence, it makes it easier to compare the variations in weak and bright parts of the sample. A graphical analysis (kinetic) of the raw data will often clearly show changes in the intensive parts while shifts in dimmer structures, although relatively of the same magnitude, might be overlooked. A side effect of this type of plot, however, is often the loss of structural details.

10.7.2 Generating a (ΔF/F) sequence

The Delta F dialog box is opened with the Delta F button or via Image Analysis ▶ Complex Analyses ▶ DeltaF / F...

Dialog page Delta Settings

Output field. The selection of the options Image and Kinetics determine if a ΔF/F image sequence and/or a graph is generated.
Background Subtraction field. The option None is of limited value because the unavoidable background intensity leads to skewed results when dividing pixel values. If Constant is selected a fixed background value is subtracted from all pixel intensities in all images. The constant is set in the box that is only visible if this option is chosen. ROI: The typical approach to background subtraction is to mark a ROI in an image area that contains only background intensity and use the average intensity in this ROI as background value. This value is determined individually in each image of each channel. Image: The last option is to subtract a predetermined background image from each of the images of the data set.

Kinetic field. This field is only active if the Output option Kinetics has been marked. Here you have to select from which data set the ROIs shall be taken and for which ones the analysis shall be performed. If the option Highlight selected ROIs is activated, those ROIs are shown with bold lines. If Sheet is activated, in addition to the graph also the corresponding spreadsheet is generated.

Reference image field. Here you determine the range of images that will be averaged and taken as the reference for the analysis. For example, if the Start frame is set to 1 and Number of frames to 5, the first 5 images of the sequence are intensity averaged. The resulting average image is the F in ∆F/F ratios.

Thresholds field. The thresholding is performed to prevent that low signal areas and background areas result in areas of pronounced noise in the ∆F/F sequence (the reason being the division of small values by other small values). The thresholds is set in the respective box. For any pixel with an intensity value below the threshold the ratio value will be set to -1 (the lowest possible value) so that it appears black in any standard false-color display.

Output Scaling field. Digital images displayed on computer screens are based on integer numbers representing intensities. Division of two of such integers generates so-called floating point numbers, which cannot be displayed (e.g., (438-316)/316=0.3869759). These numbers have to be multiplied by a Scale Parameter with the positions after the decimal point being clipped. With a factor of 1000 (which is the default) the above number would give 387. However, in case of a decreasing signal a negative number, which again cannot be displayed, would result. Thus an offset is added to each resulting value, usually 1000. A pixel value of 1000 thus stands for 100%. In the example, 1387 results indicating a signal increase of 38.7%.

Dialog page Dimensions.
See the description in Chapter 10.5, Background Subtraction.
10.8 Ratio Analysis

10.8.1 General

This analysis tool is used for ion imaging with dual-excitation or dual-emission fluorochromes, the fluorescence intensity of which is dependent on the ion concentration. Calcium imaging with the dual-excitation dye Fura-2 as in the example in this chapter, is probably the most common such technique. The principle is that the sample is imaged “simultaneously” at two different illumination wavelengths, typically at 340 nm and 380 nm. “Simultaneously” means here that the two images of a pair are acquired immediately one after the other. Afterwards a background correction is performed and then the intensity values of the 340 nm image are divided by those of the 380 nm image pixel by pixel. The result is a new image, the ratio image. Any change of intensity in a time sequence of ratio images is directly correlated to a change in calcium concentration.

10.8.2 Generating a Ratio Sequence

Ratio dialog box is opened with the Ratio button or via Image Analysis > Complex Analyses > Ratio…

Dialog page Ratio Settings

Output field: The selection of the options Image, Kinetics and Calibrated determine if a ratio image sequence, a graph or a calcium concentration image sequence are generated. Any assortment of selections is possible.

Background Subtraction field. The option None is of limited value because the unavoidable background intensity leads to skewed results when dividing pixel values. If Constant is selected a fixed background value is subtracted from all pixel intensities in all images of the two channels. The constant for the two channels (340 nm and 380 nm) is set in the respective boxes Value 1 and Value 2. ROI: The typical approach to background subtraction is to mark a ROI in an image area that contains only background intensity and use the average intensity in this ROI as background value. This value is determined individually in each image of each channel. The last option is to subtract a predetermined background image from each of the images of the data set.
Kinetic field. This field is only active if the Output option Kinetics has been marked. Here you have to select from which data set the ROIs shall be taken and for which the analysis shall be performed. If the option Highlight selected ROIs is activated, those ROIs are shown with bold lines. If Sheet is activated, in addition to the graph also the corresponding spreadsheet is generated.

Thresholds field. The thresholds for the two bands can be set in the respective boxes. For any pixel with an intensity value below the threshold the ratio value will be set to 0. The thresholding is performed to prevent that low signal areas in the original channels result in areas of pronounced noise in the ratio sequence (the reason being the division of small values by other small values).

Output Scaling field. Digital images displayed on computer screens are based on integer numbers representing intensities. By division of two of such integers so-called floating point numbers, which cannot be displayed, are generated (e.g., $769 : 845 = 0.9100591$). These numbers have to be multiplied by a Scale Factor with the positions after the decimal point being clipped. With a factor of 1000 (which is the default) the above number would give 910. With this factor a pixel value above 1000 means signal increase and a smaller value a decrease.

Dialog page Dimensions
See the description in Chapter 10.5, Background Subtraction.
Dialog page **Calibration**

It is possible to calculate the calcium concentration out of FURA-2 ratio images if the imaging system is calibrated following a procedure described in the literature. The calibration parameters have to be entered into this Properties page. A calibration protocol can be downloaded from the Molecular Probes homepage: http://www.probes.com/media/pis/mp03008.pdf.

## 10.9 Spectral Unmixing

### 10.9.1 Application

Having the genome of more and more species been elucidated, the next challenge of modern biology will be to investigate the functional outcome of the genes - the proteins - and their role in physiology and disease conditions.

The development of computerized microscopes capable of acquiring spectral information, together with the development of new life cell fluorescence dyes and new color variants of fluorescent proteins opens new possibilities for the modern cell biologist. Multi-dimensional fluorescence microscopy offers the possibility to visualize the spatio-temporal behavior of cellular, sub-cellular, and molecular structures. In order to simultaneously visualize different structures, labels with different spectral properties have to be used.

### 10.9.2 The Problem

A major problem in live cell imaging arises from the use of different fluorochromes with overlapping spectra in one multi-labeled sample, impairing a number of applications. The considerable overlap of excitation and emission spectra of different fluorochromes is exemplified by the spectra of enhanced green fluorescence protein (eGFP) and enhanced yellow fluorescent protein (eYFP), two commonly used variants of the green fluorescent protein (Fig. 1).

Even with the use of high quality optical filters it is not satisfactorily possible to separate the spectral information (see Figure 2). The consequence is the excitation and imaging of YFP-labeled structures with a GFP filter set and vice versa.
Figure 1. Absorption and emission spectra of eGFP and eYFP

Figure 2. Images taken with YFP dichroic and emitter. Left: GFP exciter, right: YFP exciter.

The HeLa cells shown here are transfected with eGFP fused with H2B histone protein and with eYFP-tubulin fusion protein. Ideally eGFP should be exclusively distributed in the nucleus and eYFP should be localized in the cytosol. However, it is evident from the images in Figure 2 that there is a significant contribution of the YFP-labeled structures to the GFP image. Similarly you can see a relatively strong, but undesired fluorescence of the nucleus upon YFP-excitation. This phenomenon, known as ‘bleed-through’, strongly reduces color resolution and constrains scientific conclusions.
10.9.3 The Solution

Olympus’ imaging systems are the first to implement Spectral Imaging and Linear Unmixing, a technique adapted from satellite imaging, into widefield fluorescence microscopy. With this technique it is possible to separate and resort the contribution of different fluorochromes to the total signal in each color channel.

10.9.4 How Does it Work?

The principles of the method can easily be explained considering the example shown in Figure 2. To ‘unmix’ the spectral information of the fluorochromes with strongly overlapping emission spectra, it is necessary to determine the spectral properties of the individual fluorochromes under the same imaging conditions used for the multi-labeled samples: the system has to be calibrated for each fluorochrome. This is performed by taking reference images of single labeled samples with these fluorochromes using the same filter set (excitation filters, dichroic mirror and emission filter) as for the later images of double (or triple) labeled specimen. This means, in our example, that GFP and YFP reference images have to be taken for both the eGFP (Figure 3) and the eYFP (Figure 4) samples.

Figure 3, left: spectral match between eGFP fluorescence and optical filters (HQ480/40x, HQ500/20x, Q515LP and HQ535m); right: reference images of an eGFP sample.
Figure 4. Left: Spectral match between eYFP fluorescence and optical filters (HQ480/40x, HQ500/20x, Q515LP and HQ535m); right: reference images of an eYFP sample.

The ratio of the average intensities of labeled structures (ROIs) measured at the two excitation wavelengths after background correction gives a constant that is specific for each fluorochrome under the given experimental conditions. These two ratios are the prerequisite for the unmixing of the images of double-labeled samples.

The reference images have to be taken only once for each fluorochrome in a given experimental set-up (e.g., filter set, labeling method, cell type).

Now the system is set to examine samples labeled with both fluorochromes. The intensity measured at 450–490 nm excitation is composed of fluorescence due to eGFP plus fluorescence due to eYFP.

10.9.5 **Spectral Unmixing with OV100**

OV100 provides a software module named **Unmixing** that gives you a powerful tool to separate information from strongly overlapping emission spectra of two or three fluorochromes. Spectral unmixing is composed of two steps, **Calibration** and **Unmixing**. It is currently possible to separate two or three different color channels.
10.9.6 Calibration

The first step is to calibrate the contribution of the fluorochromes to the different color channels. Depending on the number of different fluorochromes to be analyzed, different reference samples stained with only one fluorochrome have to be prepared. Acquire multi-color reference images of the reference samples under the same imaging conditions as used later for the experiments with your multi-labeled samples. Load the acquired reference images into the image buffer and click on the Calibration button. This opens the Measure Ratio (Unmixing) dialog window to define two ROIs. The first one has to be within an area where the fluorochrome is visible while the second ROI is used for background correction. To do so press Define ROIs to open the respective dialog box.

The ROIs are set in the same way as in the Image Analysis > ROIs... menu (Chapter 10.4, Regions of Interest – ROIs). Afterwards close the Define ROIs window. The ratio of the average intensities within in the first ROI after background subtraction (see chapter 10.5) is computed automatically and its value displayed in the dialog box. The ratio has to be labeled (e.g., GFP) in the respective box and then saved using the Save button. Depending on the number of different fluorochromes the ratios are respectively stored in the folder cell^R(M) > Unmixing > ratio2 or ratio3.

This procedure has to be repeated for each of the fluorochromes used, that is, for all reference images.

10.9.7 Unmixing

Based on the calibration for the different fluorochromes the ‘unmixing’ of a multi-labeled sample can be performed. Load the multi-color image of a multi-labeled sample into the active image
buffer. In our example it would be a two-channel image of a GFP-YFP labeled specimen taken with the GFP and the YFP excitation filters. Press the **Unmixing** button to open the respective dialog. The OV100 software automatically recognizes the number of color channels and the dialog will have two or three fluorochromes to be selected.

Select the ratio data for the different fluorochromes from the respective pick lists. Before performing the linear unmixing, it is additionally necessary to define a ROI for background correction. To do so press the **ROI Background** button to open the **Define ROI** dialog. Draw a ROI as usual to determine the background intensity.

To start the unmixing algorithms press the **OK** button. The processed image is automatically loaded into the current destination image buffer.

**Acknowledgement**
The images shown were acquired and unmixed with a cell^R Imaging Station and kindly provided by Dr. Paulo Magalhaes and Prof. Dr. Tullio Pozzan, University of Padua, Italy.
11 Graph Display and Graph Analysis

The previous chapter lined out how changes in intensity, for example in time-lapse experiments, can be quantified and plotted in graphs. In the following section you will means to modify and further analyze these graphs and the underlying data spread sheets. The Kinetics tool (Chapter 10.6, Intensity Kinetics in Time and Z) and the line profile tools (Chapter 10.3, Line Profiles: Intensity) of OV100 generate analytical results of fluorescence intensity changes in form of graphs (and spread sheets). They can be either exported into other programs such as MS Excel or further analyzed within OV100.

Several functions do not work on Kinetics graphs.

11.1 Graph Documents

For displaying and processing one-dimensional data, OV100 contains an additional document format, the graph document. Similar to images, newly generated Graph documents or those loaded from an archive are accessible in the Graph page of the Image Manager that automatically opens if a Graph window is activated.

The elements Src (Source), Dest (Destination) and Src2 (Source 2) of the Operands Box now refer to the corresponding graph buffer. The destination graph buffer is used for all graph-operating functions creating a new graph. The Source2 graph buffer is needed for graph operations with two source graphs, for example, for the addition of two graphs. The Graph page closes again if the Viewport or the List or Gallery pages of the Image Manager are activated.

Graph windows are located in the document area – just like the Viewport. They contain special buttons for setting the graph display; see Chapter 11.2.3, The Graphs Button Bar.
11.2 The Graph Window

Upon start of the OV100 Imaging Software the Graph window is minimized and located in the bottom left corner of the document area. If not minimized it might be hidden behind the Viewport but will be brought to the front if the Graph page of the Image Manager is activated. To display a graph select the corresponding graph buffer.

If the mouse cursor is moved over the diagram area it changes into a horizontal double-headed arrow on top of a vertical line.
11.2.1 The Cursor: Changing the XY Scaling in the Diagram

Upon a left mouse click on the graph diagram the cursor changes its shape to a double-arrow cross. Moving the cursor up and down stretches or compresses the Y scaling. Moving it right or left stretches or compresses the X scaling. Alternatively, the scaling buttons of the Graphs button bar can be used; this is explained in detail in Chapter 11.2.3, The Graphs Button Bar. Upon zooming in, scroll bars appear at the right side and at the bottom of the diagram to shift the graph along the axes without a change in the axis scale.
11.2.2 The Cursor: Measuring Individual Graph Points

If the mouse cursor is located over the diagram’s area, the X value of the current cursor position and the corresponding Y value (where the black horizontal line crosses the curve) are given in the status bar of the graph document (at the bottom left corner).

If more than one graph is displayed only the X value is displayed while the Y value is set to zero.

11.2.3 The Graphs Button Bar

The button bar at the top of the graph document is used to change the displayed X and Y range and to edit graph overlays. The different buttons are arranged in functional groups.

11.2.3.1 Scaling the X axis

Zoom In

Click the Zoom In button to decrease the displayed X range, i.e., to stretch the graph in the X direction.

Zoom Out

Click the Zoom Out button to increase the displayed X range, i.e., to compress the graph in the X direction.

Scale X

Click the Scale X button to enlarge any X segment of the displayed graph to full axis size. Mark the left and the right margins by mouse click. The first click generates a blue vertical line, the second a green one. Both can be moved via mouse drag. While doing so, the current X position of the line is continuously shown on the status bar. Right-click to accept the new scale. The two margins remain visible as long as the button remains pressed; once the button is depressed they are deleted.
11.2.3.2 Y Scale

**Zoom Up**

Click the **Zoom Up** button to decrease the displayed Y range, i.e., to stretch the graph in the Y direction.

**Zoom Down**

Click the **Zoom Down** button to increase the displayed Y range, i.e., to compress the graph in the Y direction.

**Scale Y**

Click the **Scale Y** button to enlarge any X segment of the displayed graph to full axis size. Mark the left and the right margins by mouse click. The first click generates a blue vertical line, the second a green one. Both can be moved via mouse drag. While doing so, the current X position of the line is continuously shown on the status bar. Right-click to accept the new scale. The two margins remain visible as long as the button remains pressed; once the button is depressed they are deleted.

**Max. Y**

Click the **Max. Y** button to autoscale the Y range from the minimum to the maximum Y value of the displayed graph segment.

**Auto. Max Y**

This is the dynamic analog of **Max. Y**: The scaling is automatically updated when moving the graph in the X direction by using the scroll bar at the bottom of the graph document.

11.2.3.3 Further zooming and scaling functions

**Define Display Area**

Click the **Define Display Area** button to zoom up a rectangular area of the current graph document. Clicking the button opens the **Define Display Area** dialog box. Click the **Set** button to draw a rectangle into the graph. Use the mouse to resize and move the rectangle to the interesting part of the graph. Click the right mouse button to return to the **Define Display Area** dialog box. Alternatively, you may enter the absolute X and Y-limits of the graph area into the fields of the dialog box. Click the **OK** button to zoom the selected area of the graph to the whole graph window.
11.2.3.4 Diverse functions

Delete All Labels

Click the **Delete All Labels** button to delete all text labels in the current graph.

Window Mode

The **Window Mode** button is currently without function.

Show Legend

Click the **Show Legend** button to display legends of the individual curves in a graph containing the kinetics of more than one image ROI or more than one line profile.

11.2.3.5 Overlay Functions

These functions do not work on Kinetics graphs.

The remaining elements of the button bar refer to overlay functions. The display of more than one curve in a graph document is termed overlay. Use the **Graph Analysis > Overlay Selection...** command to create such an overlay graph.

Overlay Mode

If the **Overlay Mode** switch is set, the scroll bars and all buttons of the button bar concerning the axis scale apply only to the selected curve. These functions can now be used for alignment of the overlaid curve relative to the original graph for purposes of comparison. For example, this function may be useful in cases where one of the graphs has an X or Y offset.
Overlay

Use the Overlay list to select one of the overlaid curves. The original graph cannot be activated because it always remains fixed with respect to the X and Y-axes. The active overlay is affected by the overlay operations explained below.

Fit

Click the Fit button to adjust the Y scale of the overlay to the scale of the actual graph. This function is a quick and convenient method for the direct comparison of two graphs whose Y ranges are very different. The highest Y value of the overlay is adjusted to the maximum Y value of the graph in the displayed X range. You should keep in mind, that after clicking this button the labels of the Y-axis refer only to the actual graph and no longer refer to the overlay.

11.3 The Graph Analysis Menu

The Graph Analysis menu contains special commands for graph processing; they do not work on images. These commands are described in the following.

11.3.1 Markers and Labels

11.3.1.1 Display markers

Use Graph Analysis ➤ Markers and Labels ➤ Display Markers to select whether the markers set during image acquisition are displayed in the graph document.

11.3.1.2 Set labels...

Use the Graph Analysis ➤ Markers and labels ➤ Set Labels... command to add and position annotations to the active graph. Alternatively, right click within a graph document to open the context menu and then click Set Labels....
It is convenient to change the display of the graph so that the interesting region of the graph is completely displayed in the graph document before you use this command.

**Label text.** In the **Label text** field enter the text for the annotations. The amount of text is limited to 116 signs. Click the **Set** button to position the text frame in the graph document. Note that the text frame can only be positioned in the visible part of the graph. You cannot scroll or zoom the graph while you set the labels.

**Anchor text.** Check this box to position the text frame at a fixed position of the graph document. The position of the text frame in the graph area thus remains fixed upon changing the zoom factor or scaling.

Clear the **Anchor text** check box to position the text frame at a certain XY position of the graph. When you shift the graph or change the zoom factor the position of the text frame inside the graph area will change accordingly.

**Centered text.** Use the **Centered text** check box to format the text in the text frame. When the dialog box is opened the text frame is indicated in the graph document by a rectangle. Clear the **Centered text** check box to left-align the text in the text frame. Select the check box to center the text.

**Data position.** Use the features in this group to set a label to a defined X position of the graph. The options are disabled if the **Anchor text** position is deselected.

**Position.** Set the X position where the label shall be placed at in this field. The minimal and maximal X values that can be entered are the left and right margins of the current graph display.
Set and Align. Click the Set button to set the X position interactively. A dashed line connects the text frame (which is initially placed in the center) and the X position of the cursor. Left-click to confirm the setting and return to the Set Labels window. The new X value has been transferred into the Position field. To fix the label at the new position click the Align button. To move the text frame in the vertical direction click the Set button next to the Label text field (not the Set button of the Data position group).

Draw line. Select the Draw line check box to connect the text frame and the X position on the X-axis by a line.

Draw arrow. Select the Draw arrow check box to connect the text frame and the X position on the X-axis by an arrow.

11.3.1 Modify...

Use the Graph Analysis ▶ Markers and labels ▶ Modify... command to change the text and/or the position of the previously set annotations in the active graph. Alternatively, right-click within a graph document to open the context menu and then click Modify Labels....

Labels. Select the label to be modified from the pick list in the Labels field.

Delete. Use this command to delete the label currently listed in the Labels field.

Delete all. Click this command to delete all labels in the active graph. Alternatively, select Data Analysis ▶ Markers and Labels ▶ Delete All from the file menu, or use the respective command in the context menu of the graph document.

Label text. In the Label text field enter the new text for the annotations. The amount of text is limited to 116 signs. Click the Set button to position the text frame in the graph document. Anchor text, Centered text, and the commands within the Relative position field have the same function as described above for Set Labels... (see chapter 11.3.1.2).
11.3.1.4 Copy

Use **Graph Analysis > Markers and Labels > Copy** command to copy the labels of the active graph document into the subsequent graph document (or the graph set as dest buffer) in the Operands Box of the Image Manager.

This tool is very useful to set labels in a series of graphs derived from one experiment at the same position.

- The labels can only be copied if the graph in the **dest** buffer has the same X-axis scaling as the graph of the **src** buffer.
- This command is deactivated for graphs resulting from a Kinetics calculation.

11.3.2 Protect Graph

Use **Graph Analysis > Protect Graph** or click on the **Protect Graph** button in the Standard toolbar to protect the graph from being deleted or overwritten unintentionally.

11.3.3 Delete Graph

Use **Graph Analysis > Delete Graph** to delete the currently displayed graph document. Alternatively, an active graph document can be deleted by pressing the **Del** key.

11.3.4 Graph Information...

Use this dialog box to change the name of the active graph buffer, to enter a graph comment, and/or to have graph information displayed.

How to open the **Graph Information** dialog box:

- Double-click on any graph buffer within the Image Manager to view information on that graph.
- **<Alt>Return** keys: use these keys to view information on the active graph.
- **Image Manager context menu**: right-click on any graph buffer to open the corresponding context menu and then click on **Graph Information**... to see the information of this particular graph without making it the active one (displaying it).
- **Graph Document context menu**: right-click on the graph window to open the corresponding context menu and then click on **Graph Information**...
11.3.4.1 The General tab

This tab contains general Graph information.

**Title.** Displays the title of the graph document. The title can be changed. It can be up to 39 characters long.

**Date.** Displays the date the graph was created.

**Time.** Displays the time the graph was created.

**Comment.** Use this field to add any comments concerning the graph. The comment can be up to 114 characters long.

**Graph Information**

- **Title:**
  - X-axis Title: "Ventricles Position x"  
  - Y-axis Title: "Ratio"

- **Date:**
  - Date: "03 08 003"

- **Time:**
  - Time: "10 47"

- **User:**
  - User: ""

- **Comment:**
  - Comment: ""

- **X-axis:**
  - X-axis Title: "Time"
  - X-axis Unit: "s"

- **Y-axis:**
  - Y-axis Title: "Ratio"
  - Y-axis Unit: ""

**Graph data** field. Here information about the active graph parameters is displayed.

**Graph start.** Displays the start point together with the unit of the abscissa.

**Graph end.** Displays the end point together with the unit of the abscissa.

**Channel width.** Displays the interval and unit between single data points on the X coordinate.

**Graph range.** Displays the total range and unit of the abscissa.

**Components.** Gives the number of graphs displayed in the graph document.

**Channels.** Displays the number of data points on the X coordinate.
11.3.5 Record Graph History...

With Record Graph History... OV100 provides you with a tool which will record the changes done to the original graph. These changes may be due to the execution of certain analyses functions or modifications of the appearance.

Graph Analysis ▶ Record Graph History... opens the Define Graph History dialog box, where you can select the command groups to be recorded if applied to the active graph. Activating the recording adds an additional tab, called History, to the Graph Information dialog box. In this tab the modifications made to the active graph are recorded, according to the previously defined command groups.

Information: Currently only the type of modification without the parameters used is recorded.

11.3.6 Sheet

Image analysis done with the analysis tools from the Image Analysis menu automatically creates a graph but no data sheet. To create data sheets for the graphs, use Graph Analysis ▶ Convert to ▶ Sheet (see Chapter 11.3.7, Convert to). Any data sheet can be edited with the commands in the Graph Analysis ▶ Sheet submenu.
11.3.6.1 Sort Ascending

Use Graph Analysis > Sheet > Sort Ascending to rearrange the data in the highlighted column(s) in an ascending order.

11.3.6.2 Sort Descending

Use Graph Analysis > Sheet > Sort Descending to rearrange the data in the highlighted column(s) in a descending order.

11.3.6.3 Create Copy

Use Graph Analysis > Sheet > Create Copy to create a copy of the currently displayed sheet.

11.3.6.4 Autofilter

Use Graph Analysis > Sheet > Autofilter to activate the autofilter function. If activated the Autofilter command in the menu shows a check mark and the column headers in the sheet feature pull down menus. You can select some predefined functions from a pull down menu to filter the data within the respective column, e.g., select Top 10 to display the 10 sheet cells with the highest value.

User defined... Use to define the lower and upper end of an interval for the rows to be displayed. If Exclude rows is checked, the rows within the interval will be excluded.
**String...** Use to define a string to display only those rows that contain this string. If **Exclude rows** is checked, the rows containing the string will be excluded. For example, if "40??,??" is set as a string for the sheet above, only entries higher than 4000 will be listed.

**11.3.6.5 Edit Column Header**

Use **Graph Analysis ▶ Edit Column Header...** to change the title/header of the highlighted sheet column. The header is limited to 31 characters.

**11.3.6.6 Create Graph from Sheet...**

Use **Create Graph from Sheet...** to make a new graph from the currently opened data sheet. As an alternative right-click within an active data sheet to open the context menu and select **Create Graph...**. From the dialog box you can edit the **Title**, and select the **X** and **Y-axis** for the newly created graph.

**11.3.6.7 OV100 and Excel**

Use **Graph Analysis ▶ Sheet ▶ Start Excel** to open the spreadsheet program Excel, if it is installed on your Imaging computer. Alternatively, right-click within an active data sheet to open the context menu and select **Excel ▶ Start Excel**.
Select **Graph Analysis ▶ Sheet ▶ New Workbook** to open a new workbook in Excel. You can alternatively activate this command from the data sheet context menu. This command can only be performed if Excel has already been started. Otherwise an error message will occur.

To transfer the data from the data sheet to the Excel worksheet select **Graph Analysis ▶ Sheet ▶ Transfer Data to Excel**. The same command can be activated via the context menu of the data sheet. To do so right-click within an active data sheet and select **Excel ▶ Transfer Data**.

### 11.3.7 Convert to

Use **Graph Analysis ▶ Convert to ▶ Sheet** to convert the coordinates of the displayed graph into a new datasheet.

Part of the graph analysis tools is only functional if only one curve is displayed in the graph document. Select **Graph Analysis ▶ Convert to ▶ Series of Graphs** to create a series of single curve graphs from a graph document containing several data sets. All newly created graph documents will have the same X values, but different Y values.

### 11.4 Printing Graphs

Use the **File ▶ Print...** command to print the active graph.

#### 11.4.1 Graphs and Images

How to print images and graphs simultaneously.

1. Activate the image document (not the graph document).
2. Use the File ➤ Print... command. The Print Image dialog box provides you with several general page layouts.

3. To print graphs and images simultaneously choose the Multiple Images ➤ Graphs entry from the Page Layout list.

4. To assign images and graphs to the relevant frames click the Layout... button. The Define Page Layout dialog box opens.

5. Activate the Multiple Images tab.
The Preview group displays the predefined page layout. There is an additional list at the right side of the dialog box. The Documents list displays all available image and graph buffers.

6. Click on the plus signs to the left of the Images and graphs icons to list all image and graph buffers.

7. Use the left mouse button to drag the desired images or graphs onto the frames. The buffer number is now connected with the selected frame and the selected image will be printed at the selected position.

8. Click the Print... button. The system returns to the Print Image dialog box.

9. Click OK to start the printing task.

What will happen...
- The selected images and graphs are fit into the frames.
- Only the graph range currently displayed in the graph diagram is printed.
- In this mode the graphs are always printed without the additional graphs information.

11.4.1.1 Printing Graphs
To print the graph of the active graph buffer activate the graph document and use the File ➤ Print... command. You may print the graph information together with the graph.

What will happen...
- Only the graph range currently displayed in the graph diagram is printed.
- The page layout of printed graphs is preset and cannot be influenced by the File ➤ Define Page Layout... command.

Choose the Graph only option to print only the graph in the active image buffer. Choose the With general info data option to print the information from the General tab of the Graph information dialog box below the graph. The general info data comprises the graph range, the
initial and final values, the number of channels, the data type and a user-defined comment. Choose the With all available info data option to print the information of additional tabs (of the Graph information dialog box) onto a second page.
12 Archiving

The database is an integral part of the OV100 Imaging Software. It allows an organized storage of all acquired images, created graphs and documents like sheets, diagrams and texts. The design of the database facilitates an easy and fast access to even a huge data stock. The database is fully network-compatible and can be used simultaneously by different users.

12.1 Directories for Data Storage

How to specify the directories for data storage?

1. Select Special > Preferences... from the menu bar or alternatively press <F8>.

2. Select the tab Database.

3. Specify a default directory to store all database files in the Database files box. Make sure to use a large partition of the hard disk for storage; the D partition should be used in an Olympus BioSystems imaging PC.
4. Specify a directory in the **Temporary storage directory** box. This directory is used as a temporary storage during data storage and archiving of the database and should likewise be on a large partition of the hard disk.

> On principle it is possible to use network databases or write directly to CD. However, this is strongly not recommended, problems might occur at least in case of large and complex experiments.

5. Check the preset **Backup volume capacity**.
   - When archiving the database on a CD, adjust backup volume capacity in accordance to the size of the volume, e.g., 600.
   - When the system administrator stores the network database, the value for the backup volume capacity should be set to ‘0’.

### 12.2 Open Database...

OV100 offers a number of possibilities for opening an already existing database. Select **Open Database...** in the File, Acquisition or Archiving menus or in the pull-down pick list of the Open button of the standard toolbar to open the Open Database dialog. Navigate to the desired database file (*.apl) and press Open. A recently used database can also be selected from the file list at the end of the Archiving menu.

[Image: Open Database dialog]

Mark the **Exclusive** control box to set or change for example the password for the database, to change the database settings, to execute a SQL statement or to delete a database. Furthermore the several commands in the Database ➤ Administration menu become enabled.

> The **Exclusive** option is only possible if the database is currently not opened by another user. On the other hand, if the database is opened in the **Exclusive** mode, no other user has access to it.
To close an open database select **Database ▸ Close Database** or press the standard MS Windows **Close** button.

### 12.3 New Database...

A database assistant makes it easy to create a new database.

1. Select **New Database...** in the **Database** menu or in the Experiment Manager **File** menu to open the **New Database...** dialog box.

2. Write the name of the new database into the **Database name** field. The database will be created by default in the directory specified in the preferences, see Chapter 12.1, *Directories for Data Storage*. To select a different directory press the **Browse...** button.

3. Click **Next ▶** and then **Finish** if you accept the settings displayed in the dialog.
12.4 The Database Features

12.4.1 General Remarks

When looking at the database window you will recognize features that you are familiar with: buttons, thumbnails and, last not least, icons in a tree structure somewhat similar to the MS Windows Explorer software. However, you will not find the data files on the computer or the storage medium under the same names as displayed in the database window. Internally the data are stored as files with cryptic default names created by the OV100 software. For example, an image time series resulting from an experiment called CFP-YFP in the Experiment Plan, acquired by the system and stored in a database named FRET, for example, will be found on the hard disk as a file named something like 4E55H85C_F00000021.tif in the folder ..\FRET\4E55H85C_DocumentFiles. Easy and intuitive access to the image and analysis data is only possible from within the OV100 software. The "cryptic" file names are listed if the option Table View for the database window is selected in the Archiving ▶ View ▶ Choose View... dialog, see Chapter 12.4.3, Adjusting the Database Window.

Database folder
A database folder is a term for a folder in the tree structure of the OV100 database. This folder is no file folder on the level of the system software and thus is only visible in the data base window but not in a file manager program, like MS Windows Explorer. Database folders are created automatically when an Experiment Plan is executed and carry the name of the experiment. They can also be created via Archiving ▶ Insert ▶ Experiment....

Database fields
The database fields are entries in the table of parameters and information listed for the active document in the Form view of the database window, see next chapter.

Organizational fields
An organizational field is a database field associated to a database folder and thus to all data records within that database folder as well. The organizational field has the same value for all records created in a respective database folder.

The OV100 template database has the predefined organizational fields Experiment Name, Experiment Comment, Date and Time. They are automatically stored with each data record.
Organizational ID
This is the name of the database folder, i.e., the Experiment Name. The other Organizational fields cannot be chosen as Organizational ID.

12.4.2 The Database Window

After opening or creation of a new database, the database window will be displayed. The title bar shows the name of the database: *.apl. Important database commands are accessible via the Button bar of the database window. The lower border displays the Status bar with information about the active folder or file. By default the database window is displayed in Full view subdivided into four areas: Preview, Tree view, Gallery, and Form. The size of the four areas can be freely adjusted by mouse dragging of the borders. The mouse cursor, when on top of an area border, changes from the typical arrow to a double-arrow crossed by two bars to indicate the dragging possibility.

---

Tree view. The Tree view in the lower left corner resembles the structure known from file management programs like Windows Explorer. However, only the database “folder” itself, called `<database name>.apl`, in the top-most level, appears as such in a standard file manager program. The main entries, that is, the folders in the second level in the hierarchy, represent the experiments and are usually created automatically by the Experiment Manager. They contain the
image data, experiment plans, graphs and other documents. Double-click an entry to expand or to reduce the active level.

**Form.** The **Form** view in the lower right part displays a table with information details of the currently active item; in case of image data, for example, all relevant acquisition parameters are listed.

**Gallery.** If an experiment folder is the active entry in the **Tree view**, the **Gallery** field on top right displays thumbnails of the items contained.

**Preview.** This area in the upper left corner shows a thumbnail of the currently active item in the **Tree view**.

### 12.4.3 Adjusting the Database Window

**Arrange fields...**

Use the command **Arrange fields...** in the **Archiving > View** menu or the context menu (the pick-list that appears upon a right-click on the database window) to open the **Arrange fields** dialog window.

The dialog allows to add, to remove, or to change the entries listed in

- the information table of the **Form** area
- the **Info Window**
- the optional **Table View** display of the database window
- the **Query by Example** dialog box
- the **Insert** dialog box

in the currently active database.
**View ▶ Type** lists all available views and data types, **Current** lists all possible parameters for the active view or data types and **Available** lists all further parameters that are not yet in the **Current** list.

To add a new entry to the **Current** list select it from the **Available** list and then press the **Add>>** button. To remove an entry from the **Current** list select it and press **<<Remove**.

The order in which the entries are displayed can easily be changed. To do so select the entry that is to be moved and click the **Up** or **Down** arrow button.

Press **Get Default** to use the default settings for the different views and data types.

To use the same settings for a specific data type for all views, press **Set to all of this type**.

---

**Choose View...**

Use the command **Choose View...** in the **Database ▶ View** menu or the context menu (the pick-list that appears upon a right-click on the database window) to open the **Choose View** dialog window.

Six different views are available for the database window. By default the database window opens with the **Full View ▶ Gallery View** – the one shown in the previous chapter. Two other alternative displays for the Full View can be selected.

In the **Table View** the thumbnails of the Gallery is converted into a table with icons instead of thumbnails. Additionally it lists the "cryptic" default names under which the files are stored and appear in disk management programs, see Chapter 12.4.1, **General Remarks**.

When the **Horizontal Gallery View** is selected, the gallery is displayed as a scrollable single row of thumbnails. Thus more space remains for the Form view.

In the **Narrow View** the **Form** view is removed and the **Gallery** displayed as a single column. The database window is attached to the Image Manager and Viewport Manager windows but can be moved freely at will.

---

**Full View 📊, Narrow View 📊**

The **Full View** and **Narrow View** buttons allow toggling between these two view options.
In the **Structure Strip** mode only the **Tree view** and the **Preview** are displayed.

Select **Gallery Strip** to reduce the database window to the **Gallery view** in form of a single column of thumbnails.

---

**Update Views**

Select the command **Archiving > View > Update Views**, use the key `<F5>`, or press the **Update Views** button in the button bar of the database window to refresh the display of the database window.

---

**Info ; Pin**

**Info Window**. Select the command **Archiving > View > Info Window** or click on the **Info** symbol on the bottom right corner of a thumbnail in the **Gallery** to open the **Info Window**.

The information displayed can be defined in the dialog **Arrange fields > Info Window**. Usually the window closes if a different icon or document is activated. To prevent this press the **Pin** button in the **Info Window**, the button turns into a counter-sunk pin. Now the window remains open showing the information about the active item. The **Info Window** can be closed as usual with the **Close** button.

---

**12.5 Working with the Database**

**12.5.1 Loading Documents**

Any document contained in a database can simply be loaded by a double-click on the thumbnail in the **Gallery**. However, this does not work for the icons in the **Tree view**. Image data and graphs can also be loaded by drag&drop into slots of the **Viewport Manager** or **Graph Manager**.
12.5.2 Inserting Documents

Images acquired via the Experiment Manager and the Experiment Plans used for the acquisition are stored automatically in the database. Snapshots, processed images and analyses, however, are not stored automatically. To store these documents within the database the Insert function has to be used. The Save as... function leads to data export.

The active image set can be inserted into the active folder of the database with the Insert Image button. Alternatively, an image can be inserted by dragging it from the Image Manager into a database folder. More than one image can be selected by using <Shift> + click or <Ctrl> + click. A dialog box opens where the Record Name and Sample / Preparation can be given and a Comment can be added. Upon clicking Insert the image set will be moved from the temporary folder to the database.

For all other types of data the menu Database ▶ Insert has to be used.

Archiving ▶ Insert ▶ Experiment...
This command creates a new Database folder in the active database.

Archiving ▶ Insert ▶ Image...
This has the same function as the Insert Image button.

Archiving ▶ Insert ▶ Images...
This command allows inserting a series of images from the Image Manager into the currently opened database folder. Select the images to be added from the Insert Images window that opens. If the option Always is selected in the Prompt for data input field, the insert dialog will appear every time before an image is inserted.

Archiving ▶ Insert ▶ Image File...
This command imports stored image files, for example from the hard disk, into the database.

Archiving ▶ Insert ▶ Data...
This command opens a dialog box that enables the user to add a comment to the database folder. This comment is not an independent document but is an entry in the Field table.
Archiving ▶ Insert ▶ Documents...
This command inserts Graphs, Sheets or Text documents/Macros into a database folder. Select the documents to be added from the **Insert Document** window.

Archiving ▶ Insert ▶ Document File...
The command allows to import stored document files, e.g. from MSWord, MSExcel, etc., into a database folder.

12.5.3 Query

Query (by Example...)  

Archiving ▶ Query by Example...

The database architecture of OV100 allows to search the contents of a database for documents that match certain criteria. Click the **Query** button or use Archiving ▶ Query by Example... to open the search mask. The fields in the dialog box are listed by default but can be changed as
explained in the next Chapter 12.5.4, Administration: Defining Organizational and Database Fields.

Type in search parameters and click Search. The results will be listed in the database in a new folder called Query results and indicated by the query icon. Name fragments can be searched – as common in other programs as well – if the fragment entry is framed by asterisks, e.g., *<name>*.

If the active entry in the database is a folder, the query will only scan the contents of this folder. Activate the database icon in the Tree view to search the entire database.

A query can be further refined by marking data types in the Advanced view of the dialog box. Documents that do not match the selected types will not be considered in the search.

To find the location of an entry in the database first mark the thumbnail, then right-click to open the context menu and select the command Goto Record.

A database can contain only one Query results folder. If a new query is carried out the contents will be actualized.

Archiving ➤ Query by Free Filter...
This command allows to perform queries with several criteria combined with AND or OR links.

Archiving ➤ Query by SQL...
This command enables the usage of the SQL database language to define search criteria.

12.5.4 Administration: Defining Organizational and Database Fields

Create a new database or open a database in the Exclusive mode and select the command Archiving ➤ Administration ➤ Define fields... to open the Define fields window.

The Field list contains the Organizational ID Experiment Name and the predefined database fields.

New button. This button creates a new database field. The name is given as User field + <sequential number>. The name of the newly created field is displayed in the Current field box and can be edited.

The Data type pick-list allows selecting different data types, e.g. text, date, time, number, etc.

Required. If this option is marked, the respective information will always be stored together with a new document.
Organizational ID. This option is exclusively available for Experiment Name.

Organizational field. If this option is clicked, the respective information will be associated with the database folder and all records stored within.

Display: Organizational field. This option instead of All Fields allows viewing solely the organizational fields.

Default. Select either Value of last input or the Editing field to automatically store either the last value or the edited value, respectively.

Picklist: Edit...: Click here to define a Picklist for the Default Editing field. Options for the Picklist can be selected via the respective radio buttons.

Arrange button. This button leads to the dialog box described in Chapter 12.4.3, Adjusting the Database Window.
13 The Special Menu and the Window Menu

Macros are little programs that allow to repeat series of processing and analysis steps upon a click of a button. Here we explain how such macros can be generated. Also you will find in detail how personal preferences for the software user interface can be set.

13.1 Macros

This command opens a submenu:

<table>
<thead>
<tr>
<th>Special</th>
<th>Window</th>
<th>?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macros</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Imaging C</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add-In Manager...</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit Button Bars...</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Define Menu Bar...</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

13.1.1 General

Macros and C modules (commands under Special → Imaging C, next chapter) are very similar. In general, macros and C modules fulfill the same tasks. C modules are often complex and make use of all elements of a programming language. Macros, on the other hand, are supposed to handle simpler tasks. They are mainly used to combine available internal functions with C modules, together forming a sort of chain-link fence of mutually dependent elements – e.g., linking a frequently used series of functions into one single function. Whereas C modules are more loosely integrated into a configuration (remaining independent files), a macro will fully become part of the configuration itself.
13.1.2 Record Macro

Use this command to record a series of commands in the macro language, Imaging C, while you are executing the commands. These recorded series of commands can then be used as the basis for developing your own macros. Macros take several steps and integrate them into one macro.

You may also click on the Record Macro button in the Macros toolbar.

**Application.** Certain image analysis processes frequently require series of commands that are repeated over and over again. The macro recorder enables you to record these commands and subsequently have them all run automatically instead of having them execute one at a time – again and again.

**General settings.** Select Special ▶ Preferences... or press <F8>. The Module tab contains the Macro recorder field. The selectable settings have to do with the recording of argument names and image buffers.

**What will happen...**

- After activating the Record Macro command, the Recorder button bar will appear.
- This menu command’s function will be changed – to Stop Macro Recorder.
- OV100 will generally open a new text document at this stage. If a text document is already open, you can append the commands you’re recording at the end of this text. To do so, activate the text document before activating the Execute Macro command.
- All operations you execute within OV100 will now be recorded in this text document. Each step will result in one or more functions being recorded in the text document. If you’d like, you can have the image buffer selection in the Image Manager recorded – this has to be preset in the Special ▶ Preferences... ▶ Module tab.
- Stop the recording with the Stop Macro button.

**Saving macros.** Use the Save command (in the File menu) to save the macro recorded. Now you will be able to re-load, modify or add this macro in OV100.
13.1.3 Executing Macros

There are a variety of ways to execute macros:

- Activate the text document containing the macro. Start up the macro with <F5>.
- Activate the text via the macro. Use the Special › Macros › Set as Default-Macro command (in the menu, see below). Now the macro can be executed anytime pressing <F5> – even if the text document isn’t active.
- Select the Special › Macros › Define Macros... command to integrate the macro into a particular configuration as button, menu command or key combination. This is explained below.
- The macro can then be integrated into an Imaging-C module – if your program version enables you to write your own C modules. To do this, you could use, e.g., the settings shown in the Special › Imaging C › New Module dialog box. Set a name and click on OK to generate a text document that has a sample program in it already. Simply substitute your macro text with the following line

```c
dlgOutput("Hello World");
```

and then compile your module using the Build Module command (in the Special › Imaging C menu, see below).

Editing macros. If you wish to alter a macro, be aware of the subsequent points:

Opening dialog boxes. The macro recorder records many commands so that linked dialog boxes will not be opened when you execute the macro. To change this, all you need to do is append a dollar sign [$] to the names of the functions within the recorded macro.

Example. Use the Image Analysis › Filter › Define Filter › NxN command to open the corresponding dialog box. The macro recorder will record the following entry, e.g.:

```c
DefineNxN(Iterations:=3, Size:=10);
```

If you accept the command as recorded, the dialog box will not be opened and selected parameters will always remain the same. To open the dialog box, you just have to modify the entry as follows:

```c
DefineNxN $();
```

Now, when you activate the macro, the Define NxN dialog box will be opened and you can adjust the parameters.

Logging dialog box parameters. When you call up a dialog box there are two ways to log the entered parameters during recording of the macro:

Command window output: Anytime you like you can have values within a macro output in the command window. Use the ? operator to do this.
Working with loops. Quite often you want to apply a recorded function series to more than one image. This can be easily achieved by supplementing the macro with a basic for loop.

Example. Select the Horizontal Distance command (in the Image Analysis ➤ Measurements menu). In this case the macro recorder will record the following entry:

HorizontalDistance();

Let’s suppose you wish to conduct this analysis for 10 similar images. The images are in image buffers 1-10. To solve this task, set a for loop around the commands recorded:

```c
int i; //Variable i is defined
for(i=1;i<11;i++)
{
    Op.Display=i; //Image buffer is set
    HorizontalDistance();
}
```

Imaging C Online Help. To get a precise description of the recorded commands use the Imaging C online help. Select a command in the macro text and then press <F1>. The Imaging C online help for this command will automatically be opened.

13.1.4 Stop Macro Recorder

After you have executed all commands or image analysis steps to be included in the macro, click on the Special ➤ Macros ➤ Stop Macro Recorder command. Or simply click on the button with the same name in the Recorder button bar. The Stop Macro Recorder command will appear during a macro recording instead of the Record Macro command - in the Special menu.

13.1.5 Run Macro

Use the Special ➤ Macros ➤ Run Macro command to execute the commands in the active text document or the selection in the active text document as a macro. You may also simply click on the button with the same name in the Macros toolbar or press the <F5>.

What will happen... The exact function of the Run Macro command will depend on the current context.
Text document. The active document is a text document containing a macro text. OV100 is not in the debug mode and the active text document does not contain a selection: in this case the entire text document will be interpreted as an Imaging C program and executed in the interpreter mode. Before doing so, the interpreter will be reset. This means that all variables and functions defined in the interpreter mode are internally reset. They remain however in the text.

Text document and selection. The active document is a text document containing a macro text. OV100 is not in the debug mode and the active text document does contain a selection: In this case the interpreter will not be reset. Only the commands selected will be executed.

Debug mode. If OV100 is in the debug mode (Special > Imaging C > Quick Watch..., see below), the program will continue with the next command independently from the active document’s type.

Syntax error. If a syntax error is found in the macro text, the first incorrect line will be selected and a warning indicating the type of error will be displayed.

13.1.6 Single Step

Use this command or the <F10> key to execute a macro one step at a time.

The Single Step and the Run Macro command have the same meaning. Single Step, however, executes the macro one step at a time – under user control.

Application. This command is very useful for running a systematic error search in a new macro. You can follow the flow of the program and have the content of variables and expressions displayed simultaneously.

What will happen... The exact function of Single Step will depend on the current context.

Text document. If OV100 is not in the debug mode and the active text document does not contain a selection, the entire text document will be interpreted as an Imaging C module and executed stepwise in the interpreter mode. Before doing so, the interpreter will be reset. This means that all variables and functions defined in the interpreter mode will be internally reset, but remain in the text. The Debug button bar is displayed and the mouse cursor will be transformed into the shape of a hand. The first executable step will be indicated by the footprints symbol at the beginning of the text document line.

Text document and selection. If OV100 is not in the debug mode and the active text document does contain a selection, the interpreter will not be reset. Only commands that have been selected will be executed. The Debug button bar is displayed and the mouse cursor will be
transformed into the shape of a hand. The first executable step will be indicated by the footprints symbol at the beginning of the text document line.

**Debug mode.** If OV100 is in the debug mode, the program will continue with the next command, independently from the active document’s type. The line containing the command will be indicated by the footprints symbol.

**Syntax error.** If a syntax error is found in the macro text, the first incorrect line will be selected and a warning indicating the type of error will be displayed.

### 13.1.7 Reset Interpreter

Use this command to re-initialize the macro interpreter.

**Definition.** Each time a command is executed it is compiled in the interpreter mode. OV100 makes use of this mode when a command is executed via the command window, when the text of a window is interpreted by the Run Macro command or when a macro is defined using the Define Macro... command.

**What will happen...** All variables and functions defined in the interpreter mode will be deleted internally but not in the text document.

### 13.1.8 Set as Default-Macro

Use this command to define the active text document as the default macro.

**What will happen...** Using the Run Macro command will have the active text document executed as a macro. Execution is not possible if the image document is active. The Set as Default-Macro command defines a text document which will then be executed when the command Run Macro is selected. This permits the execution of the associated macro even if a non-text document is the active document.
13.1.9 Define Macros...

Use this command to add new macros to the configuration. The corresponding dialog box opens.

![Define Macros dialog box]

All macros that integrated into the OV100 Graphical User Interface using the Define Macros... command must be saved in a user configuration. Use the Special > Configuration > Save... command to save the configuration.

**Macros.** Name your macro in the Macros field.

**Add.** Click on the Add button after entering the name of the macro into the Macros field. The name will be added to the existing macros list.

**Warning.** A macro it must be added to the list in order to be defined. It is not sufficient to exit the dialog box by clicking on OK.

**Delete.** To delete a macro from the list - select it and then press Delete.

**Macro description.** In the Macro description field you can insert a brief description of your macro.

**Macro text.** Enter the program code of your macro into the Macro text field. Normally you first record and test a macro in a text document. Use the Copy and Paste commands (in the File menu) to copy the macro text into this field. A macro text can be no longer than 1000 characters.

**Definition of more comprehensive macros.** If you wish to define a longer macro, you should remove the macro text for safe storage in a file via the #include command (see below) – or have
the macro implemented via a C module. To do this, first save the program code of the macro, e.g., in a file named 'C:\cellR\macro\MyMacro.sfm'. Enter the following line into the Macro text field:

```
#include<C:\cellR\macro\MyMacro.sfm>
```

When you use the `#include` command within a macro function you’ll have to reset the interpreter every time you make an alteration to the file (linked to the macro) in order to have the function re-defined. To do this, use the **Reset Interpreter** command (in the **Special** menu). The interpreter will be automatically reset when you exit the **Define Macros** dialog box via **OK**.

**Define as macro function.** If the **Define as macro function** check box has been selected, a macro function will automatically be defined using precisely the same name with which it was entered into the **Macros** field. You may then use this new function within other macros or you may activate it directly from the command window. For example, if the macro name is 'MyMacro', you can activate it by entering

```
MyMacro();
```

into the command window. This check box is only available if your program version includes the **C Module** menu.

**Reset Interpreter.** If the **Reset Interpreter** check box has been selected OV100 will reset the interpreter before running the macro. This means that all definitions made in the interpreter mode (e.g., variable definitions, function definitions, etc) will become invalid. This ensures that macro definitions will not conflict with previous definitions. This check box is only available if your program version includes the C-Module menu.

**13.2 Add-In Manager...**

Use this command to add/load optional extensions to the OV100 standard configuration.

**Definition.** The range of functions OV100 provides can be extended as much as you like. An Add-In is an additional program developed for special tasks that you can integrate into your program using the Add-In-Manager. All add-ins are optional – i.e., OV100 does not require any add-ins to be fully functional.

Add-ins can be Imaging C modules (SXU) as well as program libraries (DLX).

**Available add-ins.** The Available add-ins list displays all add-ins available in your program package. These add-ins are automatically a part of the program when you install it. They are not, however, automatically activated.
Activating add-ins. Select the check box next to the name of the program to activate the add-in. A number of add-ins can only be used after you re-start OV100. If this is the case, you’ll receive a message to this effect.

Some of the available add-ins will already have been activated as they make up essential components of OV100. Take the image database, for example - it’s an add-in. If you clear the check box next to the entry Graph Processing, the whole Graph Analysis menu will be gone the next time you start up OV100.

Add-ins that have not yet been activated remain on offer. We recommend however, that you activate only those add-ins that you really need. Otherwise, you’ll have too many superfluous button bars or commands making the appearance of the Graphical User Interface unnecessarily complex.

Add-in information. Select an entry in the list of add-ins to view a brief description of that program. It will be displayed in the lower field of the dialog box.

Close. Click on the Close button to close the dialog box and to save any alterations you’ve made.

Add... Click on the Add... button to insert an add-in to the list of available add-ins. The standard dialog box for loading files will be opened. The file types available to you are the following add-in formats: SXU and DLX. Generally you’ll only need to insert add-ins in two cases: either you had deleted existent add-ins, or an additional add-in has been purchased.

Remove: Click on the Remove button to remove an entry from the list of available add-ins. This button only removes the entry from the dialog box. The add-in file will not be deleted. Any add-in you’ve removed can thus be re-added at any time. However, you need to know the corresponding *.sxu or *.dlx file name.
13.3 Define Menu Bar...

Use this command to alter the configuration of the menu bar or context menu.

Any alterations you make to menu definitions via the Define Menu Bar... command and integrate into the OV100 Graphical User Interface have to be saved in a user configuration. Use the Special ▶ Configuration ▶ Save... command to save the configuration.

Explanation. Menus are organized hierarchically. Main menu entries contain commands and submenus. An arrowhead to the right of an entry denotes a submenu. Submenus contain further commands. Three dots behind a command indicate that a dialog box will open.

Menu. The contents in the Menu list can be toggled with the Show Main Menu and Show Sub Menu buttons. As soon as you select an entry in this list, that entry will appear in the field above the list. This entry is the menu element ready for editing. You can, e.g., alter a name in the list of menu entry.

Show Sub Menu. Click on the Show Sub Menu button to move down a level in the menu hierarchy display. This button is only available if you've selected a menu or submenu entry. When, for example, the main menu is being shown, you can select an entry and then click on the Show Sub Menu button to have a look at all commands belonging to the entry selected. Then once all commands of a specific menu are being shown you can select a submenu and then click on this button to have a look at all the commands contained by that submenu. An easy alternative is simply to double-click on the entry in the Menu list.
Show Main Menu. Click on the Show Main Menu button to move up a level in the menu hierarchy in the Menu list. This button will not be active when the main menu is being shown in the list (you cannot go any higher...!). This button will become available when you click on the Show Sub Menu button, moving you down a level in the menu hierarchy.

Command groups. Specific groups of commands can be selected from the Command groups list. If you select, e.g., All Groups, all available commands will be displayed.

Commands. The Commands list shows available commands depending on which group of commands was selected in the Command groups list.

Description. The Description field provides a brief description of the menu or command selected.

Up or Down. After you have selected an entry from the Menu list you can adjust the position of the element by clicking on either the Up or Down buttons. A main menu will be moved either to the left or right within the menu bar; a command will be moved up or down within its menu.

Delete. Click on the Delete button to remove the menu element shown in the Menu field. Individual commands can be removed from a menu, or you can remove a whole menu.

Modify (Add). Click on the Modify button to alter the name of a menu or command. When you’ve selected an entry in the Menu list you can alter the name of the entry in the Menu field. As soon as you’ve entered the new name, the Add button’s function will be changed to Modify.

Insert sub menu. Select the Insert sub menu check box to be able to use the Add button to insert a new menu. Enter the name of this menu into the Menu field. The new menu will be located at the same menu hierarchy level as current entries in the Menu list. So if you wish, e.g., to insert a new main menu, do it when the list of main menus is being shown.

Add. Click on the Add button to

- Create a new menu:

  1. Select the Define Menu Bar... command in the Special menu.

  2. Enter the desired menu name into the Menu field, e.g., ‘&Name’.

  3. At the same time, you can also define a short cut for opening the menu more quickly: enter the ‘&’ sign along with a letter, e.g., ‘&N...’. This means you’ll be able to open the menu using <Alt+n>.

  4. Select the Insert sub menu check box.
5. Click on the Add button.

6. The new menu will be appended to the Menu list.

7. The new menu entry will be selected in the Menu list.

8. Click on the Up button to move the new menu into the menu bar position desired.

9. Click on the Show Sub Menu button.

10. Select the first command for the new menu.

11. Click on the Add button.

12. Repeat the above two steps until your menu is complete.

13. Click OK.

- Create a sub-menu:

1. Select the Define Menu Bar... command in the Special menu.

2. Double-click on the name of the menu for which you wish to create a submenu.

3. Enter the name of the submenu into the Menu field.

4. Select the Insert sub menu check box.

5. Click on the Add button.

6. Double-click on the name of the new submenu in the Menu list.

7. Select the commands desired for the new menu and click each time on the Add button.

8. Click OK.

- Create a command:

1. Select the Define Menu Bar... command in the Special menu.

2. Double-click on a menu.

3. Add a new command or delete an existing command.
4. Click on OK.

13.4 Configuration

Select Special > Configuration to open a sub menu containing the three commands Reset, Load..., and Save....

Definition. The term Configuration refers to the appearance and functions of the Graphical User Interface (GUI). A configuration consists of the following elements:

- User-defined menus or an altered pre-defined menu using the Special > Define Menu Bar... command.
- Macros generated using the Special > Macros > Define Macros... command.

The configuration does not include the settings for the Viewport Manager or the Image Manager. Settings of individual dialog boxes are not part of the configuration either.

Information about the loaded modules is not part of a configuration file. This means that after loading the standard configuration no modules will be removed. Modules that are part of a configuration file are those whose MAPI functions, e.g., are used in the configuration’s menus. These modules will be automatically loaded along with the respective configuration.

If OV100 is being used alternatively by various users or for varying tasks it makes sense to set up individual workspaces. The configuration of the relevant workspace used last will be automatically loaded along with many other settings when you start up OV100.

13.4.1 Reset

Use this command to restore the original standard configuration.

What will happen... Once you have modified a menu or a button bar, or after you have integrated macros and programs into the system, selecting Reset returns you to the original standard configuration. This is helpful when you no longer need the current configuration or when you want to create further configurations based on the standard configuration.

Saving current configuration. If you have made alterations to a particular configuration – which have not yet been saved – before the standard configuration is loaded, you’ll be given the opportunity to save your altered, current configuration.
13.4.2 Load...

Use this command to load a previously saved configuration.

**Available.** If you've already created and saved your own configuration, you can activate it using the **Load...** command, making it your current configuration. If you load a configuration that was created with an older OV100 version, the **Update Configuration: *.scy** dialog box will open.

**Cancel.** If you exit this dialog box via **Cancel**, the older configuration will not be loaded.

**Use standard configuration...** If the configuration you wish to load contains essential user-defined functions you would be well advised to load that configuration using the **Use standard configuration and include functions defined in selected configuration** option. In most cases, this option will get you the desired result.

**No update.** If the configuration you wish to load is however a reduced version of an older standard configuration, you would do better to use the **No update: ignore new functions of this program version** option. In this case, the configuration will be loaded precisely as it is.

Any commands that are exclusive to the current program version are not part of the older configuration. Thus these commands will not be available. If you want to use them, it will be necessary to add them manually to the configuration using update commands, e.g., the **Specials ▶ Define Menu Bar...** command. This option should be used in cases where you simply do not know in what way the older configuration differs from the current configuration.

If necessary repeat loading of a configuration to achieve the result desired using another option. If you're happy with the results of your loading of an older configuration then save this now current configuration using the **Configuration... ▶ Save...** command (in the **Special** menu). The next time you load this configuration, you'll be able to load it without any further queries.
13.4.3 Save...

Use this command to save the current configuration.

**Application.** Select the Save Configuration... command to save your individual configuration. You can recall this configuration at any time. Configurations can be designed for different tasks and/or users, and saved as individual settings.

**File format.** A user-configuration file is saved using the *.scy* file name extension.

### 13.5 Preferences...

Use this command for setting preferences within OV100. The Preferences dialog box can alternatively be opened with <F8>.

#### 13.5.1 The Preferences → Image Tab

The settings on this tab apply the handling of images.

![Preferences Dialog Box](image.png)
Overview

- You can adjust the number of available image buffers in the image manager.
- You can activate the circular switch and set the cycle width.
- You can select whether you want to receive a query message when you delete or copy images from the image buffer via drag & drop.
- You define whether most of the menu commands are also allowed for false color images.
- You can predefine the image name automatically set for image acquisition.

Imaging functions
The settings in this group are relevant for image processing operations, for altering gray or color values of an image.

Available image buffers. Enter the desired number of image buffers to be available in the image buffer box of the Image Manager into the Available image buffers field. You can select between 16 and 200 image buffers. Any change in the number of image buffers only becomes effective after you restart OV100.

Circular switch. Select the Circular switch check box to activate the circular switch. As a consequence the destination image buffer will automatically be different from the source image buffer, i.e., the active image cannot be overwritten during image operations.

Destination image buffer and circular switch. The image buffer used as destination buffer depends on various settings:
- the number of Viewports displayed in the image document,
- whether the image buffer is protected, and
- the circular switch settings.

Single view: If you only have one Viewport displayed in the image document, the destination image buffer will be set to the next-highest image buffer after each image operation. The highest image buffer available represents the limit of the range of the circular switch. At this point, the destination image buffer will be set back to image buffer 1. If you set the range of the circular switch at, e.g., 8, the destination image buffer will be raised successively to the 8th image buffer, and then go back to image buffer 1.

Multiple view: In this case, the circular switch range is meaningless. If you’re working with several Viewports, the destination image buffer will be set to the next respective Viewport. If, for example, you’re working with four Viewports - assigned respectively to image buffers 2, 6, 3 and 8 - the destination image buffer will be successively set to 6, 3, 8 and then 2 again. If you’re working with two Viewports, for example, which are currently assigned to image buffers 7 and 8, the destination image buffer will switch back and forth between image buffers 7 and 8.

Write-protected image buffers. If the next image buffer is write-protected, the one after that one will become the destination image buffer.

Allow operations on false color images. Select this check box to apply image operations that change the gray values of an image to the false-color images as well. Several image operations applied to the gray-value image, do not affect the displayed false-color image – i.e., the resulting image has altered gray values, although the lookup table remains the same. For this reason image operations applied to false-color images may yield unexpected results.
Image acquisition
Sequence. The option chosen here determines where a newly acquired snapshot will be placed in the Image Manager and whether it will be stored in the active database or not.
None. A newly taken snapshot will always be placed into the active buffer in the Image Manager overwriting any image currently being placed there.
Image buffers (All). A newly taken snapshot will always be placed into the next buffer in the Image Manager overwriting any image currently being placed there.
Image buffers (Circular Switch). This is the default selection. A newly taken snapshot will always be placed into the next free buffer in the Image Manager unless all buffers are occupied. In that case the last one to be filled will be overwritten again and again.

Prefix for images. This setting applies to the standard names OV100 provides when you acquire an image using the Acquisition ▶ Snapshot command. Enter the prefix of an image name into the Prefix for images field. A prefix consists of up to 8 characters of upper- or lowercase letters, numbers or special symbols. Each new image you acquire will then be given automatically this prefix. The default is Tv.
Incremental number. This setting applies to the standard names OV100 provides when you acquire an image using the Acquisition ▶ Snapshot command. In the Incremental number list, select the number to be given to the next snapshot to be acquired. Each successive image’s number is raised by 1. This value is a whole number with a maximum of eight digits. The lowest value available is 1. This number will automatically be reset to 1 every time you start up.

Confirm operations
Drag & Drop. Decide whether you wish or not to receive a query message when you Copy image or Delete image in the image manager using drag & drop. To select these options set the tick marks in the respective small boxes. These queries apply only to the dragging & dropping of images. You will not receive a query when using the Edit ▶ Delete Image and Edit ▶ Copy commands.
Overlay. Decide whether you wish or not to receive a query message by selecting the check box Delete overlay. If you select Burn overlay the overlays will be saved together with the image, thus it will change the image data.

Image Manager tabs
Select here whether the Image Manager should list all loaded images as a list with name entries, as thumbnail gallery or both.
13.5.2 The Preferences › View Tab

The settings of this tab apply to the OV100 Graphical User Interface.

Overview

- Choose the font size for OV100 image overlays and sheets in this tab.
- Decide whether the mouse cursor is to be transformed into the shape of an arrowhead or of crosshairs during interactive measuring.
- Decide whether the name of a function is to appear along with a brief description of the command in the status bar.
- Indicate whether you’re working with a general or individual workspace.
- Align the image document along with all other document windows when you use the commands of the Window menu to sort the document windows of the Graphical User Interface (GUI).

Overlay

Set the Font size for texts in the overlay and the Pen size (line thickness) for the overlay drawing tools.

Sheet

Determine sheet font and font size for sheets in the Sheet group. Arial is the default font set in the Font list; the Font size is automatically set to 10. Select the settings from the pull-down lists accordingly to change the Font or the Font size. The settings apply to the values in the sheets themselves as well as the column headers and the first sheet column, containing the row numbers. Any alterations you make to the settings here apply to any open sheet document. Set the number of Decimal places of the values displayed in the sheets.
Mouse cursor

**Style.** Determine the shape of the mouse cursor. This applies only to interactive commands like drawing ROIs, measurements and overlay drawings. You have three choices: an **Arrowhead**, a **Small crosshair** or a **Large crosshair** (which covers the entire image).

**Primary.** Determine the temporary color, for example, of a ROI while drawing it. After terminating the action the color switches to the designated (permanent) color.

**Auxiliary.** Determine the temporary secondary color, for example, of the distance to be measured. After terminating the action the color switches to the designated (permanent) color.

**Navigator.** Determine the color of the frame indicating the current image cutout in the Viewport manager.

### General

**Function names & arguments in status bar.** If selected, function name and arguments of a command will be shown in the status bar (lower right corner of the OV100 window) in addition to a brief description. To view the respective status bar information, simply select the command of interest. To see the information about buttons in the tool bar, simply position the mouse cursor on the button of interest.

**Startup with user dependent settings.** If selected, on startup your own individual workspace will be displayed. If this check box has already been selected, clear the check box and then select it once more to enable startup with your own workspace. To load the general workspace for all users clear this check box.

### Workspace

**Workspace** comprises most settings of your last work session, including:

- Viewport Manager and Image Manager structure.
- Settings of individual parameters in many dialog boxes.
- The most recently loaded configuration – i.e., menu structure, button bars and key assignments.

If you have tick marked this check box, your individual workspace will be saved in the `<user>.INI` initialization file. This initialization file will be called, e.g., `JOECOOL.INI` if you’ve logged onto Windows using the name “JoeCool”.

If you have NOT selected this option the workspace will be saved in the `ANALYSIS.INI` general initialization file. This workspace will be for all other users who also have NOT selected this option. The next time you start up OV100 you’ll receive the workspace as used by the last (general) user – i.e., a user who was not using an individual workspace.

**Application.** In addition to general and individual workspaces, you have the option of creating and saving several initialization files along with various workspaces. These workspaces can be varied by topic, for example. When you start up the program you can select which workspace you wish to work with. It's not necessary to create your own individual workspace if you're the only user on your system and use to work with only one single workspace.
13.5.3 The Preferences › File Tab

The settings of this tab apply to various options for saving images and sheets.

**Overview.** On this tab you decide

- the default method of compression for TIFF images and quality of JPEG images,
- whether the active configuration is automatically saved when you shut down OV100 or whether you are to receive a query message,
- whether an automatic back-up of the previous text file is made when saving the current version of the respective text document,
- the default file type for saving and opening images and documents, and
- how many entries are to be listed in the recent file list.

**Save image files**

Here you can set defaults for saving images in the TIFF, JPEG, JPEG200 and LEAD formats.

![Image](image.png)

**Tagged Image Format (*.tif).** The TIFF format is the standard image format in OV100. Select another image format only if you wish to export images to another application program - which cannot read the TIFF format. The TIFF format enables you to save additional information along with the image itself. In OV100 this non-image information refers to, e.g., calibration data, image comments and overlays.

**Preprocessing.** In the Save Image Options dialog box you can select Preprocessing commands. Before saving the image you can adjust whether the image should be Converted form 16-bit to 8-bit and whether the Burn overlay into image should be done, by clicking the respective check boxes.
Compression. The TIFF format also supports a series of compression methods (Packed Bits, JPEG, JPEG 2000) for reducing the file size of an image you are saving. The methods can be selected from the list in the Compression field. This allows you to save more images than you could without compression – an important point as far as image archiving is concerned. Compression can be relevant as far as long-distance image data transmission is concerned – transmission time is reduced due to smaller file size, thus reducing costs. To return to the default settings – no Preprocessing and no Compression - press the Default button.

JPEG (JFIF, *.jpg), JPEG2000 (*.jp2), LEAD Compression (*.cmp). In order to achieve a stronger data reduction you may choose to export images using these formats. However, they go along with loss of quantitative information in dependence of the compression quality. JPEG does result in information lost – i.e., an image you had saved using the JPEG method is no longer 100% identical to the original image. A compressed image is no longer of any use for precise quantitative analysis. You may have trouble making out the difference with the naked eye – depending on the degree of image compression. Some image information loss may be acceptable for applications where the most important thing is the visual appearance of the image.

JPEG compression provides fine results for gray value and true-color images of a photographic quality. For applications where color- or gray value distribution is important, we recommend to avoid JPEG compression. JPEG compression is not suitable for synthetic images or for images containing fine lines or inscriptions (which are in the image itself, and not in an overlay). This is because JPEG-compressed images do not reproduce abrupt gray value transitions satisfactorily. In fact, false-color images cannot be directly JPEG compressed. This is why OV100 will transform false-color images into (3x8) bit true-color RGB images before saving along with JPEG compression. If there is an overlay, it will be burned automatically before conversion.

Options. Pressing the Options button, the Save Image Options dialog will open. Here you can define the options for saving the image as JPEG format. The file size of the image file generated is inversely proportional to image quality. If you’re dealing with realistic images and you enter a quality value of 85% – you won’t be able to distinguish the compressed image from the original onscreen. At 75%, there is minimal deviation; at less than 50% you’ll be able to see the loss in quality. You’ll notice this loss in quality at higher values when working with synthetic images. The image quality set should in the main depend on the properties of the available output device. Say you print out a gray-value image on a 600-dpi printer at a 10 cm width – even at a quality
value of 25; you will hardly be able to distinguish the compressed image print out from a print out of the original. But keep in mind the effects compression has on various image processing functions.

**Warning.** Try to avoid compression in general. Compression always results in image artifacts. Images should only be compressed once you’ve finished analyzing them.

**Sheet format**

Decide which file format the system will offer by default for your use when you save. This format is a pre-set file type – i.e., you are free to alter the actual format of a sheet anytime you like. To make an alteration select the desired file format in the Files of type list in the **File > Save As…** dialog box. The above-mentioned pre-set format in this tab is only relevant for new sheets – i.e., those sheets for which there is as yet no existing file. These pre-sets will only be relevant for the ‘file-less sheets’ if you’ve cleared the Keep file type in file input/output dialogs check box in the General group.

**When to use which sheet format?** The standard format must be used if you later wish to be able to read in and continue work on sheet data in OV100. Use other formats if you wish to export data into other application programs.

**Standard.** Select the Standard option to save sheets using the OV100 sheet format whose file name extension is SFS. Any sheets you later wish to load and continue work on in OV100 must be saved using this format.

**Microsoft Excel.** Select the Microsoft Excel option to save sheets in the XLS file format. These sheets can be loaded into and further processed in the MS Excel sheet calculation program. OV100 is not able to read this file format.

**Lotus123.** Select the Lotus123 option to save sheets in the WK3 file format. These sheets can be loaded into and further processed in the Lotus123 sheet calculation program. OV100 is not able to read this file format.

**Text.** Select the Text option to save sheets in the TXT format. Sheets will be saved as text. Semicolons will separate data within individual columns from one another. Each text line represents a sheet row. This text file can be read by any text editor or word-processing program. The advantage here is that sheet data can then be read into many other application programs. This file will be opened as a text document in OV100 – not as a sheet document.

**Replace blanks.** Select the Replace blanks check box to automatically have all spaces replaced with an underscore symbol ("_") when saving sheet data in the TXT format. This check box is for making the reading of sheet data from text files in other application programs much easier: When reading in strings, it’s generally easier to deal with underscores than with spaces.

**Use Windows regional settings.** If this box is checked the **Decimal symbol** and the **List separator** will be used as corresponds to the regional settings of the operating system of your computer. If you deactivate this option you may choose between dot and comma for the **Decimal symbol** and between comma and semicolon for **List separator**.
Certain programs may not read your data properly if you choose not to use the regional settings.

General

Save configuration on exit without confirmation. A configuration file contains the structure and content of menus and button bars, as well as the assignment of accelerator combinations (key code short-cuts). Select the Save configuration on exit without confirmation check box to have any user-defined OV100 configuration saved automatically upon shut down. A configuration will only be saved if you’ve made alterations to it. The current configuration will be saved in the corresponding configuration file, thus overwriting the previous version of the configuration. Clear this check box to receive a query message each time you’ve made alterations to a user-defined configuration and shut down OV100. You’ll be asked whether you wish to save the current configuration. Selecting Yes will open up the Save Configuration dialog box. This dialog box is structured like the standard Windows dialog box for saving files. The file type at the top of the list is the one for configuration files: *.scy. Now you can create a new configuration file or overwrite an existing configuration file.

It’s a good idea to clear this check box to ensure that you do not unintentionally overwrite an existing configuration file.

Create backup when saving text files. Select the Create backup when saving text files check box to have a backup saved automatically when you save text files. This second file – the backup – contains the version of the text file as was last saved - not the current text file. This backup will be created when you overwrite the previous version of the text file. The first time you save a text no backup will be created.

What you’ll have is two files containing two different versions of a text document: the current version will be saved in the file format selected in the Files of type list of the File > Save As… dialog box – e.g., report.txt. The previous version will be saved in the so-called *.bak file format – e.g., report.bak.

Loading backups: bak files can be loaded in OV100. To do this, select the All (‘*’) entry from the Files of type list of the File > Open… dialog box. Now the bak files will be shown as well. They will not be shown via the Text Formats entry, however. Click on the Open button in this dialog box. The Load File dialog box will be opened. Click on Yes to open the bak file in a separate text document.

When do I need a backup? Primarily backups make sense for macros. You’ll still have the previous version of the macro if it turns out that the new version is causing you problems - such as crashes, for example.

Keep file type in file input/output dialogs. Select this check box to have the file type you last used offered to you the next time you save or open a file. This check box affects the standard Windows dialog box for opening and saving files (in the File menu). Keep in mind that the file type offered to you will depend on the document you wish to save or open.

Examples. If you have saved, for example, your latest new sheet document in the xls format – the next time you wish to save a new sheet, the xls format will be offered to you. Say that the last
time you opened a text document you used the All (*.*) format – the next time you wish to open a
text document you’ll be shown all files of the currently-set directory.
Preselect file type 'All Formats' in Open dialog. If this box is checked all files of all formats will
be shown in the File Open… dialog. Otherwise only the files of the most recently chosen
format will be shown.
Number of entries in recent file list. Here you can select how many of the recently used files
are displayed in the file list within the File and Archiving menu.

13.5.4 The Preferences Measure Tab

The settings in this tab are mainly concerned with interactive measurement functions of the
Measurements toolbar.

General
Continuous Measurement. If this option is not marked the selected measurement tool
becomes disabled after each measurement and has to be selected anew for another
measurement. Otherwise several measurements of the same time can be executed one after the
other and the function has to be terminated with the <Esc> key.

Use inverted Y axis. Conventionally in imaging the origin of the X/Y coordinate system is the
upper left corner. Mark this option to set the origin to the bottom left corner with rising Y axis.

13.5.4.1 Show labels / Label font

None. If this option is chosen, measurement objects such as lines and 'x's will not be labeled in
the overlay.
Numbering. If selected, individual measurements conducted within a series of measurements
will be numerated in the overlay. When you select this check box the Measurement results
option will be cleared – you cannot display numbers and measurements simultaneously in the overlay.

**Measurement results.** Select this option to label each object being measured with the measurement result and the relevant unit of measurement.

**Decimal places.** Here you determine how many decimal places will be displayed. This field is only active if the **Measurement results** option is selected.

**Zoom text with image.** Mark this option if the label text shall be zoomed together with the image.

**Label style**

> These settings do not affect the colors of ROIs.

**Use alternating colors.** Select this check box to have different colors automatically assigned to different measurement objects or series of measurements. This color appears in visualization of interactive measurements, and in the corresponding labeling and sheet entries. Colors will be assigned cyclically to the various measurements - their sequence is red, green, yellow, blue, magenta, cyan and then back to red. This sequence is preset. After finishing a measurement (series) and then beginning another, color assignment will start with red again.

**Inactive Color** and **Active Color.** If the **Use alternating colors** colors check box is deselected, you can choose one of the 16 MSWindows colors to mark the currently active measurements objects in the overlays in one color of choice and the inactive measurement objects in another. Color selection applies to:

- Display of interactive measurement elements such as lines and ‘X’s.
- The corresponding labeling of measurement objects or series of measurements of objects being measured.
- Corresponding sheet entries.

**Background.** This sets the color of choice of the background underneath the labels of the overlay objects. Without such background they would easily be overlooked in non-gray scale images – depending on the color.

> This field is inactive when the option **Show labels / None** is selected.

**Magic Wand options**

See Chapter 9.3.1, **Magic Wand Options**, for details.
13.5.5 The Preferences ➔ Module Tab

The settings in this tab apply to users who wish to create their own macros or Imaging C modules for use in OV100.

**Modules**

**Auto save on build.** When selected, the text document is automatically saved – using the Run macro command – when you start up your macro. When compiling a C module using the Build Module command, or using the identical function Build in the Module Manager dialog box, all files used in the C module will automatically be saved. For this to happen, however, each of the component files must have been saved at least once already – in order for files to be saved automatically they must have an existing file name or path name. A source text does not necessarily have to be saved to run a macro - however, this is obligatory for running a C module.

![Preferences dialog box](image)

Background: When a C module is created, only the text documents that have already been saved will be compiled. Thus to avoid problems, we recommend you generally to select this check box.

The header of the active text document indicates whether that document has been saved or not. If you’ve made alterations to the active text document and these have not yet been saved, an asterisk [*] will appear next to the name of the document.

**Reload on startup.** Select this option to have all C modules – that were loaded when you shut down OV100 – reloaded when you start OV100 again.

**Debug mode.** Having selected the Debug mode, you can use the Assert and Verify Imaging C functions for the development of your own Imaging C modules. Both functions can be used for tracking down errors in Imaging C modules.

**Maximum number of modules.** Enter the maximum number of C modules you wish to have loaded simultaneously. The standard value here is 20. You should only increase this number if
you really need all those modules – in order not to occupy more system capacity than necessary.

**Language version.** When programming, C modules function names will be shown in either English or German – depending on which language you’ve selected in the Language list. This setting also determines what language is to be used by the macro recorder for recording menu functions.

**Command window**

**Activate on output.** C modules and macros are able to write results into the command window. Select this option to have the command window opened automatically, or placed in the foreground (if it was already open). When working with macros, keep in mind that due to an output, for example, using the ? operator, or the `printf` function, the active document will lose its ‘active’ status - the command window will be activated in correlation with this check box. A macro that refers to an active sheet document, for example, will locate the command window instead and thus can no longer continue working correctly.

**Display string pointer values.** Tick mark this option to have not only strings displayed at output in the command window, but the corresponding address as well.

**Example.** Select the check box. Enter the following two lines into a text document; run the sample macro by pressing <F5>.

```c
char szInfo[20] = "Example";
? szInfo;
```

The following line will be output in the command window:

```
0x59b7:0x000c -> Example
```

This check box is not selected in the standard setting of the program - strings are used frequently and having addresses included all the time makes them more difficult to read.

**Macro recorder**

**Named arguments.** Select this option to record the argument names together with the invoked functions with the macro recorder.

**Image buffer arguments.** Tick-mark this check box to have the macro recorder record the index of image buffers involved (absolute image-buffer address). If the check box is deselected, the recorded functions will refer to the current values for the source and destination image buffers (relative image buffer address). In this case the macro recorder will record every interactive image buffer selection (i.e. every click within the Image Manager).

**Issue error message for invalid pointers.** When this option is selected and you use a pointer variable, you will get an error message in case the value it contains is not valid.
13.5.6 The Preferences › Graph Tab

The settings on this tab apply to the handling of graphs.

Overview

- You can adjust the number of available graph buffers in the image manager.
- You can determine whether the graphs are displayed in the list view.
- You can select whether you want to receive a query message when you delete or copy graphs from the graph buffer via drag & drop.

Graph functions

Available graph buffers. Enter the desired number of graph buffers to be available in the graph buffer box of the Image Manager. You can select values between 12 and 100 graph buffers. Any change in the number of image buffers only becomes effective after a OV100 restart.

Display as list view. This check box is not activated by default and the graph buffer box appears like the Gallery buffer box with graph thumbnails. If you activate this check box the graph buffer box will look similar to the images list buffer box without thumbnails.

Drag & drop in the Graph Manager

Confirm delete, copy. Decide whether you wish or not to receive a query message when you copy or delete graphs in the graph manager. These queries apply only to the dragging & dropping of graphs. You will not receive a query when using the Edit › Copy command.

Background pattern. When activated, the graph window and the graph thumbnails in the graph buffer box of the Image Manager will have a background pattern of diagonal stripes.
13.5.7 The Preferences › Database Tab

Use this tab to define presets for a database you wish to create. See also Chapter 12.1, *Directories for Data Storage*.

**Overview.**

On this tab you can decide

- the current size of the thumbnail display for all database documents, and
- the preferences for new databases. These settings comprise actual thumbnail size, the standard image format, maximum size of image drive or directory, compression method and the paths for system files and images.

To adjust the actual **Thumbnail display size** you can select between the predefined sizes **Small**, **Medium**, and **Large** from the pull down list.

**Database defaults**

You can set the preferences for new databases.

**Thumbnail creation size.** You can adjust the size of newly created thumbnails from the pull down list to **Small**, **Medium**, and **Large**.

In the **Save images** field you can preselect from the pull down list the **File type** for saving images acquired in the database. Selecting **Force TIF type for documents**, inserts images as documents with the TIF format. The read only information **Compression** indicates if and which compression method you have selected. The **Options...** button has the same function as the one on the File tab (for details see Chapter 13.5.3.1, *Save image files*).
We recommend you to use the TIF format as default for the reasons already described in Chapter 13.5.3, *The File Tab*.

In the **Location** field you can determine the pathname for the **Database files** and the **Temporary storage directory**, as well as the **Backup volume capacity**.

## 13.6 Window

<table>
<thead>
<tr>
<th>Window</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cascade</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Tile Vertical</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Tile Horizontal</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Minimize All</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Arrange Icons</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Close All</strong></td>
<td>GH+D</td>
</tr>
<tr>
<td><strong>Document Manager...</strong></td>
<td>Alt+3</td>
</tr>
<tr>
<td><strong>Full Screen</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Viewport Manager</strong></td>
<td>Alt+1</td>
</tr>
<tr>
<td><strong>Image Manager</strong></td>
<td>Alt+2</td>
</tr>
<tr>
<td><strong>Status Bar</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Command Window</strong></td>
<td>Alt+F2</td>
</tr>
</tbody>
</table>

### 13.6.1 Minimize All

Use this command to minimize all open documents and arrange the document icons.

**What will happen...** Document icons will be aligned along the lower edge of the documents area. Using this command can help you keep track of all the documents you’re working with. This command is for text, sheet, diagram and database documents as well as for the Image Document.
13.6.2 Close All

Use this command or the short cut \texttt{<Ctrl+d>} to close all (open) documents.

This command is for text and sheet documents. It does not affect Image or Graph Documents, or any images within the image buffer box. Database documents will not be affected either.

13.6.3 Document Manager...

Use this command to open the Document Manager dialog window. This is helpful in case your workspace contains many open and/or minimized windows.

As an alternative, you can open this dialog window using the short cut \texttt{<Alt+3>}.

\begin{itemize}
  \item \textbf{Activate}. This button activates the window selected in the Document/Name list. The same command can be executed with a double-click on the window.
  \item \textbf{Minimize, Maximize, Restore, Close}. These buttons represent standard Windows commands and can be executed on the presently active documents, with the exception that the Image and Graph documents cannot be closed.
\end{itemize}
Cascade

**Cascade.** Use this button to have all selected text, sheet, diagram and database documents arranged – staggered – one atop the other.

**What will happen...** The order in which the documents are arranged will depend on which one was most recently active. The currently active document will be the one displayed in front. Title lines containing the names of all documents will remain visible – so that you can easily activate any of them – they will then appear in the foreground.

Tile Horizontal

**Tile Horizontal.** Use this button to have all open text, sheet, diagram and database documents arranged horizontally, and above and below each other.

**What will happen...** All open documents will be displayed at the same level and in the same size, using up the whole documents area. Document windows will be enlarged or reduced as needed. If up to three documents are selected they will be displayed one above the other. With four and more, they’ll be arranged in rows and columns – so that windows will tend to be rather squatty and broad. Title lines containing the documents’ names will remain visible – you can thus easily activate any of the open documents.

Tile Vertical

**Tile Vertical.** Use this button to have all open text, sheet, diagram and database documents arranged vertically, next to each other.

**What will happen...** All open documents will be displayed at the same level and in the same size, using up the whole documents area. Document windows will be enlarged or reduced as needed. If up to three documents are selected they will be displayed next to each other. With four and more, they will be arranged in columns and rows – so that windows will tend to be rather long and narrow. Title lines containing the documents’ names will remain visible – you can thus easily activate any of the open documents.

Close All

**Close All.** Use this button to close all Text and Sheet documents. It does not affect Image and Graph documents, or any images within the image buffer box.
13.6.4 Viewport Manager

Use this command to turn the Viewport Manager On or Off. You may also use the short cut <Alt + 1>.

What is the Viewport Manager? The Viewport Manager also displays the image of the active Viewport. Additionally, the Viewport Manager is surrounded by a red rectangle. The size and position of this rectangle can by changed using the left mouse button. The area within this rectangle is displayed in the Viewport. Thus you can use this rectangle to zoom into an area of interest.

Application. You can turn off both Viewport Manager and Image Manager to temporarily enlarge the documents area. This will give you, e.g., more space for displaying images within the Image Document.

What will happen... A tick will appear next to this command when the Viewport Manager is 'on'.

13.6.5 Image Manager

Use this command to turn the Image Manager On or Off. You may also use the short cut <Alt + 2>.

What is the Image Manager? The Image Manager contains the Operands Box with the source and destination image buffers and the image buffer box with the List, Gallery and Graph views.

Application. You can turn off both Viewport Manager and Image Manager to temporarily enlarge the documents area. This will give you, e.g., more space for displaying images within the Image Document.

What will happen... A tick will appear next to this command when the Image Manager is On.

13.6.6 Status Bar

Use this command to turn the Status Bar On or Off.

What is the Status Bar? The Status Bar is usually displayed at the bottom of the Graphical User Interface (GUI). Among other things it displays a brief description of each OV100 command, the name of the active input and position and size of the frame.

What will happen... A tick will appear next to this command when the Status Bar is On.
13.6.7 Command Window

Use this command to open the Command text window – or to activate it. You may also simply use the short-cut <Alt+F2>.

**Application.** This command will open a text window for writing Imaging C and Macro functions. Subsequently, these functions can be executed directly. Furthermore the window can be used as a calculator. Simply preface any mathematical task with a question mark. The result will appear in the next line of the Command Window.

**Example.** Entering \(5\log(43.5)+100;\) will yield the result 118.863804690473.

**Editing Command Lines, Executing Function.** A 'greater than' (>) sign at the left border indicates the beginning of a command line. You can only edit the last current command line. Any lines preceding this last one can no longer be edited. Anything you’ve got in the clipboard can also only be pasted into the last current command line. Command lines are ended with a semicolon. Press Enter to have the function of the current line executed. OV100 will execute that function immediately. The result(s) of any calculation will then be written in the next line of the Command Window. You will receive an error message, e.g., if you have made a syntax error writing the Imaging C function, if the function has too few parameters, or if the semicolon is missing at the end.

**Pasting Preceding Command Lines.** Preceding command lines can be neither edited nor executed, but they can be pasted into the current line (for editing and execution). This can be useful, e.g. if you’ve received an error message and you would like to make a correction. Simply position the cursor at the relevant preceding command line. This line will be then selected in its entirety. Then press Enter to have this line pasted into the current command line. After editing the incorrect entry, you can re-execute the function.

**Saving Command Lines.** In contrast to other document windows, the contents of the Command Window cannot be saved using the Save As command. However, you can circumvent this problem, therefore, open a new standard text document and simply paste the desired command lines via the clipboard into this text document. The text document can now be saved using the Save As command.

---

You can determine whether the Command Window is to be automatically activated by an Imaging C output. Select Special > Preferences... or press <F8>. In the displayed dialog box select the Module tab, and mark Activate on output in the Command window field. This ensures that no output goes unnoticed – e.g., because another document is covering it up. On the other hand, some Macros or C Modules use the active sheet document for their calculations. If the Command Window is activated by an output, this can interfere with the running of your program – because instead of a sheet document being active, a text document is actually active. In this case, it’s sensible to turn this automatic activation off.
14 Imaging C

OV100 has its own macro or programming language: Imaging C. It is a variation of the ANSI C standard, which has been expanded by a number of functions.

Why program in Imaging C?
Imaging C offers the possibility of automating processes you use over and over as well as expanding OV100 by adding new image processing functions. You can program your own macros using the integrated Imaging C Interpreter. This allows you to adapt image-processing functions to your particular application needs. If you are experienced in using modern programming languages, especially Standard C, programming with Imaging C will not cause you any difficulties. This way OV100 can serve as a development platform for developing problem-oriented application(s). The new macros can be integrated into the graphical user interface and used just like any of the other functions in OV100.

Definition
The Special ➤ Imaging C menu contains commands for the administration of Imaging C modules. A C module provides one or more C module functions. C modules are written using the macro language Imaging C, translated so that the computer is able to understand it, and stored as files executable by OV100 (extension SXU). C module functions enhance the functionality of OV100 and are seamlessly integrated into the user interface. It is not necessary to learn Imaging C if you want to profit from C modules. There are a large number of ready-made C modules, which can be integrated into OV100 without your having to know they are in fact C module functions and not internal functions.

A C module consists of one or more files. The files are compiled, which means that they are processed in such a way that an executable C module (SXU) is created. Before generating this executable C module a Make-File (MKU) is necessary. A make file contains – among other things – a list of the files comprising the C module.

The following file types are part of a C module:
### File types

<table>
<thead>
<tr>
<th>File name extensions</th>
<th>meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>sfm, c</td>
<td>source code</td>
</tr>
<tr>
<td>sft, h</td>
<td>header (definition of variables and constants)</td>
</tr>
<tr>
<td>rc, dlg</td>
<td>resource (definition of dialog boxes)</td>
</tr>
<tr>
<td>mku</td>
<td>make file</td>
</tr>
<tr>
<td>sxu</td>
<td>executable file</td>
</tr>
<tr>
<td>scx</td>
<td>module configuration</td>
</tr>
</tbody>
</table>

**Definition.** Imaging C expressions will always be compiled automatically in the Interpreter Mode when the expression is executed. OV100 makes use of this mode in the following situations:

- when an expression is executed from the command window,
- when you use the macro commands Define Macro and Run Macro (in the Special menu).

### 14.1 New Module...

Use **Special ▶ Imaging C ▶ New Module...** to create a new C module.

**What will happen...** The **New Module...** command lightens your workload when you wish to generate a new directory, then set up a source file (SFM) there and then have this file integrated into a make file (MKU). The text of the source file (SFM) will be opened in its own text window within the Graphical User Interface (GUI). The new module will automatically be compiled into an executable file (SXU), then loaded and made into an active module.

**What’s it for?** The **New Module** dialog box is where you determine which key segments of the new module source text are to be ‘givens’:

- the "Main" function,
- the "Exit" function,
- one of various MAPI 'Sample’ functions with varying properties (MAPI functions are the only ones that can be used as menu commands).
The various settings available in the **New Module** dialog box generate different source texts. We recommend that you should try using these source texts when you first try programming a C module – these can serve as examples.

Adding source files to a new module
If the Create sub-directory check box is the only check box that has been selected, the **Edit Module** dialog box will be opened. Here is where you can have files added to a C module. This allows you to integrate existing source and definition files into a new C module.

Create sub directory, Current directory
When you have selected the **Create sub directory** check box, a sub-directory of the current directory will be created using the module's name. You will see the current directory name displayed in the **Current directory** field.

Directory...
The **Directory...** button is for opening a standard Windows dialog box where you can select another current directory. In addition you can create a new directory or delete one you no longer need.

"Main" Function
If you have selected the "Main" Function check box, the new C module will contain an initialization function of this same name. The **Main** function of a C module is used when loading the C module. If this function returns a value of -1, the loading procedure will be interrupted and the C module closed. In general however, **Main** is used for the correct initialization of a C module. If an initialization of the C module is not necessary you can skip this function – i.e., the function does not even have to be present.

**Example**

**Imaging C Code**

```c
int Main ()
{
  return (TRUE);
}
```
**"Exit" Function**

If you have selected the "Exit" Function check box, the new C module will contain a de-initialization function of this same name. The Exit function of a C module is used when a C module is exited. If a de-initialization of the C module is not necessary, you can skip this function – i.e., the function does not even have to be present.

**Example**

**Imaging C Code**

```c
int Exit ()
{
  return (TRUE);
}
```

**MAPI "Sample" Function**

If you have selected the MAPI "Sample" Function check box, the new C module will contain a MAPI function of the same name – i.e., Sample function. Various functions can be defined within a C module. It is only the MAPI functions however that can be used as menu commands or inserted into a button bar. You can assign the description of the MAPI function (which will appear in the status bar when the function is selected) to the respective function description string. The first thing you enter into a MAPI function’s Function description is the MAPI constant. This function description is located between the ‘head’ and ‘foot’ of a function. It is enclosed by the following symbols: ‘<’ and ‘>’:

**Example**

**Imaging C Code**

```c
export UINT SampleFunction ()
{
  <MAPI, IDM_SAMPLE, "Info in status bar", "Sample &function">
  {
    dlgOutput("Hello World");
    return IDOK;
  }
}
```

**Available**

The check boxes beneath the MAPI “Sample” Function check box are only available when the MAPI “Sample” Function check box has been selected.

**"OnInitMenu" function**

If you’ve selected the "OnInitMenu" function check box, the new C module will contain a function of this same name. The OnInitMenu function of a C module is used when the program needs to know whether a certain MAPI function is valid or not. This is important for MAPI functions that have been integrated into a menu. If OnInitMenu gives you MENU_DISABLE concerning this MAPI function, the corresponding command is not available (will appear gray).
Example
Imaging C Code

```c
WORD OnInitMenu (WORD wMenuID)
{
    switch (wMenuID)
    {
        case IDM_SAMPLE:
            return (MENU_ENABLE);
        }
    return (MENU_ENABLE);
}
```

**Additional Constants**
To make the availability of MAPI functions controllable using the OnInitMenu you’ll need to put the constant MAPI_IDLECHECK at the 5th position within the definition instruction of the MAPI function:

**Example**
Imaging C Code

```c
export UINT SampleFunction ()
    <MAPI, IDM_SAMPLE, "Info in status bar", "Sample &Function",
MAPI_IDLECHECK>
```

**Auto configuration**
If you have selected the Auto configuration check box, the new C module will contain a source file (having the file name extension SFM) as well as a C-module configuration file SCX. This configuration file contains the definition for a button bar of the same name as the module as well as containing the ‘T’ button. The MAPI function Sample function can be activated by clicking on this button. When the new C module is closed the button bar will automatically vanish. It will reappear at its previous location when the C-Module is loaded once again.

> If you desire to change the name of the MAPI function `SampleFunction` after the C module has been generated, be sure not to forget to change the assignment of the `SampleFunction`’s ‘T’ button as well.

**String Table**
Select the String table check box if you wish the new C module to support different languages. In this case, the source text will contain the @-Operator instead of strings, and followed by a constant, eg, @IDM_SAMPLE in place of “Info in the status bar”.

**Example**
Imaging C Code

```c
export UINT SampleFunction ()
    <MAPI, IDM_SAMPLE, @IDM_SAMPLE, @(IDM_SAMPLE+1)>
```
{
    dlgOutput( @IDS_MESSAGE);
    return IDOK;
}

Dialog box Function
Screen shot Sample Dialog
Select the Dialog box function check box if you wish to have a look at sample programming of a dialog box using Imaging C. What will happen is that a sample dialog box will be created, when you activate SampleFunction.

Example
Imaging C Code

#define IDD_BEEP 100
#define IDD_CHECKBOX 101
#define IDD_EDIT 102
MYDIALOG DIALOG 130, 72, 186, 76
STYLE DS_MODALFRAME | WS_POPUP | WS_VISIBLE | WS_CAPTION | WS_SYSMENU
CAPTION "Sample Dialog"
FONT 8, "MS Sans Serif"
BEGIN
DEFPUSHBUTTON "OK", IDOK, 133, 12, 48, 14
PUSHBUTTON "Cancel", IDCANCEL, 133, 30, 48,14
PUSHBUTTON "&Beep", IDD_BEEP, 133, 50, 48, 14
TTEXT "&Edit- Control:", -1, 6, 20, 51, 8
EDITTEXT IDD_EDIT,60,18,54,12,ES_AUTOHSCROLL
CONTROL "&Checkbox-Control", IDD_CHECKBOX,
    "Button",BS_AUTOCHECKBOX,WS_TABSTOP,10,41,71,10
END
/**"Callback" function of the dialog box*/
BOOL SampleDlgProc (HWND hDlg, UINT uMsg, WPARAM wParam, LPARAM lParam)
{
    BOOL bEnable;
    switch (uMsg)
    {
    case WM_INITDIALOG:
        dlgCenter (hDlg);
        CheckDlgButton (hDlg, IDD_CHECKBOX, bCheck);
        SetDlgItemText (hDlg, IDD_EDIT, szText);
        EnableDlgItem (hDlg, IDD_BEEP, bCheck);
        break;
    case WM_COMMAND:
        switch (LOWORD (wParam))
        {
        case IDD_BEEP:
            MessageBeep (MB_ICONQUESTION);
            break;
...
case IDD_CHECKBOX:
    bEnable = IsDlgButtonChecked (hDlg, IDD_CHECKBOX);
    EnableDlgItem (hDlg, IDD_BEEP, bEnable);
    break;

case IDOK:
    bCheck = IsDlgButtonChecked (hDlg, IDD_CHECKBOX);
    GetDlgItemText (hDlg, IDD_EDIT, szText, sizeof (szText));
    break;

case IDCANCEL:
    EndDialog (hDlg, LOWORD (wParam));
    default:
        return FALSE;
    break;

default:
    return FALSE;

} // switch wParam

// switch uMsg
return TRUE;

}| 

If you’ve set the language to German – before initiating the Module New... command – all comments of the source file of the new C module will be in German. Language is selected in Preferences, in the Module tab (in the Special menu.)

OK. Click on the OK button in the New Module dialog box to open a text document containing the source code of the text.

How to assign a new MAPI function to the 'T' button:
You have generated a new Imaging C module called "New" using the New Module... command. You have selected the Auto configuration check box in the dialog box. This means that there is a new button bar containing the "T" button – the SampleFunction can be initiated via this button. Within the source text of the module you have defined a new function called "An_other".

1. To compile the new C-module use the Build Module (<F7>) command.

2. Select the Edit Button Bars... command (in the Special menu).

3. Select the module name in the Button Bars list. Then click on the Edit... button.

4. Select the "New" C module from the Command groups list. Commands list will now contain the SampleFunction entry as well as the name of the new function called "An_other".

5. Select the "T" button in the New Button field.

7. Click on the **Modify** button.

8. Once you click on **OK** the T button will be connected to the name of the new function.

9. Use the **Save Module Configuration** command to save this altered module configuration.
   Using this command will result in the previous module configuration being overwritten.

10. Use the **Build Module** (**F7**) command to now compile the C module again.
    When you do this, any alterations made in the C-module configuration file SCX will be included in the actual SXU of the C module.

```c
/* 26.07.2003

#define IDM_SAMPLE (IDM_USER + 1)

/******************************************************************************
 COMMENTS:
 The Add-In manager browse for this function to display a long and a short description of this module.
*******************************************************************************/

void ModuleComment ()
{
    Version: "1.0.100"
    Copyright: "C 25.07.2003"
    Description: "Sample MAPI function"
    "Imaging C Module 'Example'
)}

/******************************************************************************
 Created: Sample MAPI function
 Changed: Sample MAPI function
*******************************************************************************/

export UINT SampleFunction ()
{    MAPI, IDM_SAMPLE, "Info in status bar", "Sample &function"
    dispOutput("Hello World");
    return IDOK;
}

```

If you change the function description of a MAPI function, the configuration file does not have to be adapted accordingly. All you need to do is have the C module re-compiled using the **Build Module** (**F7**) command.
14.2 Open Module...

Use Special ▶ Imaging C ▶ Open Module... to load and activate a C module.

**Application.** The standard Windows dialog box for opening and saving files will be opened. Select the path of the module desired in this dialog box. You can use either the MKU make file or the SXU executable file to load and activate the module.

**You may also** use the Module Manager command to load and/or activate a module.

**Definition**

The reason you load a module is so that its functions are available to you in OV100.

**Which modules do I have loaded?** The modules you’ve already loaded are listed in the **Loaded** list in the Module Manager.

**What will happen...** The module will be included in the **Loaded** list in the Module Manager. All global and static variables of the C module will be initiated as well as the C module’s main function. If this function results in a value of -1, the loading of the C module will be stopped. The C module will be closed.

**Definition.** To be able to apply the following menu commands to the module, activate the module: (the commands are) Edit Module..., Save Module Configuration, Add to Module, Build Module, Close Module and Module Info.

**Which module is the active one?** Although several C modules can be loaded at the same time, only one can be active. To check which one is currently active, have a look in the Active field of the module manager or use the Module Info... command.

**What will happen...** The Open Module command will deactivate the C module that had been active and will close it. This means that the previously active module is no longer loaded. The module will be withdrawn from the **Loaded** list in the Module Manager and placed in the Other list.

If you use the Open button of the Module Manager however, the currently active module will not be closed – it will simply be deactivated.

**Activating a module without having to load.** A module can be activated without actually having to load it. To do this, simply use the **<Ctrl+Shift>** keys while clicking on the Open button in the Open Module dialog box.
The Module Formats file format is preset. This list contains the formats of the make files (MKU) and of the executable files (SXU).

Adding module to module search path. If you've selected the Add module to module search path check box, the directory name of the module will be added to the directories used for the administration of the module manager. We recommend selecting this check box if you're working with a particular module frequently.

Info... Click on the Info... button to view information on creation date, which version and a brief description of the module. The Module Info dialog box will be opened.

14.3 Add to Module

Use Special ▶ Imaging C ▶ Add to Module... to add the active text document to the active module.

Available. This command is only available...

- when a C module is active,
- if there is a MKU make file for this module, and if
- a text document is open and active.

Before you use this command. Activate the module in question in the module manager. Then you can check and see whether the module has a MKU make file using the Open... button in the Open Module dialog box. Then activate the text document that you wish to add.
What's it for? This command is for adding a text document to the active module – e.g., another source text.

What will happen... If the document has already been saved as a file, the file will be inserted into the list of C module files. If not, the **Save Text as** dialog box will be opened where you can enter a name for the file. If the file is already in a module, a message informing you of this will be displayed.

### 14.4 Save Module Configuration

Use **Special ▶ Imaging C ▶ Save Module Configuration** to save the current configuration of the Graphical User Interface (GUI) in the active C module.

**Available.** This command is only available...
- when a C module is active,
- if there is a MKU make file for this module, and if
- the current configuration contains a MAPI function of the active module.

**Before you use this command** activate the module in question in the module manager. Then you can check and see whether the module has a MKU make file using the Open... button in the Open Module dialog box.

**Configuration file.** The configuration of the Graphical User Interface (GUI) will be saved in the SCX configuration file of the C module.

**Save Shared Configuration.** Keep the `<Shift>` key depressed while you call up the menu. This command will then turn into the Save Shared Configuration command. The information on which MAPI functions of other modules will be included in the current Graphical User Interface (GUI) configuration will be saved in the SCX file of the active C module. This will result in commands and buttons of the active module being arranged in the correct order with regard to the commands and buttons of the other modules. This is relevant for example if you have two modules sharing the same button bar.

**Definition.** The term Configuration refers to the appearance and functions contained in the Graphical User Interface (GUI):
- menus and menu commands,
- button bars and buttons contained therein,
- key functions of the keyboard,
- macros and
- external programs.

On the other hand, the configuration does not contain the settings of the Viewport Manager or the Image Manager. Individual dialog box settings and which modules are currently loaded are not part of the configuration.
**What's it for?** Use the command Save Module Configuration: to assign a configuration to the current module, or to replace the module configuration with the current configuration – if a configuration has already been assigned.

**Loading a C module.** When loading a module, the MAPI module functions contained by the module configuration will be added to the current configuration. The C-module will have to be recompiled in order for the alterations to the module configuration to be considered when you load the C module.

Just as with all other alterations made on C module files, you will have to recompile the C module so that these alterations will be considered when you load the C module.

**Closing a C module.** When you close a C module all functions of the C module contained by the current configuration will be removed. This will happen if you have not cleared the On close remove module functions from configuration check box - in the Module Info dialog box.

### 14.5 Edit Module...

Use Special ▶ Imaging C ▶ Edit Module... to define the make file of the active C module.
Available. This command is only available when...

- a C module is active and if
- there is a MKU make file for this module.

Before you use this command activate the module in question in the module manager. Then you can check and see whether the module has a MKU make file using the Open... button in the Open Module dialog box.

What's it for? This dialog box is for adding or subtracting files to the list of C module files. You can also load files from the module list into the text editor.

Files of type, Add, Header files, Source files, Up, and Down. To add a file to the C module, first select the file type (located in the Files of Type list) to appear in the Look in field. Select the file to be added to the module from the file list and then click on the Add button – or simply double-click on the file in the file list. If the file has a file name extension of SFT, H or DLG it is considered a source file and will thus be appended to the Header files list. If the file has another file name extension, it will be treated as a function source file and thus appended to the Source files list. If the list position of the appended file is to be changed, you can adjust it using the Up and Down buttons.

Remove. To remove a file from the module, select that file and click on the Remove button. In this case, Remove simply refers to the file being removed from the list. The file has not been deleted from the disk.

Edit. To edit a module file select that file from either the Header files field or from the Source files field and then press the Edit button. Or - you can simply double-click on the file in the list.

14.6 Build Module

Use this command to compile the active module.

Available. This command is only available when...

- a C module is active and if
- there is a MKU make file for this module.

You may also press the <F7> key.

Before you use this command activate the module in question in the module manager. Then you can check and see whether the module has a MKU make file using the Open... button in the Open Module dialog box.

What will happen... All files of the active module will be compiled. After the build process has been completed without errors, an executable file will be stored on the hard disk with the same
base name as the modules make file and with the extension SXU. It will be stored in the same
directory as the make file (MKU) of the module. If no errors are reported, the build has been
successful. All functions, constants, types, and variables that are exported from the module can
now be tested from the **Command Window** or can be included in a configuration, e.g., in the
button bar.

**Canceling compiling.** To interrupt compilation, use the `<Ctrl+c>` keys.

### 14.7 Close Module

Use this command to close the active C module.

**Available.** This command is only available, if a C module is active.

**Before you use this command** activate the module in the module manager.

**What will happen...** If the module contains an **Exit** function, it will be executed. Values of all
variables will be reset. MAPI functions will be removed from menus and button bars. These
functions can then no longer be executed via the command window.

**Effect on other modules.** Data and functions of other modules remain unaffected by this
command.

**Reloading modules.** To reload the module, use the **Open Module...** command or the Module
Manager.

### 14.8 About Module

Use this command to view information on the active C module. Further, you can set whether
module functions are to be removed from the Graphical User Interface (GUI) configuration (or
not) when you close the module.

**Available.** The command is only available when a C module is active.

**Before you use this command** activate the module in the module manager.
On close remove module functions from configuration. This check box is only available if the C module contains a configuration (file SCX) and there is a MKU make file. Select this check box to have C module functions automatically removed from the Graphical User Interface (GUI) configuration when you close the C module.

Any alterations you made will only become effective once you've compiled the module.

14.9 Module Manager...

Use this command to manage C modules. You may also use the <Ctrl+Shift+F5> keys.

When do I use the Add-In Manager? The Module Manager command is for developers of Imaging C modules. If you wish to load finished C modules then use the Add-In Manager command (in the Special menu).

What's it for? Both dialog box lists show all C modules. All these modules can be either loaded or closed. Modules can be activated or deactivated. The following functions are available: Open
Module..., Build Module, Edit Module..., Add to Module, Module Info and Close Module. In addition, you can enter the names of directories containing modules to be included in the two lists in the Define search path for modules dialog box.

Dialog box description. This dialog box is non-modal - meaning that it can be kept open while you use other commands.

**Loaded.** All loaded modules are listed in the **Loaded** list. All functions of these modules are currently available to you. To load modules from the **Other** list, use the **Load** button. To load executable SXU module files, use the **Open...** button – or use the **Open Module...** command.

Most modules can also be loaded and closed in the **Add-In Manager.** Some modules will be automatically loaded: for example, when you load a configuration, use user-defined measurement or statistical parameters or activate an image import filter. These modules will be shown in the **Loaded** list, too.

**Other.** All modules fundamentally available to you for use are listed in the **Other** list - these modules are however closed. The functions of these modules are not available to you currently. To close modules, click on the **Close** button or use the **Close Module** command.

The following modules are displayed in the lists:

- the active module
- all loaded modules
- all modules whose directories you’ve selected - using the Directories... button - in the Define search path for modules dialog box
- all modules contained by the current configuration
- all modules registered in the Add-In Manager
- all user-defined modules (containing measurement and statistic parameters) registered in the Install Modules with Statistics Parameters or Install Modules with Measurement Parameters dialog boxes

**Remove.** Click on the **Remove** button to close the module selected. After clicking on this button, the functions of this module will no longer be available to you. This module will then be removed from the **Loaded** list and placed in the **Other** list – if the module is included in a search path or comes under one of the above list of criteria. This button is only available if you’ve selected a module from the **Loaded** list.

**Remove All.** Click on the **Remove All** button to close all modules. Module functions will not yet be available to you. All modules will then be removed from the **Loaded** list and placed in the **Other** list - if the module is included in a search path or comes under one of the above list of criteria.

**Load.** Click on the **Load** button to load the module you’ve selected. The module’s functions will be currently available. The module will be moved from the **Other** list into the **Loaded** list. This button is only available if you have selected a module in the **Other** list.
Directories... Click on the **Directories...** button to include more modules from other directories in the **Other** list. The Define search path for modules dialog box will be opened.

**Open...** Click on the **Open...** button to load a C module and activate it. The **Open Module** dialog box will be opened. Using the **Open...** button, however, the previously active C module will be only deactivated and not closed.

**Build.** Click on the **Build** button to compile the module selected. The button’s function corresponds to the Build Module... command. This button is only available if you have selected a module in either the Loaded or the Other lists. Furthermore, there has to be a MKU make file for this module. To interrupt compiling, simply use the `<Ctrl+c>` keys.

**Files...** Click on the **Files...** button to edit the module you’ve selected. The **Edit Module** dialog box will be opened. This button is only available if you have selected a module in either the Loaded or Other lists. Furthermore, there has to be a MKU make file for this module.

**Add File.** Click on the **Add File** button to add the active text document to the module selected. The **File** field indicates which text document is active. The text can comprise for example another source text, contain definitions and/or a description of module functions. This button is only available if you have selected a module in either the **Loaded** or **Other** lists. Furthermore, there has to be a MKU make file for this module. A text document has to be open and active in the Graphical User Interface (GUI).

**Module Info...** Click on the **Module Info...** button to view information on the module selected. The **Module Info** dialog box will be opened. This button is only available if you’ve selected a module in either the **Loaded** or the **Other** lists.

**Activate.** Click on the **Activate** button to activate the module selected. The previously active module will be deactivated. This button is only available if you’ve selected a module in either the **Loaded** or the **Other** lists.

**Deactivate.** Click on the **Deactivate** button to deactivate the active module. The Active field indicates which module is active. This module is the one you had either recently activated or opened - it does not necessarily have to have been selected in one of the two lists. After you deactivate a module, no C module will be currently active. This button is only active when a C module is active.

**Module.** The **Module** field indicates the path of the module currently selected in either the **Loaded** or the **Other** lists.

**File.** The **File** field indicates the path of the active text document. Using the **Add** button you can add this text document to the selected module.
**Active.** The *Active* field indicates the path of the active module. Only one module can be active at a time.

### 14.9.1 The Define Search Path for Modules Dialog Box

Use this dialog box to have other modules – from other directories – shown in the module manager.

**What’s it for?** This is where you set up a list of directories containing the C modules OV100 is to search for. The directory itself and all sub-directories will be searched. All modules will be shown in the *Other* list in the module manager. That’s where you can load, activate, edit and/or compile modules.

**Look in.** Select the directory you want included in the *Selected* directories list from the Look in list and field.

![Define search path for modules dialog box](image)

**Folder name.** The *Folder name* field shows the directory, meaning the complete path of the directory you have selected in the Look in field. You can keep the directory or enter another directory. The complete path of this directory can be added to the *Selected directories* list.

**Selected directories.** The *Selected* directories list contains the paths of all directories whose modules are shown in the module manager.

**Add.** Click on the *Add* button to add the path in the *Folder name* field to the Selected directories list.
Delete. Click on the Delete button to remove the selected directory from the Selected directories list.

14.10 Browser...

Use this command in the Special > Imaging C menu to obtain an overview of the symbols defined in Imaging C. You may also use the <Alt+F12> keys.

Definition. A Symbol can be a function, a structure, a union, an object, a variable, a dialog or a constant.

The Browser dialog box is non-modal – i.e., you can continue working with other commands without having to close this dialog box.

Query
The Query group is where you enter the symbol you’re looking for. Select the type of symbol you’re looking for from the Type list (e.g., 'Function', 'Internal Function', 'Object Function' etc). Enter the name of the symbol you’re looking for into the Symbol field. You can use wild cards (‘*’, ‘?’) here. Select where you are to find the desired symbol from the Range list (e.g., 'Exported by Loaded Modules'). This list will then disappear and replaced by the German function names check box - if you’ve selected the 'Internal Function' type of symbol.

Type. The Type list contains various types of symbols: 'Internal Function', 'Function', 'Structure Type', 'Union', 'Object Type', 'Variable', 'Dialog', 'Constant', and 'All'.

Symbol. Enter the name of the symbol you’re looking for into the Symbol field. If you only know a part of the symbol’s name you can substitute an asterisk '*' for unknown text and for unknown letters substitute a question mark '?'. Upper and lower case are not relevant when searching for a symbol.
**Range.** The **Range** list contains the following search ranges for symbols: 'Callable in Interpreter Mode', 'Exported by Tool', 'Exported by loaded modules', 'Exported by Active Module', 'Defined in Active Module', 'Defined in Interpreter Mode'. If you have selected the 'Internal Function' type of symbol the list will not appear. The 'Exported by Tool' range, for example, searches for predefined symbols.

**German function names.** This check box is only displayed if you have selected the 'Internal Function' symbol type. Select this check box if you wish to search for internal functions in German instead of in English.

**Result.** The Result field indicates the number of symbols found according to the settings of the Query group. This list contains the names of the symbol(s).

**Example**
The 'Internal Function' type and the '*' symbol will result in all internal menu functions.

**Description**
The **Description** group displays more detailed information on the symbols selected in the **Result** list.

**Edit.** The Edit button is only available if you've selected a symbol from the Result list - this symbol must have a source file. Click on this button to load the source file of the selected symbol in OV100. This file will be opened in a separate text document window. The cursor will appear right at the spot in the text where the symbol is defined - and - the name of the symbol will be selected.

**Copy & Paste.** The **Copy & Paste** button is only available if a symbol has been selected in the Result list. Click on this button to insert the name of the selected symbol into the active text document. This name will be written into the text where the cursor is at.
14.11 Find Symbol

Use this command to access the complete name of a symbol in the active text document.

**Available.** This command is available when a text document is open and active. You may also use the `<Ctrl+F12>` keys.

**What's it for?** This command is for use when you're programming in Imaging C and you don't know the precise name of a symbol – or the symbol's name is extremely long. What you would do in this case would be to, e.g., enter the first few letters of the symbol name you're looking for and then use the `<Ctrl+F12>` keys. A symbol name having these letters at its beginning will be written into the text document. If the symbol name written into your text is not the one you were looking for, use the above-mentioned keys once more (<Ctrl+F12>). Then, the next symbol name having these letters at its beginning will be written into the text document. If you still haven't found what you're looking for, simply continue to use the above-mentioned key combination - until you do find what you were seeking. You may want to try using other letters if you still cannot locate the desired symbol name.

**Where are symbol names searched for?** Firstly, symbols are searched for among the symbols defined in the interpreter mode. After that, the active C module will be searched. Lastly, the predefined symbols in the 'Exported by Tool' range are searched.

**Upper/Lower-case, Wild cards.** When making a search request upper or lower case is of no relevance. Any parts of a symbol's name you don't know can be substituted with an asterisk [*]; letters you don't know can be substituted with a question mark [?].

14.12 Goto Definition

Use this command to view the definition of a symbol.

**Available.** This command is available when a text document is open and active. You may also use the `<F12>` key.

**What's it for?** This command can give you rapid access to the definition of a symbol when you're programming in Imaging C. To do this, position the cursor within the symbol's name in the text document and then press `<F12>`. The source file will be opened in a separate text document window. The cursor will appear at the spot within the text where the symbol is defined – and the symbol name will be selected. Nothing will happen if OV100 does not find the source file. Just as when using the Find Symbol command, all you have to do is enter the letters the symbol name begins with – say, if you don’t know the precise name of the symbol or if the name of the symbol is extremely long. Continue pressing `<F12>` until the definition of the symbol you’re looking for is shown.
Where are symbol names searched for? Firstly, symbols are searched for among the symbols defined in the interpreter mode. After that, the active C module will be searched. Lastly, the predefined symbols in the 'Exported by Tool' range are searched.

Upper/lower-case, Wild cards. When making a search request upper or lower case is of no relevance. Any parts of a symbol's name you don’t know can be substituted with an asterisk [*]; letters you don’t know can be substituted with a question mark [?].

14.13 Quick Watch...

Use this command to determine the value of the selected expression or variable during an error search (i.e., debugging).

Available. This command is available when a text document is open and active. You may also use the <Shift+F9> keys.

Before you use this command open the source text of the Imaging C module or macro. Position the cursor on the variable whose value you wish to view. Use the Toggle Breakpoint command to set a breakpoint within that line. Then initiate the function containing the expression or variable in question: Imaging C functions of modules and programs are executed by you via a corresponding MAPI function – e.g., use the menu command of the MAPI function. Execute macros using the Run Macro command (in the Special menu) – or just press <F5> – or using the Single Step command (in the Special menu) – or just press <F10>. OV100 will move into the debug mode.

When is the debug mode active? As far as Imaging C programs are concerned, OV100 will switch over to the debug mode when it is executing a function and it encounters a breakpoint. With regard to macros, OV100 will also switch over to the debug mode if you execute the macro using the Single Step command - instead of the Run Macro command. You’ll know the debug mode has begun when the mouse cursor transforms into the shape of a hand.

What’s it for? When you execute the function or the macro the expression will be selected in the line containing the breakpoint. Now – to have a look at the value of the expression or variable use the Quick Watch command or simply press <Shift+F9>. You can then set another breakpoint and continue execution of the program by pressing <F10>. To have a look at the value of that expression simply press again <Shift+F9>. The above is how you can work through the source text of Imaging C programs and macros and be able to follow what values an expression occupies while the program is being executed. It’s how to find programming errors.

The specified expression and its current value

If the expression selected consists of a variable, the current value of this variable will be shown. If a value is undefined the following will appear: '???'. This will apply, e.g., to the value of a non-initialized pointer variable.
Add... Use the Add... button to add the expression to the Expression list in the Watch Variables dialog box. The Watch Variables dialog box will be opened if it wasn’t already. This dialog box is non-modal, meaning that it can remain open during debugging. This enables you to track a variable’s current value during the error search.

Command... Use the Command... button to compute the results of expressions and the values of variables. The Command dialog box will be opened.

What’s it for? This dialog box is for reading out expressions and variables of the ‘?’ operator – e.g., for converting a value into hexadecimal format.

Expression, Execute, Result
The Execute button will execute the Imaging C expression in the Expression field. Do not put a semicolon at the end of the expression. The value of the expression will be displayed in the Result field.

Example

<table>
<thead>
<tr>
<th>File types</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Expression</strong></td>
<td><strong>Result</strong></td>
</tr>
<tr>
<td>0xff</td>
<td>255</td>
</tr>
<tr>
<td>Hex (42)</td>
<td>2A</td>
</tr>
<tr>
<td>sin(PI/2)</td>
<td>1.0000000</td>
</tr>
<tr>
<td>Image[1].Protect</td>
<td>0</td>
</tr>
<tr>
<td>Image[2].Name</td>
<td>Aulabel</td>
</tr>
</tbody>
</table>
14.14 Watch Variables

Use this command to track the value of variables and expressions while searching for errors. You may also click on the Add button in the Quick Watch dialog box.

**How to add expressions in the dialog box.** Expressions and variables can be either entered directly into the Expression field in the dialog box – or added via the clipboard (copy/paste) from the source text when you’re looking for errors in this text. The easiest thing to do is to open the Watch Variables dialog box first and add the expression in the Quick Watch dialog box (using the Add button) to the Watch Variables dialog box.

This dialog box is non-modal, meaning it can be kept open during debugging. This enables you to track a variable’s current value during the debugging.

**Expression, Add, Expression list**
The Add button will evaluate the Imaging C expression entered into the Expression field and will add the expression and its value to the Expression list. Do not put a semicolon at the end of the expression. If a value is undefined the following will appear: ‘???.’ This will apply, e.g., to the value of a non-initialized pointer variable.
The Add button is only available if the Expression field contains an entry.

**When will values be calculated?** If the Watch Variables... dialog box is not closed and the debugging process continues, the values of the expressions in the Expression list field will be recalculated once execution is halted (due to a breakpoint or due to single-step execution).

**Delete.** Clicking on the Delete button will delete the selected entry in the Expression list field. This button is only available if the Expression list field contains an entry.

**Delete All.** Clicking on the Delete All button deletes all expressions from this list.

**Command...** Clicking on the Command... button will give you access to any expressions you might need. The Command dialog box will be opened.
14.15 Toggle Breakpoint

Use this command to set or delete a breakpoint in the active text document. You may also use the `<F9>` key.

**Available.** This command is available as long as a text document is opened and active.

In a text window, the symbol of a hand at the beginning of a line indicates a breakpoint.

**Definition.** When a command, for which a breakpoint has been defined, is executed the execution of the Imaging C program or module will be interrupted. The definition at the location of the breakpoint will be displayed and the **Debug** button bar will appear. The source text will appear in gray. The mouse cursor will be transformed into the shape of a hand. The breakpoint icon will be transformed into footprints.

In the **Debug** mode, this footprint icon will always appear in the line to be executed next. This enables you to either view the value of a variable or to continue execution in single steps.

**Possible breakpoint positions.** Breakpoints can be set in any line. A breakpoint can however be invalid. In this case, the breakpoint will be skipped and ignored. To locate invalid breakpoints have a look in the Edit Breakpoints dialog box: a minus sign denotes an invalid breakpoint.

**Valid breakpoints.** Breakpoints are valid where Imaging C statement are executed – e.g.:

- initializations
- if, else, do, while, for
- closing brackets `"}`
- lines ending in a semicolon if a statement comprises several lines

**Skipping breakpoints.** Here are the exceptions:

- pure definitions, such as the definition of a variable without a simultaneous initialization
- if an expression has not yet been translated by the Imaging C interpreter (not applicable to loaded C modules)
- the closing bracket of functions
- if lines are to be skipped upon execution of the program
- if you’ve selected a condition (in the Condition dialog box) whereby breakpoints are to be skipped

**Moving on to next breakpoint.** Using the Bookmark, Next command (in the Edit menu) or pressing `<F2>`, you’ll move on to the next breakpoint. To move to the previous breakpoint use the Bookmark, Previous command – or press `<Shift+F2>`.
Maintaining breakpoints after closing text(s). You do not lose breakpoints within a text as long as you don’t close OV100 – if there’s a source file. A source text document along with its breakpoints can be closed, and then the source file can be reopened, at a later time. Breakpoints will continue to be displayed. If you save the source text, breakpoints will not be saved. The next time you open OV100, all breakpoints will have been removed.

Debugging must be terminated before you can close OV100. If you cannot close the Imaging C program proper, then click on the Stop Execution button in the Debug button bar. You cannot terminate debugging by closing the source text’s document window, nor by turning ‘off’ the Debug button bar.

14.16 Edit Breakpoints

Use this command to edit the currently-set breakpoints. You may also simply press <Ctrl+b>.

Defining a breakpoint. Use the Toggle Breakpoints command to set a breakpoint.

What will happen at a breakpoint? When you execute an Imaging C program or module and come to a expression where a breakpoint has been defined, execution will be interrupted. The Debug button bar will be displayed, the mouse cursor will be transformed into the shape of a hand. The value of a variable can be tracked or execution can be continued in single steps.

Breakpoint list. The Breakpoint list displays all breakpoints defined using the Toggle Breakpoint command. Breakpoints can belong to varying source texts. Once you close a source text its breakpoints will remain undeleted only if the text has a source file.

The list shows the following on each breakpoint:

- breakpoint status
• path of the corresponding source file – if there is one – otherwise the name of the corresponding text window
• line number of the breakpoint within the text document.

<table>
<thead>
<tr>
<th>Status</th>
<th>Meaning: breakpoint is</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>valid</td>
</tr>
<tr>
<td>-</td>
<td>invalid</td>
</tr>
<tr>
<td>E</td>
<td>enabled (active)</td>
</tr>
<tr>
<td>D</td>
<td>disabled (not active)</td>
</tr>
</tbody>
</table>

**Delete All.** Click on the **Delete All** button to delete all breakpoints from the **Breakpoint list** and from source texts. Deletion is not reversible.

**Available.** The following buttons are only available if you have selected a breakpoint.

**Go To.** Click on the **Go To** button to go to the breakpoint (you’ve selected in the dialog box) in the source text. The text document will be opened if it had been closed. The line containing the breakpoint will be colored.

**Condition...** Click on the **Condition...** button to determine a condition under which a selected breakpoint is valid and when it is to be skipped.

**Example**

**Imaging C Code**

If a breakpoint is, e.g., to only be valid if the value of variable "i" is greater than 10, and the value of variable "j" is less than 10, the condition will have to be as follows:

(i>10) && (j<10)

**Disable.** Click on the **Disable** button to skip the selected breakpoint when executing the function. The breakpoint will be turned ‘off’ (i.e., disabled) in the text document. The status of the breakpoint in the Breakpoint list will go from E to D. As needed, you can reactivate the breakpoint.

**Enable.** The **Enable** button activates a deactivated breakpoint. The status of the breakpoint in the Breakpoint list will go from D to E.
Delete. Click on the **Delete** button to delete the break point selected from both the list and the text document.
15 OV100 Configuration

A special OV100 Configuration Software, ObsConfig, is provided for the configuration of the OV100 Imaging Station components: for the Illumination System MT10 and the motorized microscope components.

We recommend to use the OV100 Configuration Software also for the optical alignment of the arc burner and the illumination coupling to the microscope. Optical alignment with the OV100 Configuration Software is described in detail in Part B: Hardware Manual.

If your OV100 imaging station is equipped with a motorized Olympus BX or IX series microscope, please note that the configuration of the motorized microscope components is carried out within the OV100 imaging software as described in this chapter.

It is not possible to run the OV100 Configuration Software and the OV100 Imaging Software at the same time.

15.1 The Illumination System MT10

15.1.1 Configuring the Excitation Filters

The excitation: filters are mounted in the filter wheel of the Illumination System MT10 which is accessible via the filter flap on the right side of the illumination system housing. The filter wheel has 8 slots for different excitation filters and can be rotated so that each filter slot is accessible via the filter flap.

Filter exchange and configuration of the excitation filters with the OBS System Configuration software is described in detail in Chapter 7.3.3, Filter Exchange, of the Hardware Manual (Part B).
In brief, start the OV100 configuration software by clicking the **ObsConfig.exe** button and go to the **Illumination System → Excitation filter** page. A gray arrow in the list of program pages on the left hand side indicates the selection.

With the vertical slider bar shown in the dialog below you can rotate the filter wheel so that any of the 8 filter wheel positions of the MT10 light source is in the exchange position.

![Filter Wheel Dialog](image)

Open the filter flap on the right side of the illumination system’s housing. The flap has a magnetic closure, no tools are required for opening / closing. The filter slot 6 points to the flap opening in the example above. The filter position number is labeled right above the filter opening. In case an excitation filter in this filter slot has to be exchanged this can be done easily without any tools: the filter is clamped with a metal clip onto the filter wheel. Pull out the filter with your hand while taking care not to touch the filter’s glass surface.

---

**Tip:**

Only optical filters with a diameter of 25 mm may be inserted into the filter wheel. All filters purchased from Olympus BioSystems are suitable. There are templates on the inside of the filter flap, which can be used to check the appropriate size of an optical filter.

Insert the new excitation filter into the filter wheel simply by pushing it underneath the metal clips. This can also be done by hand. Again, be careful not to touch the filter’s glass surface.

**Tip:**

The correct orientation of the filter with respect to the direction of the light path is in most cases marked with a little arrow on the frame of the filter. The arrow has to point in direction of the light fiber.
**Excitation filter.** In the configuration dialog select the inserted excitation filter from the drop list of the current filter wheel position. The list offers many standard excitation filters provided by Olympus BioSystems. If the inserted excitation filter is a special filter not listed here or if you want to use a different name for the filter, you may just enter or change the filter name by clicking into the edit field and typing the desired filter name. The filter name defined here will appear on the respective switch button of the **Illumination system MT10** dialog in the OV100 Imaging Software (see Chapter 4.3, **Illumination Control**).

**Color.** The rectangular field adjacent to the filter name box shows the color of the switch button in the **Illumination system MT10** dialog that will move the respective filter into the illumination path. Each standard excitation filter, which can be selected from the drop list, has a predefined default color setting. You can change / define the switch button color by clicking on the color palette button to the right of the color field:

With the three slider bars you can adjust the **Hue**, the **Saturation** and the **Brightness** of the switch button color, respectively. The **Hue** values can be set in a range between −60 and 280. Following the conventions, 0 corresponds to red, 180 to cyan. Each value has a corresponding wavelength, indicated below the quadratic color field. The saturation and the intensity can be set between 0 and 1000 on an arbitrary scale. A **Brightness** of 0 results in the color black while a **Saturation** of 0 causes the color to be in a shade of gray. It is advisable to select the switch button color according to the filter properties, i.e. according to the effective sample illumination color.

**Example.** The selected GFP filter has a center transmission wavelength of 492 nm and thus transmits excitation light of turquoise color. Set the hue to a value of 185. The corresponding wavelength will be 492 nm and the switch button will be cyan.

Before the filter wheel can be rotated via software to another position to exchange / insert additional filters the filter flap needs to be closed. After closing the filter flap, the filter wheel is initialized (this takes approx. 5 sec). After this is done the green STATUS diode on the MT10 front is turned on. Then the filter wheel can be rotated into the next position for insertion / exchange of another filter as described above.
15.1.2 Burner Configuration

The **Illumination System > Burner** dialog is used for configuration and optical alignment of the burner after installation and/or exchange. This is described in detail in chapters 7.3.1 and 7.3.2 of the Hardware Manual (Part B).

**Display message.** You can activate a display warning message, which reminds you that the burner is still turned on, if you want to exit the OV100 Imaging software.

![Display warning message if user is logging out and burner / light source is still switched on]

15.1.3 Using MT10 without the Imaging Software

You can operate the Illumination System MT10 with the dialog box **Illumination System > Full control** without using the OV100 Imaging Software, that is, you can switch the burner on and off, change the excitation filter and the illumination intensity.

15.2 Configuring the Microscope

15.2.1 General Configuration

**Connectivity.** Select the serial port of the imaging PC that is connected with the universal microscope control box (UCB) from the shortlist.

**Lamp.** The transmission lamp can be switched on here by clicking on the button without having to start the OV100 software; the intensity can be set by moving the slider.

**Type.** Select the type of microscope from the shortlist.
15.2.2 Z-Drive Configuration

**Z-Drive available.** The check box needs to remain checked to keep the motorized Z-drive activated.

**Position box and range sliders.** The box displays the current Z-drive position. You can move the Z-drive by typing in a new position or by using the sliders. The Z-drive can be operated within the set limits (see below) with the **Limits range** slider. The dark gray bars to both sides of the **Full range** slider indicate the current range. If the **Full range** slider is moved beyond the limits the following message will appear:
Limits. The values may be optimized for each individual setup.

15.2.3 Configuration of the Objectives

Nosepiece. The check box needs to remain checked to keep the motorized objective revolver activated.

Objectives slider. You can use the slider to move any of the mounted objectives into position without having to start the OV100 software.

Magnification, Name, N.A., Correction. The values are set by default in OV100 and need not be changed.

Magnification Changer. This option is not available.
15.2.4 Configuration of the Fluorescence Filter Turret

**Fluorescence turret.** The **Turret (BX-RFAA)** needs to remain selected to be able to use it via the OV100 software.

**Filter cubes slider.** You can use the slider to move any of the mounted fluorescence filter cubes into position without having to start the OV100 software.

**Filter cube names.** Type in a name for each filter cube mounted or select a name from the shortlist.

15.2.5 Transmission Contrast Inserts

This feature is not available in the OV100.
15.2.6 Configuration of the Filters of a Filter Wheel

Filterwheel. Select **Observation (U-FWO)** if an observation filter wheel is available to be able to use it via the OV100 software.

Filters slider. You can use the slider to move any of the mounted filters into position without having to start the OV100 software.

Filter names. Type in a name for each filter mounted or select a name from the shortlist.

15.3 Definition of Image Types

The definition of image types corresponding to certain excitation wavelengths is important for the set-up of experiments with the Experiment Manager and for the display of images onscreen.

**Image Type.** The Experiment Manager will use the names given in the **Image Type** fields of the dialog box. Also, the resulting color bands of multi-color images will have the image type name.

**Illumination / Excitation filter.** An image type has always to be connected with one of the excitation filters defined in the **Illumination system** → **Excitation filter** page, see Chapter 15.2.1, *Configuring the Excitation Filters*. If, to follow the example in the screenshot, a RFP image icon is set in an experiment plan, the filter wheel automatically moves to position 3, which holds the corresponding filter named **BA570-625**, before the image acquisition starts during the execution of the experiment. An exception, obviously, is the image type **Transmission**, which does not rely on the fluorescence illumination system MT10 and any excitation filter.
Shutter. Image types based on the usage of the illumination system MT10 automatically result in the opening of the shutter before the image acquisition and its closing immediately afterwards. No selection has to be made in Shutter field to configure this. However, if the transmission light path of the microscope is equipped with a shutter it has to be selected from the pick list here in order to be synchronized with the camera exposure.

Filter cube. This column is active only if the microscope features a motorized fluorescence filter turret and it has been configured on page Microscope > Fluorescence turret. The fluorescence filter cube that matches the excitation filter of the image type has to be selected here so that it will be moved automatically into position for the image acquisition.

Fluorescence Color. The Fluorescence Color, which can be defined in the exact same way as described for Excitation filters (see Chapter 15.2.1, Configuring the Excitation Filters), determines the color of the image acquisition command icon in the Experiment Manager and, more important, the color with which images (or color channels) will be displayed onscreen. In the example a black-to-red color palette will be used for RFP images. If no color is selected a black&white (gray scale) display will be used.

15.4 Configuration of the Motorized Stage

Type. If the stage is properly connected, this will be stated as Connected in the box on the right side. Otherwise it will show Disconnected.

Speed. The settings are without use in OV100.
Calibration. The calibration of the origin of the stage coordinate system and limits can also be done in the OV100 software and is described in Chapter 4.5.3, Calibrating the Motorized Stage, in detail.

Position loop Z-device. The Z-Drive needs to remain selected so that the saved Z-position will be set in Experiment Plans.

### 15.5 Parfocality Correction of Objectives
The absolute position of the focal plane will always slightly differ from one objective to the next. The parfocality correction enables to automatically correct the individual offset. Once done, the objective can be switched without losing focus. This function is available in the OV100 software, not in the configuration software ObsConfig.exe.

1. Select **Acquire > Parfocality Correction (z)**... in the OV100 software. The **Parfocality Correction (z)** window will open.

2. Start the camera **Live** mode and focus the sample.

3. Press the **<<Read** button. The current z-drive position will be set in the **Position** box.

4. Click the next **Objective** button in the window **Parfocality Correction (z)**. The nosepiece will move this objective into position.

5. Focus again.

6. Press the **<<Read** button. The new z-drive position will be set in the **Position** box of the chosen objective.

7. Press **OK** when the correction is completed for all objectives.

The set differences in parfocality will be considered in experiments involving the switch of objectives.
16 Installing the OV100 Software

The OV100 Imaging Station will be delivered with the software installed. However, in case of software updates a new installation is necessary. Several administrative requirements have to be fulfilled for the system to function without problems.

What needs to be done.

1. Update the software: chapter 16.1

2. Update the hardware control: chapter 16.2

16.1 Updating the OV100 Software to Version 2.3

It is not necessary to uninstall the older version first! However, if you decide to uninstall the software, first start the OBS System Configuration software (ObsConfig.exe), go to the burner page and deactivate the option Display warning message if user is logging out and burner / light source is still switched on. Otherwise the un-installation will not be completed because an active dll file will be detected.

In that case also make a back-up copy of the ObsConfig.xml (in the cell^R folder).
1. Run the Setup.exe that is to be found on the OV100 2.3 CD. Use the existing OV100 folder on the hard disk (usually on the large D: partition) as destination for the installation.

2. Select Install software in the setup window.

3. Accept the License Agreement in the next window by clicking Yes.

4. Select OV100 in the Package Selection window and click Next >.

5. The setup routine will detect an existing OV100 program. You can choose between Update and New Installation. The Update installs new files and new versions of existing files but keeps unchanged files. The New Installation overwrites all existing files.

   If you select New Installation make a back-up copy of the software configuration file ObsConfig.xml that contains the information about excitation filters, image types etc. Thus you avoid having to go through parts of the configuration steps described in Chapter 15.2, The Illumination System MT10 anew.

6. Next, you have to fill in the customer information and confirm it.

7. In the Display Device Selection window you have two options:
   a. Single Screen (Windows Display).
      Use this option if the system features only one monitor.
      You can also use it in case of two monitors. The OV100 interface window can simply be dragged open to cover both screens. Together they behave as if they were one big screen. It is convenient, in this case, to place the Viewport in the second monitor while all control windows and the database remain in the first.
   b. Dual Screen (Dual Screen Win). If the system has two monitors, you may choose this option. The second monitor will then be filled out entirely and unchangeable with a second Viewport. The Viewport Manager allows switching focus from one to the other Viewport via mouse click.
8. Click Next > and decide if you want the Life Science Demo database from the second CD to be installed. Click Next >. This database has not changed in the new version and there is no need to install it anew.

9. In the following three windows choose the Destination Folders where the program files are to be written, image files are to be stored and image databases are to be saved. The setup will suggest the existing folders, probably D:\OV100, D:\OV100\Images and D:\Archive. It is most convenient to accept each time and simply continue with Next >.

10. In the next window, choose in which group program shortcuts for Start > Programs are to be added. The setup will suggest the folder OV100. It is most convenient to accept this and simply continue with Next >. The installation will be executed.

16.2 Updating the OV100 Hardware Control to Version 2.3

obsUpdate.exe

The cell™ System Coordinator in the imaging PC and the processors of the MT10 electronics run their own softwares (so-called firmware), which need to be updated for version 2.2 as well. Before doing this, switch on the MT10 and wait a few seconds for it to initialize. Then execute the obsUpdate.exe that can be found in the OV100 folder or under Start > Programs > OV100. The software checks the current firmware versions and opens a dialog box listing the current status. If the necessity of an update is indicated, click the Start Update button.

⚠ Make sure the MT10 illumination system is switched on.
Carefully read the warning message that appears and follow its instructions. Then click the **Start firmware update now** button. Do not use the computer or any of the peripherals for other tasks during the update process and do not unplug any connection cables.

The update lasts few minutes. Once it is completed, a window with the confirmation appears.

Switch off the MT10 illumination system after the update. Switch it on again after about 5 seconds. This is necessary for a complete reinitialization of the electronics. The illumination system will not be fully functional otherwise.

### 16.3 Configuring the OV100 Software

This is not necessary after an update to the new software version.

**Selecting the Camera**

1. Press `<F6>` (or select **Acquisition > Select Camera**) to open the **Set Input** dialog window.
2. Click the **New Channel** button to open the **Select Channel** dialog window.

3. Select the correct camera type. In case of a FView-II-T camera select OBS MegaView.

4. Exit with **OK**.

5. Calibrate the camera pixel size as described in Chapter 7.1, *Calibrate Images*.

### 16.4 Single-User Systems (Administrator Users)

If the system is used exclusively with Administrator rights (by one or several users) the following has to be observed.

By default the hard disk of the OV100 computer has two partitions:

- Partition C, the smaller one, contains the operating system, standard software and enough space to install additional programs.
- Partition D, the large one, contains the OV100 software and the folder Archive, where the databases are usually created.

The archival path can be changed in OV100 via **Special > Preferences > Database** in the field **Database files**. The path should not be set to C, otherwise memory problems will occur soon.
while using the system. The corresponding error message would be "Could not reserve enough memory". Make sure that the Temporary storage directory – to be set in the same dialog box – is on the same disk partition as the database directory, otherwise problems might arise at least in case of fast data acquisition.

### 16.5 Multi-User Systems

Note the following if user accounts in addition to the Administrator are to be installed on the OV100 computer.

**How to run OV100 in a "normal" user account under MSWindows XP**

1. Log on as Administrator

2. To create a new user using the Computer Management click Run... in the MSWindows Start menu. In the command line of the window that appears type `mmc c:\windows\system32\compmgmt.msc` and click OK.

3. Select Local Users and Groups ▶ Users and Action ▶ New User and fill the required fields. The new user is member of the group "Users" only.

4. Check that the newly created user has permission to write into the Archive directory where the databases are created when working with OV100. To check the security of a directory/file the Security tab in the Properties dialog (to be opened via right-click) has to be made visible.
   a. Start the Control Panel.
   b. Open Folder Options.
   c. Select the View tab and make sure that the option Use simple filesharing is NOT selected.

5. To check the security settings of the Archive use the Windows Explorer and do the following:
   a. Select the Archive directory.
   b. Right-click and select File ▶ Properties.
   c. Select the Security tab.
   d. Click Add, write the name of the new user under Enter the object names to select and exit with OK.

   The user is added to the list “Group or user names”.
   e. Check that the permissions for the user include: Modify, Read&Execute, List Folder Contents, Read and Write.
6. Check that the user has the permission to *Increase scheduling priority*.

7. Click **Run**... in the MSWindows Start menu. In the command line of the window that appears type `mmc c:\windows\system32\compmgmt.msc` and click **OK**.

8. Select **Local Policies** ▸ **User Rights Assignment**.

9. Select the item **Increase scheduling priority** on the list on the right side.

10. Select **Action** ▸ **Properties**.

11. Click **Add user or group**, write the name of the new user under **Enter the object names to select** and exit with **OK**.